Помогите изменить массив :Дан одномерный целочисленный массив mas?

Информатика | 5 - 9 классы

Помогите изменить массив :

Дан одномерный целочисленный массив mas.

Поменять местами два элемента массива с номерами k1 и k2, если оба этих элемента чётны.

Иначе – запросить у пользователя индекс ещё одного элемента k 3 и поменять его местами с первым элементом массива.

Вывести на экран итоговый массив в строку.

Массив :

Program pr1 ;

Var i, N, k1, k2, R : integer ; mas : array[1.

100]of integer ;

Begin Writeln ('Введите число элементов массива (N.

Ответить на вопрос
Ответы (1)
Соня214143322 28 янв. 2022 г., 04:01:44

Program pr1 ;

Var i, N, k1, k2, k3, R : integer ;

mas : array[1.

100]of integer ;

Begin

Writeln ('Введите число элементов массива (N.

Natasha7305 14 янв. 2022 г., 18:05:39 | 10 - 11 классы

1)Ввести массив A из 25 элементов?

1)Ввести массив A из 25 элементов.

Cформировать массив B из элементов массива А, кратных трем.

2)Даны массив A и B из n элементов.

Cформировать массив C из элементов массивов А и B, чередуя элементы.

Tplotitsin 10 янв. 2022 г., 22:54:45 | 10 - 11 классы

Заполнить массив из 20 элементов случайными числами, определить количество нулевых элементов массива?

Заполнить массив из 20 элементов случайными числами, определить количество нулевых элементов массива.

Evelina220400 21 янв. 2022 г., 10:29:33 | 10 - 11 классы

Помогите написать программу на паскале?

Помогите написать программу на паскале.

Дан двумерный массив размером 5 * 5 элементы массива вводятся пользователем вручную.

Составьте программу определения индексов минимального элемента этого массива.

Полученный результат вывести на экран.

Katykolomeiceva 1 апр. 2022 г., 03:07:07 | 5 - 9 классы

Массив - 10 элементов?

Массив - 10 элементов.

Задача :

Удвоить все четные элементы массива.

Все элементы с нечетным номером разделить на первый

элемент массива.

Срочно!

Завтра сдавать Дз.

Alicka762 30 янв. 2022 г., 23:07:20 | 10 - 11 классы

ПАСКАЛЬ?

ПАСКАЛЬ.

1)дан целочисленный массив из 30 элементов.

Элементы массива могут принимать целые значения от 0 до 1000.

Опишите на русском языке или на одном из языков программирования алгоритм, позволяющий найти среднее арифметическое нечетных трехзначных чисел, записанных в этом массиве.

Если ни одного такого числа нет, нужно вывести сообщение об этом.

2)дан целочисленный массив из 30 элементов.

Элементы массива могут принимать целые значения от 0 до 100.

Опишите на русском языке или на одном из языков программирования алгоритм, позволяющий найти и вывести произведение элементов массива, которые имеют четное значение и не оканчиваются на 0.

Alisho74 24 янв. 2022 г., 04:02:36 | 10 - 11 классы

Дан целочисленный массив из 40 элементов?

Дан целочисленный массив из 40 элементов.

Элементы массива могут принимать значения от - 10000 до 10000.

Написать алгоритм, который находит и выводит среднее арифметическое всех отрицательных элементов массива, оканчивающихся цифрой 7.

Гарантируется, что хотя бы один такой элемент в массиве есть.

Исходные данные объявлены так, как показано ниже.

Запрещается использовать переменные, не описанные ниже, но разрешается не использовать часть из них.

Const N = 40

var

a : array [1.

N] of integer ;

i, s, r, x : integer ;

sr : real ;

begin

for i : = 1 to N do readln (a[i]) ;

.

End. .

Anasavel 26 янв. 2022 г., 13:41:28 | 5 - 9 классы

Помогиие плз срочнокак называется номер элемента массива ?

Помогиие плз срочно

как называется номер элемента массива ?

Запишите объявления массивов по их характеристикам : целочисленный массив А[10], нумерация элементов начинается с 10

какие способы заполнения одномерного массива вы знаете?

Bunny4685 7 июн. 2022 г., 18:19:50 | 10 - 11 классы

Поменять местами минимальный и максимальный элементы массива размера 10 - C#?

Поменять местами минимальный и максимальный элементы массива размера 10 - C#.

1604ylia 27 янв. 2022 г., 15:55:30 | 1 - 4 классы

Задание 1Нахождение суммы (произведения, количества) элементов (обладающих заданным свойством)?

Задание 1

Нахождение суммы (произведения, количества) элементов (обладающих заданным свойством).

Заполнить одномерный массив А из 10 элементов случайными числами из отрезка [ - 20, 50].

Любую задачу на массив можно разбить на подзадачи.

Так, в данной задаче две подзадачи : 1.

Формирование массива ; 2.

Вывод массива на экран.

Поэтому программа решения данной задачи будет содержать процедуры : Vvod и Vivod.

Заметим, что заполнение и вывод на экран массива можно осуществить только поэлементно, то есть можно сначала присвоить значение первому элементу, затем второму и так далее.

Поскольку известно количество повторений команды ввода или вывода элементов массива, то при составлении программ на массивы используется цикл с параметром :

Program massiv1 ; Uses Crt ;

Type Mas = Array [1.

10] of Real ;

Var a : Mas ;

Procedure Vvod(Var x : Mas) ;

Var i : Integer ;

Begin For i : = 1 To 10 Do x[i] : = 30 * Random + 20 ; {(B - A) * random + A} End ;

Procedure Vivod(Var x : Mas) ; Var i : Integer ;

Begin For i : = 1 To 10 do Write(x[i] : 8 : 2)

End ;

Begin

Vvod(a) ; Vivod(a) ; End.

Дополним программу, решив задачу : найти среднее арифметическое положительных элементов массива процедурой :

Procedure sr_arif(Var x : Mas ; Var c : Real) ;

Var i, k : Integer ;

Begin c : = 0 ; k : = 0 ; For i : = 1 To 10 Do

If x[i]>0 Then Begin c : = c + x[i] ; k : = k + 1 End ; c : = c / k End ;

В программу добавятся строки :

sr_arif(a, s) ; Writeln('Среднее ариф.

Положительных элементов = ', s : 8 : 2) ; Модифицируйте программу для решения следующих задач :

1)Найти сумму элементов, кратных заданному числу ;

2)Найти количество отрицательных элементов.

3)Найти произведение элементов, меньших десяти.

Помогите пожалуйста : ))))))))) это 10 - 11 класс.

Alinakhabib 30 мар. 2022 г., 03:46:47 | 10 - 11 классы

Пожалуйста помогите, надо сдавать работу ?

Пожалуйста помогите, надо сдавать работу !

Написать программу на языке С + +

В заданном одномерном массиве поменять местами соседние элементы, стоящие на чётных местах, с элементами, стоящими на нечётных.

На этой странице находится вопрос Помогите изменить массив :Дан одномерный целочисленный массив mas?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.