Поменять местами минимальный и максимальный элементы массива размера 10 - C#?

Информатика | 10 - 11 классы

Поменять местами минимальный и максимальный элементы массива размера 10 - C#.

Ответить на вопрос
Ответы (1)
Юфо 7 июн. 2022 г., 18:19:54

Хром жрет переносы строк - сейчас поправлю \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \

using System ;

using System.

Collections.

Generic ;

using System.

Linq ;

using System.

Text ;

namespace replaceThis{

class main{ static void Main(){ int N = 10 ; int[] arr = new int[N] ; Random rand = new Random() ; Console.

Write("Исходный массив : ") ; for (int i = 0 ; i < N ; + + i){ arr[i] = rand.

Next(1, 9) ; Console.

Write("{0} ", arr[i]) ; } Console.

WriteLine("") ; int maxI, minI ; maxI = minI = 0 ; for(int i = 1 ; i< N ; + + i){ if (arr[maxI] < arr[i]) maxI = i ; if (arr[minI] > arr[i]) minI = i ; } int temp = arr[minI] ; arr[minI] = arr[maxI] ; arr[maxI] = temp ; Console.

WriteLine("Индекс максимального - {0}.

Индекс минимального - {1}.

", maxI, minI) ; Console.

Write("Измененный массив : ") ; for (int i = 0 ; i < N ; + + i) Console.

Write("{0} ", arr[i]) ; Console.

ReadKey() ; }

}

}.

0809annie 28 янв. 2022 г., 04:01:38 | 5 - 9 классы

Помогите изменить массив :Дан одномерный целочисленный массив mas?

Помогите изменить массив :

Дан одномерный целочисленный массив mas.

Поменять местами два элемента массива с номерами k1 и k2, если оба этих элемента чётны.

Иначе – запросить у пользователя индекс ещё одного элемента k 3 и поменять его местами с первым элементом массива.

Вывести на экран итоговый массив в строку.

Массив :

Program pr1 ;

Var i, N, k1, k2, R : integer ; mas : array[1.

100]of integer ;

Begin Writeln ('Введите число элементов массива (N.

Arin4eg 29 янв. 2022 г., 16:08:12 | 5 - 9 классы

ПОМОГИТЕ РЕШИТЬ В ПАСКАЛЕ?

ПОМОГИТЕ РЕШИТЬ В ПАСКАЛЕ!

Даны 2 массива сформированных случайным образом.

Составить программу которая находит сумму минимальных элементов массива

ЗАРАНЕЕ ОГРОМНОЕ СПАСИБО.

Evelina220400 21 янв. 2022 г., 10:29:33 | 10 - 11 классы

Помогите написать программу на паскале?

Помогите написать программу на паскале.

Дан двумерный массив размером 5 * 5 элементы массива вводятся пользователем вручную.

Составьте программу определения индексов минимального элемента этого массива.

Полученный результат вывести на экран.

2622002mailru 12 янв. 2022 г., 05:35:15 | 10 - 11 классы

Определить максимальный элемент в введённом с клавиатуры массиве в среде Delphi?

Определить максимальный элемент в введённом с клавиатуры массиве в среде Delphi.

Podnatalex1 5 янв. 2022 г., 15:09:48 | студенческий

Упорядочить по убыванию элементы целочисленного массива, расположенные после минимального числа - палиндрома?

Упорядочить по убыванию элементы целочисленного массива, расположенные после минимального числа - палиндрома.

Решить задачу в с + +.

Rusya545 21 мар. 2022 г., 00:09:50 | 10 - 11 классы

11 класс двумерные массивы В ПАСКАЛЕзаполнить матрицу из 8 строк и 5 столбцов случайными числами в интервале [ - 10 ; 10] и вывести ее на экран1?

11 класс двумерные массивы В ПАСКАЛЕ

заполнить матрицу из 8 строк и 5 столбцов случайными числами в интервале [ - 10 ; 10] и вывести ее на экран

1.

Удвоить все элементы и вывести на экран

2.

Найти максимальный и минимальный элемент ввода и вывести их на экран

3.

Вывести на экран строку сумма элементов которой максимальна.

AlinaMarks 27 апр. 2022 г., 10:14:26 | 5 - 9 классы

Задан целочисленный массив размера N?

Задан целочисленный массив размера N.

Определить число элементов в массиве кратных 2 (написать на pascal).

Аня10021 6 апр. 2022 г., 21:07:09 | 5 - 9 классы

Составьте программу, которая заполняет массив a[1?

Составьте программу, которая заполняет массив a[1.

10] случайными числами в диапазоне от 0 до 10, затем первый элемент меняет местами с максимальным элементом.

Выведите на экран исходный и полученный массивы.

Котик428 26 мар. 2022 г., 21:03:39 | 5 - 9 классы

Задан целочисленный одномерный массив с именем А, размером N с помощью датчика случайных чисел на промежутке (0 ; 10)?

Задан целочисленный одномерный массив с именем А, размером N с помощью датчика случайных чисел на промежутке (0 ; 10).

1. Найти минимальные элементы в массиве.

2. Найти порядковый номер этого элемента.

Alinakhabib 30 мар. 2022 г., 03:46:47 | 10 - 11 классы

Пожалуйста помогите, надо сдавать работу ?

Пожалуйста помогите, надо сдавать работу !

Написать программу на языке С + +

В заданном одномерном массиве поменять местами соседние элементы, стоящие на чётных местах, с элементами, стоящими на нечётных.

На этой странице находится вопрос Поменять местами минимальный и максимальный элементы массива размера 10 - C#?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.