Задание 1Нахождение суммы (произведения, количества) элементов (обладающих заданным свойством)?

Информатика | 1 - 4 классы

Задание 1

Нахождение суммы (произведения, количества) элементов (обладающих заданным свойством).

Заполнить одномерный массив А из 10 элементов случайными числами из отрезка [ - 20, 50].

Любую задачу на массив можно разбить на подзадачи.

Так, в данной задаче две подзадачи : 1.

Формирование массива ; 2.

Вывод массива на экран.

Поэтому программа решения данной задачи будет содержать процедуры : Vvod и Vivod.

Заметим, что заполнение и вывод на экран массива можно осуществить только поэлементно, то есть можно сначала присвоить значение первому элементу, затем второму и так далее.

Поскольку известно количество повторений команды ввода или вывода элементов массива, то при составлении программ на массивы используется цикл с параметром :

Program massiv1 ; Uses Crt ;

Type Mas = Array [1.

10] of Real ;

Var a : Mas ;

Procedure Vvod(Var x : Mas) ;

Var i : Integer ;

Begin For i : = 1 To 10 Do x[i] : = 30 * Random + 20 ; {(B - A) * random + A} End ;

Procedure Vivod(Var x : Mas) ; Var i : Integer ;

Begin For i : = 1 To 10 do Write(x[i] : 8 : 2)

End ;

Begin

Vvod(a) ; Vivod(a) ; End.

Дополним программу, решив задачу : найти среднее арифметическое положительных элементов массива процедурой :

Procedure sr_arif(Var x : Mas ; Var c : Real) ;

Var i, k : Integer ;

Begin c : = 0 ; k : = 0 ; For i : = 1 To 10 Do

If x[i]>0 Then Begin c : = c + x[i] ; k : = k + 1 End ; c : = c / k End ;

В программу добавятся строки :

sr_arif(a, s) ; Writeln('Среднее ариф.

Положительных элементов = ', s : 8 : 2) ; Модифицируйте программу для решения следующих задач :

1)Найти сумму элементов, кратных заданному числу ;

2)Найти количество отрицательных элементов.

3)Найти произведение элементов, меньших десяти.

Помогите пожалуйста : ))))))))) это 10 - 11 класс.

Ответить на вопрос
Ответы (1)
Ркокныррвенокн 27 янв. 2022 г., 15:55:32

1)

Program massiv1 ;

Uses Crt ;

Type Mas = Array [1.

10] of integer ;

Var a : Mas ; d, s : integer ;

Procedure Vvod(Var x : Mas) ;

Var i : Integer ;

Begin For i : = 1 To 10 Do

x[i] : = Random(50) ;

End ;

Procedure Vivod(Var x : Mas) ;

Var i : Integer ;

Begin

For i : = 1 To 10 do Write(x[i] : 4) ;

writeln ;

End ;

Procedure p1(Var x : Mas ; d : integer ; Var s : integer) ;

Var i : Integer ;

Begin

s : = 0 ;

For i : = 1 To 10 Do

If x[i] mod d = 0 Then s : = s + x[i] ;

End ;

Begin

Vvod(a) ;

Vivod(a) ;

write('d = ') ;

readln(d) ;

p1(a, d, s) ;

Writeln('Сумма элементов, кратных ', d, ' = ', s) ;

End.

Пример : 4 18 37 15 45 4 9 48 47 27

d = 3

Сумма элементов, кратных 3 = 162

2)

Program massiv2 ;

Uses Crt ;

Type Mas = Array [1.

10] of Real ;

Var a : Mas ; k : integer ;

Procedure Vvod(Var x : Mas) ;

Var i : Integer ;

Begin For i : = 1 To 10 Do

x[i] : = 30 * Random - 20 ; {(B - A) * random + A}

End ;

Procedure Vivod(Var x : Mas) ;

Var i : Integer ;

Begin

For i : = 1 To 10 do Write(x[i] : 8 : 2) ;

writeln ;

End ;

Procedure p2(Var x : Mas ; Var k : integer) ;

Var i : Integer ;

Begin

k : = 0 ;

For i : = 1 To 10 Do

If x[i].

Ichiruk 22 янв. 2022 г., 12:25:09 | 1 - 4 классы

Напишите программу для нахождения произведения положительных элементов массива из 10 элементов принадлежащих диапазону ( - 20 ; 20) Пожалуйста, это очень срочно?

Напишите программу для нахождения произведения положительных элементов массива из 10 элементов принадлежащих диапазону ( - 20 ; 20) Пожалуйста, это очень срочно!

0809annie 28 янв. 2022 г., 04:01:38 | 5 - 9 классы

Помогите изменить массив :Дан одномерный целочисленный массив mas?

Помогите изменить массив :

Дан одномерный целочисленный массив mas.

Поменять местами два элемента массива с номерами k1 и k2, если оба этих элемента чётны.

Иначе – запросить у пользователя индекс ещё одного элемента k 3 и поменять его местами с первым элементом массива.

Вывести на экран итоговый массив в строку.

Массив :

Program pr1 ;

Var i, N, k1, k2, R : integer ; mas : array[1.

100]of integer ;

Begin Writeln ('Введите число элементов массива (N.

Макс12908478985 26 янв. 2022 г., 16:34:04 | 10 - 11 классы

В одномерном массиве на 10 элементов, сформированном через генератор случайных чисел, найти средне - арифметическое среди наибольшего и наименьшего элемента массива?

В одномерном массиве на 10 элементов, сформированном через генератор случайных чисел, найти средне - арифметическое среди наибольшего и наименьшего элемента массива.

Начертить алгоритм и написать программу.

Evelina220400 21 янв. 2022 г., 10:29:33 | 10 - 11 классы

Помогите написать программу на паскале?

Помогите написать программу на паскале.

Дан двумерный массив размером 5 * 5 элементы массива вводятся пользователем вручную.

Составьте программу определения индексов минимального элемента этого массива.

Полученный результат вывести на экран.

Bal1 2 мар. 2022 г., 03:03:21 | 5 - 9 классы

СРОЧНОО 1?

СРОЧНОО 1.

НАйти произведение элементов с нечетными номерами(паскаль, массивы)

2.

Найти сумму четных элементов массива(паскаль, массивы).

SevenNationArmy 1 мар. 2022 г., 01:31:07 | 5 - 9 классы

Составьте программу ввода с клавиатуртуры элементов массива a [1?

Составьте программу ввода с клавиатуртуры элементов массива a [1.

10] и вывода на экран элементов с четными индексами.

Name505 11 мар. 2022 г., 14:58:45 | 10 - 11 классы

Программа на с + +Дан массив, состоящий из целых чисел?

Программа на с + +

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером).

Входные данные

Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные

Необходимо вывести единственное число - количество элементов массива, больших предыдущего.

Примеры

входные данные

5

1 2 3 4 5

выходные данные

4.

Dan34111 7 янв. 2022 г., 10:14:06 | студенческий

Помогите пожалуйста задание, надо код для паскали?

Помогите пожалуйста задание, надо код для паскали.

Дан одномерный массив, найти сумму всех четных элемент массива, кратных заданному числу.

Alisho74 24 янв. 2022 г., 04:02:36 | 10 - 11 классы

Дан целочисленный массив из 40 элементов?

Дан целочисленный массив из 40 элементов.

Элементы массива могут принимать значения от - 10000 до 10000.

Написать алгоритм, который находит и выводит среднее арифметическое всех отрицательных элементов массива, оканчивающихся цифрой 7.

Гарантируется, что хотя бы один такой элемент в массиве есть.

Исходные данные объявлены так, как показано ниже.

Запрещается использовать переменные, не описанные ниже, но разрешается не использовать часть из них.

Const N = 40

var

a : array [1.

N] of integer ;

i, s, r, x : integer ;

sr : real ;

begin

for i : = 1 to N do readln (a[i]) ;

.

End. .

Miramironova001 19 февр. 2022 г., 05:27:01 | 5 - 9 классы

Помогите срочно?

Помогите срочно!

Нужно набрать программу, которая выводит 2 массива и находит сумму элементов этих массивов.

«Даны два многомерных массива.

Найти их разность С = А - В.

».

Перед вами страница с вопросом Задание 1Нахождение суммы (произведения, количества) элементов (обладающих заданным свойством)?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 1 - 4 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.