ПАСКАЛЬ?

Информатика | 10 - 11 классы

ПАСКАЛЬ.

1)дан целочисленный массив из 30 элементов.

Элементы массива могут принимать целые значения от 0 до 1000.

Опишите на русском языке или на одном из языков программирования алгоритм, позволяющий найти среднее арифметическое нечетных трехзначных чисел, записанных в этом массиве.

Если ни одного такого числа нет, нужно вывести сообщение об этом.

2)дан целочисленный массив из 30 элементов.

Элементы массива могут принимать целые значения от 0 до 100.

Опишите на русском языке или на одном из языков программирования алгоритм, позволяющий найти и вывести произведение элементов массива, которые имеют четное значение и не оканчиваются на 0.

Ответить на вопрос
Ответы (1)
Gman97 30 янв. 2022 г., 23:07:21

Задача сделана на языке паскаль, при помощи PaskalPlus

Оформление сделана как студенческой задачи

Если есть вопросы пиши в личку.

0809annie 28 янв. 2022 г., 04:01:38 | 5 - 9 классы

Помогите изменить массив :Дан одномерный целочисленный массив mas?

Помогите изменить массив :

Дан одномерный целочисленный массив mas.

Поменять местами два элемента массива с номерами k1 и k2, если оба этих элемента чётны.

Иначе – запросить у пользователя индекс ещё одного элемента k 3 и поменять его местами с первым элементом массива.

Вывести на экран итоговый массив в строку.

Массив :

Program pr1 ;

Var i, N, k1, k2, R : integer ; mas : array[1.

100]of integer ;

Begin Writeln ('Введите число элементов массива (N.

Макс12908478985 26 янв. 2022 г., 16:34:04 | 10 - 11 классы

В одномерном массиве на 10 элементов, сформированном через генератор случайных чисел, найти средне - арифметическое среди наибольшего и наименьшего элемента массива?

В одномерном массиве на 10 элементов, сформированном через генератор случайных чисел, найти средне - арифметическое среди наибольшего и наименьшего элемента массива.

Начертить алгоритм и написать программу.

Bal1 2 мар. 2022 г., 03:03:21 | 5 - 9 классы

СРОЧНОО 1?

СРОЧНОО 1.

НАйти произведение элементов с нечетными номерами(паскаль, массивы)

2.

Найти сумму четных элементов массива(паскаль, массивы).

Hjbfjhfbjh 6 февр. 2022 г., 02:20:51 | 5 - 9 классы

Тема массивы?

Тема массивы.

Язык - pascal abc.

Нужна программа по принципу работы Вводим 10 элементов массива - выводятся нечетные.

Katykolomeiceva 1 апр. 2022 г., 03:07:07 | 5 - 9 классы

Массив - 10 элементов?

Массив - 10 элементов.

Задача :

Удвоить все четные элементы массива.

Все элементы с нечетным номером разделить на первый

элемент массива.

Срочно!

Завтра сдавать Дз.

Name505 11 мар. 2022 г., 14:58:45 | 10 - 11 классы

Программа на с + +Дан массив, состоящий из целых чисел?

Программа на с + +

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером).

Входные данные

Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные

Необходимо вывести единственное число - количество элементов массива, больших предыдущего.

Примеры

входные данные

5

1 2 3 4 5

выходные данные

4.

Кнопа20010502 19 апр. 2022 г., 09:46:31 | 10 - 11 классы

Массив состоит из 40 элементов?

Массив состоит из 40 элементов.

Значение от 1 до 10000.

Найти и вывести наименьший элемент массива, восьмеричная запись которого заканчивается 7.

Если такого элемента нет, вывести 0.

Zhuldizbest 24 мая 2022 г., 16:37:06 | студенческий

Сформировать массив а[n][m] из случайно заданных элементов, значения которых находятся на отрезке [ - 10000 ; 10000]?

Сформировать массив а[n][m] из случайно заданных элементов, значения которых находятся на отрезке [ - 10000 ; 10000].

Вывести число элементов с наименьшим и наибольшим значениями этого массива / помогите, пожалуйста.

Alisho74 24 янв. 2022 г., 04:02:36 | 10 - 11 классы

Дан целочисленный массив из 40 элементов?

Дан целочисленный массив из 40 элементов.

Элементы массива могут принимать значения от - 10000 до 10000.

Написать алгоритм, который находит и выводит среднее арифметическое всех отрицательных элементов массива, оканчивающихся цифрой 7.

Гарантируется, что хотя бы один такой элемент в массиве есть.

Исходные данные объявлены так, как показано ниже.

Запрещается использовать переменные, не описанные ниже, но разрешается не использовать часть из них.

Const N = 40

var

a : array [1.

N] of integer ;

i, s, r, x : integer ;

sr : real ;

begin

for i : = 1 to N do readln (a[i]) ;

.

End. .

7vlad2003 14 мар. 2022 г., 04:43:21 | 5 - 9 классы

Даю 25 баллов?

Даю 25 баллов!

Дан массив из 20 вещественных чисел.

Найти среднее арифметическое чисел элементов массива и заменить на него максимум и минимум элементов массива стоящие на местах кратных 5.

На этой странице сайта размещен вопрос ПАСКАЛЬ? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 10 - 11 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.