Помогите с Pascal пожалуйста Задача : Подсчитать кол - во вхождений заданной буквы в строку и заменить эту букву на другую?

Информатика | 10 - 11 классы

Помогите с Pascal пожалуйста Задача : Подсчитать кол - во вхождений заданной буквы в строку и заменить эту букву на другую.

Ответить на вопрос
Ответы (1)
Zigan 25 мая 2020 г., 10:45:51

Var s : string ; c1, c2 : char ; i, k : integer ;

begin Write('Введите строку : ') ; Readln(s) ; Write('Введите букву, которую надо найти : ') ; Readln(c1) ; Write('Введите букву, на которую надо заменить : ') ; Readln(c2) ; k : = 0 ; for i : = 1 to Length(s) do if s[i] = c1 then begin Inc(k) ; s[i] : = c2 end ; Writeln('Найдено вхождений и сделано замен : ', k) ; Writeln('Строка после замен : ') ; Writeln(s)

end.

Тестовое решение :

Введите строку : А роза упала на лапу Азора

Введите букву, которую надо найти : а

Введите букву, на которую надо заменить : о

Найдено вхождений и сделано замен : 6

Строка после замен :

А розо уполо но лопу Азоро.

Rudywade 13 янв. 2020 г., 14:58:31 | 10 - 11 классы

Заданы М строк слов, которые вводятся с клавиатуры?

Заданы М строк слов, которые вводятся с клавиатуры.

Подсчитать количество гласных букв в каждой из заданных строк.

Chichigina77 15 янв. 2020 г., 20:08:04 | 10 - 11 классы

Дана строка символов?

Дана строка символов.

Замените в строке все маленькие буквы на одноименные большие буквы.

Надо решить в Pascal.

Net.

Nfd 1 июн. 2020 г., 18:38:57 | 10 - 11 классы

Помогите пожалуйста составить программу на ''Pascal ABC'') Дана строка, содержащая текст на русском языке, и некоторая буква?

Помогите пожалуйста составить программу на ''Pascal ABC'') Дана строка, содержащая текст на русском языке, и некоторая буква.

Подсчитать, сколько слов начинается с указанной буквы.

Richgirl 19 мар. 2020 г., 01:23:26 | 5 - 9 классы

ПОМОГИТЕ ПОЖАЛУЙСТА?

ПОМОГИТЕ ПОЖАЛУЙСТА!

1) В заданном предложении заменить все гласные на парные гласные.

2) В заданном предложении подсчитать количество букв С.

Заменить все буквы С на Ш.

Подсчитать сколько раз в полученном предложении встречается буква Ш.

Dilya03276 24 февр. 2020 г., 02:57:42 | 5 - 9 классы

Дана строка заканчивающаяся точкой подсчитать сколько в строке слов с тремя буквами PASCAL?

Дана строка заканчивающаяся точкой подсчитать сколько в строке слов с тремя буквами PASCAL.

Lyudamininaa 19 июн. 2020 г., 02:48:51 | 10 - 11 классы

Дана строка символов?

Дана строка символов.

Подсчитать количество вхождений буквы "n".

Рокера 11 февр. 2020 г., 20:01:37 | 10 - 11 классы

Вывести из строки гласные буквы и их кол - вона языке Pascal, прошу помогите ?

Вывести из строки гласные буквы и их кол - во

на языке Pascal, прошу помогите !

Natali85271 13 апр. 2020 г., 04:29:03 | 10 - 11 классы

Pascal В заданном тексте подсчитайте общее количество букв "х" и "у"?

Pascal В заданном тексте подсчитайте общее количество букв "х" и "у".

Massimka 26 авг. 2020 г., 14:18:08 | 10 - 11 классы

Определить сколько слов в заданной строке начинаются на букву "а"?

Определить сколько слов в заданной строке начинаются на букву "а".

Pascal.

Paqrf 30 дек. 2020 г., 23:57:29 | 10 - 11 классы

На строки :Дан текст из букв и цифр?

На строки :

Дан текст из букв и цифр.

Заменить все нули в тексте на букву А, а все единицы на букву М.

Подсчитать число замен.

Pascal ABC.

Net type const.

На этой странице находится вопрос Помогите с Pascal пожалуйста Задача : Подсчитать кол - во вхождений заданной буквы в строку и заменить эту букву на другую?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.