Определить сколько слов в заданной строке начинаются на букву "а"?

Информатика | 10 - 11 классы

Определить сколько слов в заданной строке начинаются на букву "а".

Pascal.

Ответить на вопрос
Ответы (1)
Bodnachukyu 26 авг. 2020 г., 14:18:14

Program Project1 ;

uses crt ;

const / / Разделители слов.

D = ['.

', ', ', ' : ', ' ; ', '!

', '?

', ' - ', ' ', #9, #10, #13] ;

var S : String ; i, Cnt, Len : Integer ;

begin repeat Writeln('Задайте строку : ') ; Readln(S) ; Len : = Length(S) ; Cnt : = 0 ; for i : = 1 to Len do begin / / Пропускаем разделители.

If S[i] in D then Continue ; / / Отслеживаем начало слова.

If (i = 1) or (S[i - 1] in D) then begin if S[i] in ['a', 'A'] then Cnt : = Cnt + 1 ; end ; end ; Writeln('В заданной строке найдено ', Cnt, ' слов, ') ; Readln(S) ; until S < ; > ; '' ;

end.

Hazeevar79 20 дек. 2020 г., 12:41:51 | 10 - 11 классы

С клавиатуры вводится строка?

С клавиатуры вводится строка.

С новой строки вводится буква.

Составьте программу подсчета количества заданных букв в заданной строке.

Определить, является ли длина введенного слова числом, кратным трем.

Определить, заканчивается ли введенное слово гласной буквой.

Chichigina77 15 янв. 2020 г., 20:08:04 | 10 - 11 классы

Дана строка символов?

Дана строка символов.

Замените в строке все маленькие буквы на одноименные большие буквы.

Надо решить в Pascal.

Net.

Nfd 1 июн. 2020 г., 18:38:57 | 10 - 11 классы

Помогите пожалуйста составить программу на ''Pascal ABC'') Дана строка, содержащая текст на русском языке, и некоторая буква?

Помогите пожалуйста составить программу на ''Pascal ABC'') Дана строка, содержащая текст на русском языке, и некоторая буква.

Подсчитать, сколько слов начинается с указанной буквы.

Irka7 25 мая 2020 г., 10:45:46 | 10 - 11 классы

Помогите с Pascal пожалуйста Задача : Подсчитать кол - во вхождений заданной буквы в строку и заменить эту букву на другую?

Помогите с Pascal пожалуйста Задача : Подсчитать кол - во вхождений заданной буквы в строку и заменить эту букву на другую.

Dilya03276 24 февр. 2020 г., 02:57:42 | 5 - 9 классы

Дана строка заканчивающаяся точкой подсчитать сколько в строке слов с тремя буквами PASCAL?

Дана строка заканчивающаяся точкой подсчитать сколько в строке слов с тремя буквами PASCAL.

Merey0283 22 июл. 2020 г., 03:16:01 | 10 - 11 классы

Pascal?

Pascal.

1. Определить количество слов в предложении.

2. Определить какая буква в строке встречается чаще : первая или последняя.

3. Написать программу меняющую слово "Петр" на "Иван".

Kristi1617 20 июл. 2020 г., 11:55:34 | 5 - 9 классы

Дана строка символов состоящая из букв и цифр определить сумму всех цифр в этой сроке и количество прописных заглавных букв на PASCAL?

Дана строка символов состоящая из букв и цифр определить сумму всех цифр в этой сроке и количество прописных заглавных букв на PASCAL.

Ли4ли5я 9 сент. 2020 г., 19:24:06 | 5 - 9 классы

Дана строка S?

Дана строка S.

Вывести эту строку, так чтобы каждое слово начиналось с заглавной буквы.

Veronika123000 27 апр. 2020 г., 23:41:03 | 10 - 11 классы

Pascal?

Pascal.

Напишите программу , которая из заданной строки удаляет числа.

Alinakhudiakova 16 дек. 2020 г., 18:14:48 | 1 - 4 классы

Задать произвольный текст, сколько слов в тексте начинаются на букву "а"?

Задать произвольный текст, сколько слов в тексте начинаются на букву "а".

На этой странице вы найдете ответ на вопрос Определить сколько слов в заданной строке начинаются на букву "а"?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 10 - 11 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.