На строки :Дан текст из букв и цифр?

Информатика | 10 - 11 классы

На строки :

Дан текст из букв и цифр.

Заменить все нули в тексте на букву А, а все единицы на букву М.

Подсчитать число замен.

Pascal ABC.

Net type const.

Ответить на вопрос
Ответы (1)
МистрКРуТой88 30 дек. 2020 г., 23:57:31

1)

begin var s1 : = ReadlnString('Текст : ') ; Writeln('k = ', s1.

Where(c - >Pos(c, '01')>0).

Count) ; var s2 : = s1.

Select(c - >c = '0'?

'A' : c).

Select(c - >c = '1'?

'M' : c) ; s2.

Println ;

end.

Пример :

Текст : Текст с 1 и 0 : 110 + 101 = 1011

k = 12

Текст с M и A : MMA + MAM = MAMM

2)

var s1, s2 : string ;

i, k : integer ;

begin

writeln('Введите текст : ') ;

readln(s1) ;

k : = 0 ;

s2 : = '' ;

for i : = 1 to length(s1) do

if s1[i] = '0' then begin s2 : = s2 + 'A' ; k : = k + 1 ; end else if s1[i] = '1' then begin s2 : = s2 + 'M' ; k : = k + 1 ; end else s2 : = s2 + s1[i] ;

writeln(s2) ;

writeln('k = ', k) ;

end.

Пример :

Введите текст :

Текст с 1 и 0 : 110 + 101 = 1011

Текст с M и A : MMA + MAM = MAMM

k = 12.

Chichigina77 15 янв. 2020 г., 20:08:04 | 10 - 11 классы

Дана строка символов?

Дана строка символов.

Замените в строке все маленькие буквы на одноименные большие буквы.

Надо решить в Pascal.

Net.

Nfd 1 июн. 2020 г., 18:38:57 | 10 - 11 классы

Помогите пожалуйста составить программу на ''Pascal ABC'') Дана строка, содержащая текст на русском языке, и некоторая буква?

Помогите пожалуйста составить программу на ''Pascal ABC'') Дана строка, содержащая текст на русском языке, и некоторая буква.

Подсчитать, сколько слов начинается с указанной буквы.

Irka7 25 мая 2020 г., 10:45:46 | 10 - 11 классы

Помогите с Pascal пожалуйста Задача : Подсчитать кол - во вхождений заданной буквы в строку и заменить эту букву на другую?

Помогите с Pascal пожалуйста Задача : Подсчитать кол - во вхождений заданной буквы в строку и заменить эту букву на другую.

Dilya03276 24 февр. 2020 г., 02:57:42 | 5 - 9 классы

Дана строка заканчивающаяся точкой подсчитать сколько в строке слов с тремя буквами PASCAL?

Дана строка заканчивающаяся точкой подсчитать сколько в строке слов с тремя буквами PASCAL.

Lyudamininaa 19 июн. 2020 г., 02:48:51 | 10 - 11 классы

Дана строка символов?

Дана строка символов.

Подсчитать количество вхождений буквы "n".

Кицюня095 23 янв. 2020 г., 07:00:42 | 5 - 9 классы

Дана строка?

Дана строка.

Подсчитать количество слов , начинающихся с буквы Б.

Natali85271 13 апр. 2020 г., 04:29:03 | 10 - 11 классы

Pascal В заданном тексте подсчитайте общее количество букв "х" и "у"?

Pascal В заданном тексте подсчитайте общее количество букв "х" и "у".

ВЫПУСКНИК2014 10 янв. 2020 г., 18:59:00 | 10 - 11 классы

ПРОГРАММА НА PASCAL?

ПРОГРАММА НА PASCAL!

Распечатать введенную строку, удалив из нее символы, не являющиеся буквами и цифрами, и ЗАМЕНИВ КАЖДУЮ ЦИФРУ НА " * * ".

Gelys 13 нояб. 2020 г., 18:21:24 | 10 - 11 классы

Помогите, Pascal ABC?

Помогите, Pascal ABC.

Дано предложение.

Если в этом предложении первая буква встречается более 3 раз, заменить её на восклицательный знак.

Исходный текст задать самостоятельно таким образом, чтобы решалась задача.

Kristi1617 20 июл. 2020 г., 11:55:34 | 5 - 9 классы

Дана строка символов состоящая из букв и цифр определить сумму всех цифр в этой сроке и количество прописных заглавных букв на PASCAL?

Дана строка символов состоящая из букв и цифр определить сумму всех цифр в этой сроке и количество прописных заглавных букв на PASCAL.

На этой странице сайта вы найдете ответы на вопрос На строки :Дан текст из букв и цифр?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.