ПОМОГИТЕ ПОЖАЛУЙСТА?

Информатика | 5 - 9 классы

ПОМОГИТЕ ПОЖАЛУЙСТА!

1) В заданном предложении заменить все гласные на парные гласные.

2) В заданном предложении подсчитать количество букв С.

Заменить все буквы С на Ш.

Подсчитать сколько раз в полученном предложении встречается буква Ш.

Ответить на вопрос
Ответы (1)
Школоло1313 19 мар. 2020 г., 01:23:32

Program test ;

var n : string ; i, c, sh : integer ;

begin

readln(n) ;

for i : = 1 to length(n) do

begin

if (n[i] = 'б') or (n[i] = 'Б') then n[i] : = 'п' ; if (n[i] = 'п') or (n[i] = 'П') then n[i] : = 'б' ;

if (n[i] = 'в') or (n[i] = 'Б') then n[i] : = 'ф' ; if (n[i] = 'ф') or (n[i] = 'Ф') then n[i] : = 'в' ;

if (n[i] = 'г') or (n[i] = 'Б') then n[i] : = 'к' ; if (n[i] = 'к') or (n[i] = 'К') then n[i] : = 'г' ;

if (n[i] = 'д') or (n[i] = 'Б') then n[i] : = 'т' ; if (n[i] = 'т') or (n[i] = 'Т') then n[i] : = 'д' ;

if (n[i] = 'ж') or (n[i] = 'Б') then n[i] : = 'ш' ; if (n[i] = 'ш') or (n[i] = 'Ш') then n[i] : = 'ж' ;

if (n[i] = 'з') or (n[i] = 'Б') then n[i] : = 'с' ; if (n[i] = 'с') or (n[i] = 'С') then n[i] : = 'з' ;

end ;

writeln('1) ', n) ;

for i : = 1 to length(n) do

begin

if (n[i] = 'С') or (n[i] = 'с')

then begin inc(c) ; n[i] : = 'ш' ; end ;

if (n[i] = 'Ш') or (n[i] = 'ш')

then

inc(sh) ;

end ;

writeln('2) ', n) ;

writeln('В предложении буква "Ш" встречаеться : ', sh) ;

writeln('В предложении буква "C" встречаеться : ', c) ;

end.

Валюшк 7 июн. 2020 г., 06:01:43 | 10 - 11 классы

Строки в Си Задан текст, состоящий из заглавных латинских букв и цифр?

Строки в Си Задан текст, состоящий из заглавных латинских букв и цифр.

Определите, сколько раз каждая гласная буква встречается в тексте.

Результат распечатайте в виде : Буква – количество.

(гласные : A, E, I, O, U).

Rudywade 13 янв. 2020 г., 14:58:31 | 10 - 11 классы

Заданы М строк слов, которые вводятся с клавиатуры?

Заданы М строк слов, которые вводятся с клавиатуры.

Подсчитать количество гласных букв в каждой из заданных строк.

Irka7 25 мая 2020 г., 10:45:46 | 10 - 11 классы

Помогите с Pascal пожалуйста Задача : Подсчитать кол - во вхождений заданной буквы в строку и заменить эту букву на другую?

Помогите с Pascal пожалуйста Задача : Подсчитать кол - во вхождений заданной буквы в строку и заменить эту букву на другую.

Natali85271 13 апр. 2020 г., 04:29:03 | 10 - 11 классы

Pascal В заданном тексте подсчитайте общее количество букв "х" и "у"?

Pascal В заданном тексте подсчитайте общее количество букв "х" и "у".

Abok99 1 июл. 2020 г., 10:37:36 | 5 - 9 классы

В слове аэрография все гласные буквы кроме первой заменили на те что идут в слове перед ними?

В слове аэрография все гласные буквы кроме первой заменили на те что идут в слове перед ними.

Какие буквы присутствуют в полученной последовательности букв.

Dum4evaludmila 4 мая 2020 г., 17:07:56 | 5 - 9 классы

В слове ГЕОЛОГИЯ все гласные буквы заменили на те, что идут в слове перед ними?

В слове ГЕОЛОГИЯ все гласные буквы заменили на те, что идут в слове перед ними.

Какие буквы присутствуют в полученной последовательности букв?

А)Е Б) О В) Ю.

Gelys 13 нояб. 2020 г., 18:21:24 | 10 - 11 классы

Помогите, Pascal ABC?

Помогите, Pascal ABC.

Дано предложение.

Если в этом предложении первая буква встречается более 3 раз, заменить её на восклицательный знак.

Исходный текст задать самостоятельно таким образом, чтобы решалась задача.

Sesnation 19 авг. 2020 г., 09:04:03 | 5 - 9 классы

Дано предложение - строка?

Дано предложение - строка.

Подсчитать количество слов, начинающихся с буквы 'а' написать программу на паскале.

Sanek05121983r 13 июн. 2020 г., 14:49:04 | 10 - 11 классы

Подсчитайте количество гласных латинских букв в строке?

Подсчитайте количество гласных латинских букв в строке.

(ПАСКАЛЬ).

Lyubakhlapova 27 нояб. 2020 г., 02:55:34 | 10 - 11 классы

Дано слово?

Дано слово.

Подсчитать сколько раз в нем встречается заданная буква qbasic.

На этой странице находится вопрос ПОМОГИТЕ ПОЖАЛУЙСТА?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.