Написать программу, которая определяет в одномерном массиве, заполненном случайным образом, количество элементов, значения которых меньше числа, введенного с клавиатуры?

Информатика | 5 - 9 классы

Написать программу, которая определяет в одномерном массиве, заполненном случайным образом, количество элементов, значения которых меньше числа, введенного с клавиатуры.

Если есть, то вывести эти элементы.

Ответить на вопрос
Ответы (1)
Naumova2001 21 нояб. 2020 г., 08:01:06

Program n1 ;

const n = 17 ;

var a : array[1.

N] of integer ;

i, c, k : integer ;

begin

randomize ;

write('введите число : ') ;

readln(c) ;

writeln('массив : ') ;

for i : = 1 to n do

begin a[i] : = random(50) ; write(a[i], ' ') ;

end ;

writeln ;

writeln('эл.

Которые меньше ', c) ;

for i : = 1 to n do if a[i].

Ghjkknbbv 21 дек. 2020 г., 09:04:39 | 1 - 4 классы

Одномерные массивы : Составить программу, заполняющую массив, состоящий из N элементов, введенными с клавиатуры целыми числами?

Одномерные массивы : Составить программу, заполняющую массив, состоящий из N элементов, введенными с клавиатуры целыми числами.

Требуется вывести массив на экран компьютера и найти индекс последнего по счету в массиве отрицательного элемента.

Menshih5536 22 июн. 2020 г., 02:08:28 | 5 - 9 классы

Напишите программу, которая случайным образом заполняет массив из 10 элементов целыми числами из диапазона [ - 6 ; 9]?

Напишите программу, которая случайным образом заполняет массив из 10 элементов целыми числами из диапазона [ - 6 ; 9].

И вывести все элементы массива на экран.

МаксимШевкунов2004 18 нояб. 2020 г., 09:05:52 | 10 - 11 классы

1. Заполнить массив с клавиатуры целыми числами?

1. Заполнить массив с клавиатуры целыми числами.

Вывести элементы этого массива на экран.

(Добавить комментарии) 2.

Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса).

3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива.

4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных.

5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных.

6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами.

Вывести на экран исходный и новый массив.

7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы.

8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

Kitaev97 27 февр. 2020 г., 01:05:08 | 5 - 9 классы

Написать программу в ПАСКАЛЕ, которая проверяет, есть ли во введенном с клавиатуры массиве элементы с одинаковым значением?

Написать программу в ПАСКАЛЕ, которая проверяет, есть ли во введенном с клавиатуры массиве элементы с одинаковым значением.

Пожалуйста подробно.

Лерик22 22 апр. 2020 г., 08:40:45 | 5 - 9 классы

Составить программу заполнения массива из 7 элементов числами от 1 до 30 с помощью генератора случайных чисел и вывести значения его элементов в строку через запятую?

Составить программу заполнения массива из 7 элементов числами от 1 до 30 с помощью генератора случайных чисел и вывести значения его элементов в строку через запятую.

Александр19833891 9 апр. 2020 г., 02:33:53 | 5 - 9 классы

1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N?

1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N.

Отрицательные элементы заменить на N.

Измененный массив вывести на экран одной строкой.

2. Дан одномерный массив размерностью N, заполненный случайными числами в интервале от - 15 до 20.

Вывести на экран значения элементов массива, абсолютное значение которых > ; 10.

3. Дан одномерный массив размерностью N, заполненный случайными числами.

Каждый третий элемент массива возвести в квадрат, если элемент отрицательный.

Измененный массив вывести на экран.

Vikavizsa 13 сент. 2020 г., 02:37:20 | 10 - 11 классы

В одномерном массиве от нуля до 10 заполненный случайным образом найти среднее арифметическое элементов массива?

В одномерном массиве от нуля до 10 заполненный случайным образом найти среднее арифметическое элементов массива.

Fair5 14 апр. 2020 г., 22:31:32 | 1 - 4 классы

Написать программу которая определяет количество положительных элементов одномерного массива?

Написать программу которая определяет количество положительных элементов одномерного массива.

Артёмкекеенреое 10 окт. 2020 г., 17:45:30 | 5 - 9 классы

В одномерном массиве из 20 элементов заполненном случайными числами из интервала [ - 10, 10] определить количество отрицательных элементов?

В одномерном массиве из 20 элементов заполненном случайными числами из интервала [ - 10, 10] определить количество отрицательных элементов.

Серебристый1 11 нояб. 2020 г., 05:25:18 | 10 - 11 классы

1)Дан целочисленный массив с числом элементов N?

1)Дан целочисленный массив с числом элементов N.

Вывести все его нечётные элементы и сумму.

2)Написать программу, которая проверяет, есть ли во введённом с клавиатуры массиве элементы с одинаковым значением.

СРОЧНО!

Вопрос Написать программу, которая определяет в одномерном массиве, заполненном случайным образом, количество элементов, значения которых меньше числа, введенного с клавиатуры?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.