Найти все трехзначные числа, квадраты которых оканчивается тремя одинаковыми числами отличными от нуля?

Информатика | 5 - 9 классы

Найти все трехзначные числа, квадраты которых оканчивается тремя одинаковыми числами отличными от нуля.

На паскале

Числа должны выводиться сразу в квадрате, а не (100, 200, 300, 400).

Ответить на вопрос
Ответы (1)
Ines007 8 мая 2024 г., 06:55:58

Программа :

var i, a, a1, a2, a3 : integer ;

begin

for i : = 101 to 999 do begin a : = i * i ; a1 : = a mod 1000 div 100 ; a2 : = a mod 100 div 10 ; a3 : = a mod 10 ; if (a1 = a2)and(a2 = a3)and(a1< ; > ; 0) then writeln(i, ' ', a) ; end ;

end.

Результат :

462 213444

538 289444

962 925444.

Гргргр 7 янв. 2024 г., 23:19:23 | 5 - 9 классы

Даны два целых числа A и B (A < ; B)?

Даны два целых числа A и B (A < ; B).

Найти сумму квадратов всех целых чисел от A до B включительно.

В питоне.

Omertys 17 мар. 2024 г., 03:27:25 | студенческий

Пожалуйста помогитеНапишите программу, которая запрашивает двацелых числа x и y, после чего вычисляет и выводитзначение x в степени y на пайтоне?

Пожалуйста помогите

Напишите программу, которая запрашивает два

целых числа x и y, после чего вычисляет и выводит

значение x в степени y на пайтоне.

EvdokiomovaUna 16 янв. 2024 г., 19:45:36 | 5 - 9 классы

Дана часть программы?

Дана часть программы.

Определите число, которое выведет программа на экран.

Максим01022004 26 февр. 2024 г., 11:43:24 | 5 - 9 классы

Даны три числа?

Даны три числа.

Написать yes если среди них есть одинаковые на языке питон и чтобы было по простому, БЛАГОДАРЮ.

Dmitrievvanya 4 мар. 2024 г., 04:10:55 | 10 - 11 классы

ПОМОГИТЕ СДЕЛАТЬ В ПИТОНЕ?

ПОМОГИТЕ СДЕЛАТЬ В ПИТОНЕ!

Дано неотрицательное число N - количество элементов массива (N< ; = 100)

Заполнить массив из N элементов первыми натуральными трехзначными числами, произведение цифр которых есть трехзначное число.

Madinabajramova 8 мар. 2024 г., 21:23:13 | 5 - 9 классы

Решите пожалуйста?

Решите пожалуйста!

Автомат получает на вход пятизначное десятичное число.

По полученному числу строится новое десятичное число по следующим правилам.

1. Вычисляются два числа – сумма первой, третьей и пятой цифр и сумма второй и четвёртой цифр заданного числа.

2. Полученные два числа записываются друг за другом в порядке неубывания (без разделителей).

Пример.

Исходное число : 15177.

Поразрядные суммы : 9, 12.

Результат : 912.

Определите, сколько из приведённых ниже чисел могут получиться

в результате работы автомата.

1220 120 210 2012 1920 2019 212 2919 1929

В ответе запишите только количество чисел.

Mvvluba 31 мар. 2024 г., 18:07:05 | 5 - 9 классы

На вході маємо 2 числа програма порівнює їх між собою і виводить результат у вигляді True або False?

На вході маємо 2 числа програма порівнює їх між собою і виводить результат у вигляді True або False.

Порівняння відбувається за такими пунктами :

1) Чи ці числа рівні ;

2) чи числа нерівні ;

3) чи перше число більше за друге ;

4) чи друге число більше за перше ;

5) чи квадрат першого числа більший за квадрат другого числа ;

6) чи сума цих чисел більша за їх добуток.

ДашаВова 30 янв. 2024 г., 05:19:22 | 5 - 9 классы

Даны три числа a, b, с?

Даны три числа a, b, с.

Найти их среднее арифметическое(сумму чисел разделить на их количество).

С клавиатуры вводится число a, количество килобайт.

Переведите это число в байты, биты и мегабайты и выведите значения на экран.

​.

Damiryusiev 29 февр. 2024 г., 03:38:40 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Определить каких цифр в данном числе больше четных или нечетных.

Через Паскаль ЛЕГКИЙ ВАРИАНД С While.

Noritsyna0703 28 мар. 2024 г., 03:51:03 | студенческий

Тактовая частота процессора — это : максимальное количество бит информации, которые процессор может обрабатывать и передавать одновременно ; количество тактов, выполняемых процессором в единицу времен?

Тактовая частота процессора — это : максимальное количество бит информации, которые процессор может обрабатывать и передавать одновременно ; количество тактов, выполняемых процессором в единицу времени ; скорость обмена информацией между процессором и устройством ввода / вывода ; число двоичных операций, совершаемых процессором в единицу времени ; ​.

Sany18 3 апр. 2024 г., 01:56:08 | 5 - 9 классы

Факториал числа 10 и числа 17​?

Факториал числа 10 и числа 17​.

На этой странице сайта вы найдете ответы на вопрос Найти все трехзначные числа, квадраты которых оканчивается тремя одинаковыми числами отличными от нуля?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.