1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N?

Информатика | 5 - 9 классы

1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N.

Отрицательные элементы заменить на N.

Измененный массив вывести на экран одной строкой.

2. Дан одномерный массив размерностью N, заполненный случайными числами в интервале от - 15 до 20.

Вывести на экран значения элементов массива, абсолютное значение которых > ; 10.

3. Дан одномерный массив размерностью N, заполненный случайными числами.

Каждый третий элемент массива возвести в квадрат, если элемент отрицательный.

Измененный массив вывести на экран.

Ответить на вопрос
Ответы (1)
Naziko100496 9 апр. 2020 г., 02:33:59

1) var

a : array[1.

10]of integer ;

i, n, k : integer ; begin readln(n) ; for i : = 1 to 10 do begin read(a[i]) ; if a[i]< ; 0 then a[i] : = n ; end ; for i : = 1 to 10 do write(a[i], ' ') ; end.

2)

var

a : array[1.

999999]of integer ;

i, n, s : integer ; begin readln(n) ; for i : = 1 to n do begin a[i] : = random(36) - 15 ; write(a[i], ' ') ; end ; writeln ; for i : = 1 to n do if abs(a[i])> ; 10 then write(a[i], ' ') ; end.

3) var

a : array[1.

999999]of integer ;

i, n, s : integer ; begin readln(n) ; for i : = 1 to n do begin a[i] : = random(36) - 15 ; write(a[i], ' ') ; end ; writeln ; for i : = 1 to n do begin if i mod 3 = 0 then if a[i]< ; 0 then a[i] : = a[i] * a[i] * a[i] ; write(a[i], ' ') ; end ; end.

Клиндух 22 июн. 2020 г., 23:53:09 | 5 - 9 классы

Дан массив из 10 элементов, заполненный случайным образом?

Дан массив из 10 элементов, заполненный случайным образом.

Значения элементов от - 50 до 50.

Вывести на экран элементы массива, оканчивающиеся на 4 или 8.

Ghjkknbbv 21 дек. 2020 г., 09:04:39 | 1 - 4 классы

Одномерные массивы : Составить программу, заполняющую массив, состоящий из N элементов, введенными с клавиатуры целыми числами?

Одномерные массивы : Составить программу, заполняющую массив, состоящий из N элементов, введенными с клавиатуры целыми числами.

Требуется вывести массив на экран компьютера и найти индекс последнего по счету в массиве отрицательного элемента.

Hatashaprudhik 4 авг. 2020 г., 01:37:25 | 10 - 11 классы

Дан целочисленный одномерный массив из n - элементов?

Дан целочисленный одномерный массив из n - элементов.

Вывести на экран четные элементы стоящие на нечетных массивов через паскаль.

Ulia026 12 мар. 2020 г., 22:54:59 | 10 - 11 классы

Помогите пожалуйста?

Помогите пожалуйста.

Срочно нужно.

Дан одномерный массив, состоящий из 10 элементов.

Вывести на экран в строчку.

Поменять местами значения от 6 - 10 элементов массива элементов массива и снова вывести на экран!

Diana98n 10 июн. 2020 г., 21:33:13 | 10 - 11 классы

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс?

В одномерном массиве А(10) найти максимальный элемент, вывести его значение и индекс.

Заменить все четные элементы значением максимального элемента.

Полученный массив вывести на экран.

Angelina2016a 26 авг. 2020 г., 04:14:27 | 10 - 11 классы

В одномерном массиве найти максимальный элемент заменить на 0 , и вывести массив на экран?

В одномерном массиве найти максимальный элемент заменить на 0 , и вывести массив на экран.

На паскале.

Sveti4ek2000 8 дек. 2020 г., 16:46:15 | 10 - 11 классы

Создать одномерный массив, содержащий целые числа?

Создать одномерный массив, содержащий целые числа.

Элементы массива вводятся с клавиатуры.

Найти номера всех элементов больше 5 (вывести их на экран), если таких нет, то сообщить об этом.

Конфетка26 8 сент. 2020 г., 22:59:33 | 5 - 9 классы

1)Создать и напечатать одномерный массив случайными числами от 0 до 15 и вывести на экран те из них, которые больше 10?

1)Создать и напечатать одномерный массив случайными числами от 0 до 15 и вывести на экран те из них, которые больше 10.

2) Создать и напечатать одномерный массив случайными числами от 0 до 10 и вывести на экран те из них, которые больше последнего элемента массива.

3)Создать и напечатать одномерный массив случайными числами от 0 до 9.

Если есть в нем элементы, равные 3, то заменить их последующими числами.

Помогите, пожалуйста.

Shippi546 9 дек. 2020 г., 21:39:18 | 5 - 9 классы

1)В одноменрном массиве найит разность наибольшего и наименьшего элемента?

1)В одноменрном массиве найит разность наибольшего и наименьшего элемента.

2)Дан одномерный массив.

Вывести на экран числа >5

3)В одномерном массиве найти произведение нулевых элементов.

Gubin20011 21 нояб. 2020 г., 08:01:00 | 5 - 9 классы

Написать программу, которая определяет в одномерном массиве, заполненном случайным образом, количество элементов, значения которых меньше числа, введенного с клавиатуры?

Написать программу, которая определяет в одномерном массиве, заполненном случайным образом, количество элементов, значения которых меньше числа, введенного с клавиатуры.

Если есть, то вывести эти элементы.

На этой странице сайта вы найдете ответы на вопрос 1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.