Помогите с задачкой в паскале ( не сложная)?

Информатика | 10 - 11 классы

Помогите с задачкой в паскале ( не сложная)!

Задача : каждые 3 часа моллюск делится на 2, сколько их будет через N часов?

Обратите внимание на то, что число часов может и с остатком делится на 3!

Program molusk ; var s, n, i : integer ; begin ; n : = 1 ; Writeln('введите время ') ; readln(s) ; for i : = 1 to s do if(s mod 3) = 3 then n : = s : 3 ; writeln(n) ; end.

Где у меня тут ошибка, думаю скорее всего в (.

Mod. ).

Ответить на вопрос
Ответы (1)
Nastya161604 19 дек. 2020 г., 10:26:18

Ошибка мягко говоря везде.

Все перепутано и никаккой логики

var molusk, n, i : integer ;

begin ; molusk : = 1 ; Writeln('введите время ') ; readln(n) ; for i : = 1 to n do if i mod 3 = 0 then molusk : = 2 * molusk ; writeln(molusk) ;

end.

Polinka275 15 мая 2020 г., 04:26:59 | 5 - 9 классы

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число?

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число.

Program cisla ; var a : integer ; begin writeln('Введите число, ') ; readln(a) ; if a mod 2 = 0 then writeln('Число четное') ; else writeln('Число нечетное') ; readln end.

Antonharitonov0 28 янв. 2020 г., 01:46:32 | 10 - 11 классы

Помогите Срочно?

Помогите Срочно!

Чему будет равен результат выполнения программы, если ввести значения для a = 2468?

Program c22 ; var a, b : integer ; k : integer ; begin K : = 0 ; readln(a) ; while (a< ; > ; 0) do begin b : = a mod 10 ; if b mod 2 = 0 then inc(k) ; a : = a div 10 ; end ; writeln(k) ; end.

A) 9 Б)3 В)0 Г)4.

Irinakirikovam 24 мая 2020 г., 05:37:28 | 5 - 9 классы

Program yura ; var x : integer ; begin writeln ('Напишите x') ; readln (x) ; if x mod 2 = 0 then writeln(x * x + (sqrt2)) else writeln(x * x * x + x) end?

Program yura ; var x : integer ; begin writeln ('Напишите x') ; readln (x) ; if x mod 2 = 0 then writeln(x * x + (sqrt2)) else writeln(x * x * x + x) end.

В чём ошибка?

Дулетол3 31 окт. 2020 г., 09:13:31 | 5 - 9 классы

Перевод программы с Pascal на QBasic Решение : var a, s : integer ; begin s : = 0 ; readln(a) ; while a< ; > ; 0 do begin if (a mod 6 = 0) and (a mod 10 = 4) then s : = s + a ; readln(a) ; end ; w?

Перевод программы с Pascal на QBasic Решение : var a, s : integer ; begin s : = 0 ; readln(a) ; while a< ; > ; 0 do begin if (a mod 6 = 0) and (a mod 10 = 4) then s : = s + a ; readln(a) ; end ; writeln(s) end.

Temnikt2998 26 июн. 2020 г., 06:21:35 | 5 - 9 классы

Почему не работает запись в Паскале по задаче : Написать программу, подсчитывающую количество четных цифр, которые делятся на 4, в числе?

Почему не работает запись в Паскале по задаче : Написать программу, подсчитывающую количество четных цифр, которые делятся на 4, в числе.

Вот запись, исправьте пожалуйста : program chisla ; var a, b, k : integer ; begin k : = 0 ; writeln('Введите число') ; readln(a) ; repeat if(a mod 2 = 0)and(a mod 4 = 0)then k : = k + 1 until a = 0 ; writeln('Количество чисел = ', k) end.

Akmalrakhmonov 15 янв. 2020 г., 00:20:20 | 5 - 9 классы

Program z_1 ; var i : integer ; s : string ; begin s : = 1 ; for i : = 10 to 99 do if (i mod 13 = 0) and (i mod 2 < ; > ; 0) then s : = s * i ; writeln('proizvedenie = ', s) ; readln ; end?

Program z_1 ; var i : integer ; s : string ; begin s : = 1 ; for i : = 10 to 99 do if (i mod 13 = 0) and (i mod 2 < ; > ; 0) then s : = s * i ; writeln('proizvedenie = ', s) ; readln ; end.

Дана задача объяснить три строки : s : = 1 ; for i : = 10 to 99 do if (i mod 13 = 0) and (i mod 2 < ; > ; 0) then.

Sonyatoropchina 24 мар. 2020 г., 12:41:52 | 10 - 11 классы

Исправить ошибку Помогите исправить ошибку в программе Вот задание : Разработать программу поиска и печати всех чисел - близнецов, принадлежащих заданному диапазону [N, M ]?

Исправить ошибку Помогите исправить ошибку в программе Вот задание : Разработать программу поиска и печати всех чисел - близнецов, принадлежащих заданному диапазону [N, M ].

Вот программа : program yyy ; function prost(var x : integer) : boolean ; var k, i : integer ; t : boolean ; begin t : = true ; k : = 0 ; for i : = 1 to x do begin if x mod i = 0 then k : = k + 1 ; end ; if k = 2 then t : = true else t : = false ; prost : = t end ; var n, m, i : integer ; begin writeln('1') ; readln(n) ; writeln('2') ; readln(m) ; for i : = n to m - 1 do begin if prost(i) and prost(i + 2) then writeln(i , (i + 2)) ; end ; end.

Galina50286 13 дек. 2020 г., 16:46:22 | 5 - 9 классы

Найдите ошибки в следующих программах :Program int_r ;Var a, x : integer ;b, c : real ;Begina : = 10 ;b : = 5?

Найдите ошибки в следующих программах :

Program int_r ;

Var a, x : integer ;

b, c : real ;

Begin

a : = 10 ;

b : = 5.

2 ;

x : = b div 2 ;

c : = round(x) ;

End.

Program int_r1 ;

Var a, c : integer ;

b, d : real ;

Begin

a : = 25 ;

b : = a / 2 ;

c : = sqr(a) ;

d : = a mod 10 ;

End.

Laime2014 27 сент. 2020 г., 07:49:39 | 5 - 9 классы

Паскаль?

Паскаль.

Написать программу которая, используя признаки делимости, определяет, делится ли число на 6.

Var a, c : integer ; begin cls ; randomize ; a : = random (99999 + 99999 + 1) - 99999 ; writeln ( 'исходное числo : ', a) ; if (a mod 10) mod 2 = 0 then writeln (' делится на 2') else writeln (' не делится на 2') ; while a< ; > ; 0 do begin c : = c + (a mod 10) ; a : = a div 10 ; end ; if c mod 3 = 0 then writeln (' число делится на 3') else writeln (' число не делится на 3') ; end.

Признак делимости на 6 - это значит, что число делится на 2 и 3.

Я сделала по отдельности на 2 и 3 ( программа выше).

А как это обобщить?

Ряжка 25 дек. 2020 г., 18:21:48 | 5 - 9 классы

Помогите пожалуйста, cрочно?

Помогите пожалуйста, cрочно!

Составить блок - схему.

Program primer6 ;

uses crt ;

x : integer ;

begin

clrscr ;

readln(x) ;

if x mod 2 = 0 then writeln ('да')

else writeln ('нет')

end.

Вы зашли на страницу вопроса Помогите с задачкой в паскале ( не сложная)?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.