Program yura ; var x : integer ; begin writeln ('Напишите x') ; readln (x) ; if x mod 2 = 0 then writeln(x * x + (sqrt2)) else writeln(x * x * x + x) end?

Информатика | 5 - 9 классы

Program yura ; var x : integer ; begin writeln ('Напишите x') ; readln (x) ; if x mod 2 = 0 then writeln(x * x + (sqrt2)) else writeln(x * x * x + x) end.

В чём ошибка?

Ответить на вопрос
Ответы (1)
Baha4 24 мая 2020 г., 05:37:30

Не очень понятно задание.

На сколько могу судить ошибки нет.

Polinka275 15 мая 2020 г., 04:26:59 | 5 - 9 классы

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число?

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число.

Program cisla ; var a : integer ; begin writeln('Введите число, ') ; readln(a) ; if a mod 2 = 0 then writeln('Число четное') ; else writeln('Число нечетное') ; readln end.

Brozhkodima 23 авг. 2020 г., 21:04:09 | 5 - 9 классы

Program Dr ; Var a, b, c, D, x1, x2 : Real ; Begin D : = b * b - 4 * a * c ; Read(a, b, c) ; if D< ; 0 Then Writeln ('корней нет') else if D = 0 then begin x : = - b / (2 * a) : Writeln(x) ; end ; e?

Program Dr ; Var a, b, c, D, x1, x2 : Real ; Begin D : = b * b - 4 * a * c ; Read(a, b, c) ; if D< ; 0 Then Writeln ('корней нет') else if D = 0 then begin x : = - b / (2 * a) : Writeln(x) ; end ; else begin x1 : = ( - b - SQRT(D)) / (2 * a) ; x2 : = ( - b + SQRT(D)) / (2 * a) ; Writeln(x1) ; Writeln(x2) ; end ; end.

Program1.

Pas(9) : Встречено 'else', а ожидался оператор.

В чём проблема?

Дулетол3 31 окт. 2020 г., 09:13:31 | 5 - 9 классы

Перевод программы с Pascal на QBasic Решение : var a, s : integer ; begin s : = 0 ; readln(a) ; while a< ; > ; 0 do begin if (a mod 6 = 0) and (a mod 10 = 4) then s : = s + a ; readln(a) ; end ; w?

Перевод программы с Pascal на QBasic Решение : var a, s : integer ; begin s : = 0 ; readln(a) ; while a< ; > ; 0 do begin if (a mod 6 = 0) and (a mod 10 = 4) then s : = s + a ; readln(a) ; end ; writeln(s) end.

Nikitaroker555 26 апр. 2020 г., 21:22:54 | 5 - 9 классы

Где здесь ошибка ?

Где здесь ошибка ?

Program Ylia ; var A, B, C : real ; Begin Readln (a, b) if a> ; b ; C1 = ab else C2 = a / b ; writeln (c) ; end.

Оорр1 6 мар. 2020 г., 00:18:39 | 5 - 9 классы

Program mimi ;var a, b : integer ;beginreadln (a) ;if 99 < ; a < ; thenwriteln('Неверно')elseif a> ; 999 thenwriteln('Неверно')elsewriten('Верно')end?

Program mimi ;

var a, b : integer ;

begin

readln (a) ;

if 99 < ; a < ; then

writeln('Неверно')

else

if a> ; 999 then

writeln('Неверно')

else

writen('Верно')

end.

Выдаёт : pas(5) : Ожидался идентификатор

Что не так?

Sonyatoropchina 24 мар. 2020 г., 12:41:52 | 10 - 11 классы

Исправить ошибку Помогите исправить ошибку в программе Вот задание : Разработать программу поиска и печати всех чисел - близнецов, принадлежащих заданному диапазону [N, M ]?

Исправить ошибку Помогите исправить ошибку в программе Вот задание : Разработать программу поиска и печати всех чисел - близнецов, принадлежащих заданному диапазону [N, M ].

Вот программа : program yyy ; function prost(var x : integer) : boolean ; var k, i : integer ; t : boolean ; begin t : = true ; k : = 0 ; for i : = 1 to x do begin if x mod i = 0 then k : = k + 1 ; end ; if k = 2 then t : = true else t : = false ; prost : = t end ; var n, m, i : integer ; begin writeln('1') ; readln(n) ; writeln('2') ; readln(m) ; for i : = n to m - 1 do begin if prost(i) and prost(i + 2) then writeln(i , (i + 2)) ; end ; end.

AvEnTaDoR005 25 сент. 2020 г., 12:43:18 | 5 - 9 классы

Program TELESHOP ; var x : real ; begin writeln ('?

Program TELESHOP ; var x : real ; begin writeln ('.

') ; write ('.

') ; write ('.

') ; readln (x) ; if x< ; = 1 then begin if x = 1 then begin writeln ('.

') ; writeln ('.

') ; end else begin writeln ('.

') ; end ; * else begin writeln ('.

') ; end end.

* - место ошибки.

"встречено 'else', а ожидалось оператор" Вопрос : в чем ошибка?

Ksusha1037 25 июн. 2020 г., 21:03:03 | 5 - 9 классы

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 ?

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 then begin writeln ('утро') ; readln (d) ; if a = 12 then begin writeln ('день') ; end ; if a = 16 then begin writeln ('вечер') ; / / / if a = 21 then begin writeln ('ночь') ; / / / end ; end ;

111worni111wormi 5 нояб. 2020 г., 04:49:38 | 5 - 9 классы

Что не так в программе в конце должен вывести какое число больше program primer ; var a, b : integer ; wrateln : ; readln (a, b) ; if a> ; b then writeln(a) else writeln (b) ; end?

Что не так в программе в конце должен вывести какое число больше program primer ; var a, b : integer ; wrateln : ; readln (a, b) ; if a> ; b then writeln(a) else writeln (b) ; end.

Ряжка 25 дек. 2020 г., 18:21:48 | 5 - 9 классы

Помогите пожалуйста, cрочно?

Помогите пожалуйста, cрочно!

Составить блок - схему.

Program primer6 ;

uses crt ;

x : integer ;

begin

clrscr ;

readln(x) ;

if x mod 2 = 0 then writeln ('да')

else writeln ('нет')

end.

На этой странице находится вопрос Program yura ; var x : integer ; begin writeln ('Напишите x') ; readln (x) ; if x mod 2 = 0 then writeln(x * x + (sqrt2)) else writeln(x * x * x + x) end?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.