Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число?

Информатика | 5 - 9 классы

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число.

Program cisla ; var a : integer ; begin writeln('Введите число, ') ; readln(a) ; if a mod 2 = 0 then writeln('Число четное') ; else writeln('Число нечетное') ; readln end.

Ответить на вопрос
Ответы (1)
Lukianovsasha 15 мая 2020 г., 04:27:05

Перед "else" не нужна точка я запятой ; ).

Вадун 28 июн. 2020 г., 12:52:55 | 10 - 11 классы

Составьте программу, проверяющую, что введенное число является четным или нечетнымНа языке VBA?

Составьте программу, проверяющую, что введенное число является четным или нечетным

На языке VBA.

Авророчка 26 июл. 2020 г., 19:58:22 | 10 - 11 классы

Составьте программу, проверяющую, что введенное число является четным или нечетным?

Составьте программу, проверяющую, что введенное число является четным или нечетным.

На VBA.

Irinakirikovam 24 мая 2020 г., 05:37:28 | 5 - 9 классы

Program yura ; var x : integer ; begin writeln ('Напишите x') ; readln (x) ; if x mod 2 = 0 then writeln(x * x + (sqrt2)) else writeln(x * x * x + x) end?

Program yura ; var x : integer ; begin writeln ('Напишите x') ; readln (x) ; if x mod 2 = 0 then writeln(x * x + (sqrt2)) else writeln(x * x * x + x) end.

В чём ошибка?

Kuchzipa 23 окт. 2020 г., 16:37:43 | 10 - 11 классы

HELP ME, PLEASE 1) Составьте программу, проверяющую, является ли введенное число четным или нечетным?

HELP ME, PLEASE 1) Составьте программу, проверяющую, является ли введенное число четным или нечетным.

Поля121 2 нояб. 2020 г., 07:51:49 | 5 - 9 классы

1. Составьте программу, проверяющую, что введенное число является четным или нечетным 2?

1. Составьте программу, проверяющую, что введенное число является четным или нечетным 2.

Составьте программу, проверяющую, что введенное число делится без остатка на 3.

Dim0nGreshNIK 12 февр. 2020 г., 18:24:08 | 10 - 11 классы

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и b хотя бы одно четное?

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и b хотя бы одно четное.

Была написана следующая программа : var a, b : integer ; begin readln(a, b) ; a : = a mod 2 ; if a > ; 0 then b : = b mod 2 ; if b > ; 0 then writeln ('четных чисел нет') else writeln ('четное число есть') ; end.

Известно, что программа написана с ошибками.

Последовательно выполните три задания : укажите, как, по вашему мнению, нужно доработать программу (не используя слож - ные условия), чтобы не было случаев ее неправильной работы ;

ProstoKostik 30 окт. 2020 г., 15:00:04 | 5 - 9 классы

Пожалуйста, помогите?

Пожалуйста, помогите!

Нужно срочно!

Написать программу проверяющую, принадлежит ли число введенное с данной клавиатуры промежутку от 0 до 5.

(0 ; 5)

(а> ; 0) and (a< ; 5) Начало : Program.

Var. begin Writeln('.

') readln(.

) if .

Then.

Else.

; wriyeln('.

') ; end.

Temnikt2998 26 июн. 2020 г., 06:21:35 | 5 - 9 классы

Почему не работает запись в Паскале по задаче : Написать программу, подсчитывающую количество четных цифр, которые делятся на 4, в числе?

Почему не работает запись в Паскале по задаче : Написать программу, подсчитывающую количество четных цифр, которые делятся на 4, в числе.

Вот запись, исправьте пожалуйста : program chisla ; var a, b, k : integer ; begin k : = 0 ; writeln('Введите число') ; readln(a) ; repeat if(a mod 2 = 0)and(a mod 4 = 0)then k : = k + 1 until a = 0 ; writeln('Количество чисел = ', k) end.

Оорр1 6 мар. 2020 г., 00:18:39 | 5 - 9 классы

Program mimi ;var a, b : integer ;beginreadln (a) ;if 99 < ; a < ; thenwriteln('Неверно')elseif a> ; 999 thenwriteln('Неверно')elsewriten('Верно')end?

Program mimi ;

var a, b : integer ;

begin

readln (a) ;

if 99 < ; a < ; then

writeln('Неверно')

else

if a> ; 999 then

writeln('Неверно')

else

writen('Верно')

end.

Выдаёт : pas(5) : Ожидался идентификатор

Что не так?

AvEnTaDoR005 25 сент. 2020 г., 12:43:18 | 5 - 9 классы

Program TELESHOP ; var x : real ; begin writeln ('?

Program TELESHOP ; var x : real ; begin writeln ('.

') ; write ('.

') ; write ('.

') ; readln (x) ; if x< ; = 1 then begin if x = 1 then begin writeln ('.

') ; writeln ('.

') ; end else begin writeln ('.

') ; end ; * else begin writeln ('.

') ; end end.

* - место ошибки.

"встречено 'else', а ожидалось оператор" Вопрос : в чем ошибка?

На этой странице находится вопрос Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.