Помогите Срочно?

Информатика | 10 - 11 классы

Помогите Срочно!

Чему будет равен результат выполнения программы, если ввести значения для a = 2468?

Program c22 ; var a, b : integer ; k : integer ; begin K : = 0 ; readln(a) ; while (a< ; > ; 0) do begin b : = a mod 10 ; if b mod 2 = 0 then inc(k) ; a : = a div 10 ; end ; writeln(k) ; end.

A) 9 Б)3 В)0 Г)4.

Ответить на вопрос
Ответы (1)
Joker45 28 янв. 2020 г., 01:46:34

Если запустить эту программу в Паскале, то он выдает ответ : 0

Правильный ответ : В) 0.

Serbinova98 20 апр. 2020 г., 14:42:57 | 5 - 9 классы

1) Чему будет равно значение переменной с в результате выполнения фрагмента программы а : = 125 ; b : = 25 ; с : = 12 ; if a div 25 = 0 then if a mod 12 = 0 then c : = b div (a mod c) else c : = a div?

1) Чему будет равно значение переменной с в результате выполнения фрагмента программы а : = 125 ; b : = 25 ; с : = 12 ; if a div 25 = 0 then if a mod 12 = 0 then c : = b div (a mod c) else c : = a div (b mod c) 2) Укажите результат выполнения программы var a, b : integer ; procedure proc(var a : integar ; b : integar) ; begin b : = 4 ; a : = 6 ; b : = a + b ; end ; begin a : = 2 ; b : = 3 ; proc(a, b) ; writeIn(a, ' ', b) ; end.

Пожалуйста!

Хотя бы одну!

Учени10101010101010 15 дек. 2020 г., 09:59:59 | 5 - 9 классы

Прошу вас, помогите?

Прошу вас, помогите!

Решается оценка!

Найдите ошибки в программе 1)Program z1 ; var a : integer ; begin a : = 10 ; while a< ; 5 do writeln(a) ; a : = a + 1 ; End.

2)Program z2 ; var a, s : integer ; begin a : = 1 ; s : = 0 ; while a< ; 10 do begin s : = s + a / 2 ; end ; writeln(s) ; end.

Аовл 16 июл. 2020 г., 16:45:17 | 10 - 11 классы

Чему будет равен результат выполнения программы, если ввести значения для a = 169?

Чему будет равен результат выполнения программы, если ввести значения для a = 169?

Program c22 ; var a : integer ; k : integer ; begin k : = 0 ; readln(a) ; while (a< ; > ; 0) do begin a : = a div 10 ; inc(k) ; end ; writeln(k) ; end.

А) 9 Б) 3 В) 0 Г) 1.

Йчуметнлщдшщгапм5689 22 авг. 2020 г., 00:02:41 | 5 - 9 классы

Найдите значение переменной А после выполнения программы VAR A : INTEGER BEGIN A : = SQRT(16) : END?

Найдите значение переменной А после выполнения программы VAR A : INTEGER BEGIN A : = SQRT(16) : END.

TasyaSnow 22 дек. 2020 г., 12:59:22 | 5 - 9 классы

Укажите результат выполнения программы var a, b : integer procedure proc(var a : integer ; b : integer) begin b : = 4 ; a : = 6 ; b : = a + b ; end ; begin a : = 2 ; b : = 3 ; proc(a, b) ; writeln(a, ?

Укажите результат выполнения программы var a, b : integer procedure proc(var a : integer ; b : integer) begin b : = 4 ; a : = 6 ; b : = a + b ; end ; begin a : = 2 ; b : = 3 ; proc(a, b) ; writeln(a, ' ', b) ; end.

Vlasova123 1 авг. 2020 г., 00:14:42 | 5 - 9 классы

Что будет выведено на экран в результате выполнения следующей программы, если ввести число x = 521?

Что будет выведено на экран в результате выполнения следующей программы, если ввести число x = 521?

Var x, c1, c2, c3, c4 : integer ; Begin writeln(“введите трехзначное число”) ; Readln(x) ; c1 : = x mod 10 ; c2 : = x div 10 ; c3 : = c2 mod 10 ; c4 : = x div 100 ; Writeln(c1, c2, c3, c4) ; End.

Дулетол3 31 окт. 2020 г., 09:13:31 | 5 - 9 классы

Перевод программы с Pascal на QBasic Решение : var a, s : integer ; begin s : = 0 ; readln(a) ; while a< ; > ; 0 do begin if (a mod 6 = 0) and (a mod 10 = 4) then s : = s + a ; readln(a) ; end ; w?

Перевод программы с Pascal на QBasic Решение : var a, s : integer ; begin s : = 0 ; readln(a) ; while a< ; > ; 0 do begin if (a mod 6 = 0) and (a mod 10 = 4) then s : = s + a ; readln(a) ; end ; writeln(s) end.

Arlekino2106 21 авг. 2020 г., 18:55:06 | 10 - 11 классы

Укажите наибольшее х, при вводе которого алгоритм печатает сначала 3, а потом 4?

Укажите наибольшее х, при вводе которого алгоритм печатает сначала 3, а потом 4.

Var x, L, M : integer ; begin readln(x) ; L : = 0 ; M : = 0 ; while x> ; 0 do begin L : = L + 1 If M< ; (x mod 5) then Begin M : = x mod 5 End X : = x div 5 ; End.

Writeln (L) ; write(M) ; End.

Galina50286 13 дек. 2020 г., 16:46:22 | 5 - 9 классы

Найдите ошибки в следующих программах :Program int_r ;Var a, x : integer ;b, c : real ;Begina : = 10 ;b : = 5?

Найдите ошибки в следующих программах :

Program int_r ;

Var a, x : integer ;

b, c : real ;

Begin

a : = 10 ;

b : = 5.

2 ;

x : = b div 2 ;

c : = round(x) ;

End.

Program int_r1 ;

Var a, c : integer ;

b, d : real ;

Begin

a : = 25 ;

b : = a / 2 ;

c : = sqr(a) ;

d : = a mod 10 ;

End.

Danil77728423 29 дек. 2020 г., 17:26:17 | 10 - 11 классы

Помогите срочно решить следующую задачу(оформить с пояснениями)?

Помогите срочно решить следующую задачу(оформить с пояснениями).

Задача : определите при каком наименьшем значении b в результате выполнения следующего алгоритма будет напечатано число 100 var a, b, t, k : integer ; function F(x : integer) : integer ; begin if x mod 2 = 0 then F : = 1 ; else F : = 0 ; end ; BEGIN a : = 100 ; readln(b) ; k : = 0 ; for t : = a to b do begin k : = k = F(t) ; end ; write(k) ; END.

Вы находитесь на странице вопроса Помогите Срочно? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.