Перевод программы с Pascal на QBasic Решение : var a, s : integer ; begin s : = 0 ; readln(a) ; while a< ; > ; 0 do begin if (a mod 6 = 0) and (a mod 10 = 4) then s : = s + a ; readln(a) ; end ; w?

Информатика | 5 - 9 классы

Перевод программы с Pascal на QBasic Решение : var a, s : integer ; begin s : = 0 ; readln(a) ; while a< ; > ; 0 do begin if (a mod 6 = 0) and (a mod 10 = 4) then s : = s + a ; readln(a) ; end ; writeln(s) end.

Ответить на вопрос
Ответы (1)
Goutor 31 окт. 2020 г., 09:13:36

DIM a AS INTEGER, s AS INTEGER

s = 0

INPUT a

DO WHILE a < ; > ; 0 IF (a MOD 6 = 0) AND (a MOD 10 = 4) THEN s = s + a END IF INPUT a

LOOP

PRINT s.

Hdbvd 26 мая 2020 г., 01:21:08 | 10 - 11 классы

Ниже записана программа?

Ниже записана программа.

Получив на вход число x, эта программа печатает два числа, L и M.

Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 8.

Var x, L, M : integer ; begin readln(x) ; L : = 0 ; M : = 0 ; while x> ; 0 do begin L : = L + 1 ; if (M< ; x) and (x mod 2 = 0) then begin M : = x mod 10 ; end ; x : = x div 10 ; end ; writeln(L) ; write(M) ; end.

Antonharitonov0 28 янв. 2020 г., 01:46:32 | 10 - 11 классы

Помогите Срочно?

Помогите Срочно!

Чему будет равен результат выполнения программы, если ввести значения для a = 2468?

Program c22 ; var a, b : integer ; k : integer ; begin K : = 0 ; readln(a) ; while (a< ; > ; 0) do begin b : = a mod 10 ; if b mod 2 = 0 then inc(k) ; a : = a div 10 ; end ; writeln(k) ; end.

A) 9 Б)3 В)0 Г)4.

Йчуметнлщдшщгапм5689 22 авг. 2020 г., 00:02:41 | 5 - 9 классы

Найдите значение переменной А после выполнения программы VAR A : INTEGER BEGIN A : = SQRT(16) : END?

Найдите значение переменной А после выполнения программы VAR A : INTEGER BEGIN A : = SQRT(16) : END.

Isusovv 25 окт. 2020 г., 01:43:51 | 5 - 9 классы

Исправьте программу пожалуйста (lazarus) program Project1 ; var a, b, i, s2, s1, k : integer ; begin writeln('a и b') ; readln(a, b) ; if (a< ; > ; 0)and(b< ; > ; 0)then ; k : = a * b ; i : = ?

Исправьте программу пожалуйста (lazarus) program Project1 ; var a, b, i, s2, s1, k : integer ; begin writeln('a и b') ; readln(a, b) ; if (a< ; > ; 0)and(b< ; > ; 0)then ; k : = a * b ; i : = k ; while i> ; 0 do begin s1 : = i mod a ; s2 : = i mod a ; end ; if s1 = 0 and s2 = 0 than ; writeln(k = i) ; i : = i - 1 ; end.

Sonyatoropchina 24 мар. 2020 г., 12:41:52 | 10 - 11 классы

Исправить ошибку Помогите исправить ошибку в программе Вот задание : Разработать программу поиска и печати всех чисел - близнецов, принадлежащих заданному диапазону [N, M ]?

Исправить ошибку Помогите исправить ошибку в программе Вот задание : Разработать программу поиска и печати всех чисел - близнецов, принадлежащих заданному диапазону [N, M ].

Вот программа : program yyy ; function prost(var x : integer) : boolean ; var k, i : integer ; t : boolean ; begin t : = true ; k : = 0 ; for i : = 1 to x do begin if x mod i = 0 then k : = k + 1 ; end ; if k = 2 then t : = true else t : = false ; prost : = t end ; var n, m, i : integer ; begin writeln('1') ; readln(n) ; writeln('2') ; readln(m) ; for i : = n to m - 1 do begin if prost(i) and prost(i + 2) then writeln(i , (i + 2)) ; end ; end.

Spasibo123 5 февр. 2020 г., 18:45:06 | 10 - 11 классы

Что напечатает данная программа : Var x : = Integer Begin x : = 2 WriteLn('x + 1 = ', x) End?

Что напечатает данная программа : Var x : = Integer Begin x : = 2 WriteLn('x + 1 = ', x) End.

Arlekino2106 21 авг. 2020 г., 18:55:06 | 10 - 11 классы

Укажите наибольшее х, при вводе которого алгоритм печатает сначала 3, а потом 4?

Укажите наибольшее х, при вводе которого алгоритм печатает сначала 3, а потом 4.

Var x, L, M : integer ; begin readln(x) ; L : = 0 ; M : = 0 ; while x> ; 0 do begin L : = L + 1 If M< ; (x mod 5) then Begin M : = x mod 5 End X : = x div 5 ; End.

Writeln (L) ; write(M) ; End.

Ksusha1037 25 июн. 2020 г., 21:03:03 | 5 - 9 классы

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 ?

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 then begin writeln ('утро') ; readln (d) ; if a = 12 then begin writeln ('день') ; end ; if a = 16 then begin writeln ('вечер') ; / / / if a = 21 then begin writeln ('ночь') ; / / / end ; end ;

GioZam 1 дек. 2020 г., 11:19:33 | 10 - 11 классы

Задание :Ввести массив в данную программуvarn, i, a, min : integer ;beginreadln(n) ;min : = 30001 ;for i : = 1 to n dobeginreadln(a) ;if (a mod 10 = 4) and (a < min) thenmin : = a ;end ;writeln(min)en?

Задание :

Ввести массив в данную программу

var

n, i, a, min : integer ;

begin

readln(n) ;

min : = 30001 ;

for i : = 1 to n do

begin

readln(a) ;

if (a mod 10 = 4) and (a < min) then

min : = a ;

end ;

writeln(min)

end.

Vikalove07012000 25 дек. 2020 г., 12:19:12 | 5 - 9 классы

4. Определите результат работы программ :1)var а, b : integer ;begina : = 26 mod 11 ;b : = 3 ;b : = 6 + a * b ;a : = b / 3 * a ;writeln(а) ;end?

4. Определите результат работы программ :

1)

var а, b : integer ;

begin

a : = 26 mod 11 ;

b : = 3 ;

b : = 6 + a * b ;

a : = b / 3 * a ;

writeln(а) ;

end.

2)

var s, k : integer ;

begin

s : = 0 ;

for k : = 12 to 15 do s : = s + 13 ;

writeln(s) ;

end.

Вопрос Перевод программы с Pascal на QBasic Решение : var a, s : integer ; begin s : = 0 ; readln(a) ; while a&lt ; &gt ; 0 do begin if (a mod 6 = 0) and (a mod 10 = 4) then s : = s + a ; readln(a) ; end ; w?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.