Паскаль?

Информатика | 5 - 9 классы

Паскаль.

Написать программу которая, используя признаки делимости, определяет, делится ли число на 6.

Var a, c : integer ; begin cls ; randomize ; a : = random (99999 + 99999 + 1) - 99999 ; writeln ( 'исходное числo : ', a) ; if (a mod 10) mod 2 = 0 then writeln (' делится на 2') else writeln (' не делится на 2') ; while a< ; > ; 0 do begin c : = c + (a mod 10) ; a : = a div 10 ; end ; if c mod 3 = 0 then writeln (' число делится на 3') else writeln (' число не делится на 3') ; end.

Признак делимости на 6 - это значит, что число делится на 2 и 3.

Я сделала по отдельности на 2 и 3 ( программа выше).

А как это обобщить?

Ответить на вопрос
Ответы (1)
Matos2016 27 сент. 2020 г., 07:49:44

Var a, c : integer ;

begin randomize ; a : = random(99999 + 99999 + 1) - 99999 ; writeln('исходное числo : ', a) ; while a > ; 0 do begin c : = c + a mod 10 ; a : = a div 10 ; end ; if (c mod 3 = 0) and ((a mod 10) mod 2 = 0) then writeln(' число делится на 6') else writeln(' число не делится на 6') ;

end.

Polinka275 15 мая 2020 г., 04:26:59 | 5 - 9 классы

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число?

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число.

Program cisla ; var a : integer ; begin writeln('Введите число, ') ; readln(a) ; if a mod 2 = 0 then writeln('Число четное') ; else writeln('Число нечетное') ; readln end.

Irinakirikovam 24 мая 2020 г., 05:37:28 | 5 - 9 классы

Program yura ; var x : integer ; begin writeln ('Напишите x') ; readln (x) ; if x mod 2 = 0 then writeln(x * x + (sqrt2)) else writeln(x * x * x + x) end?

Program yura ; var x : integer ; begin writeln ('Напишите x') ; readln (x) ; if x mod 2 = 0 then writeln(x * x + (sqrt2)) else writeln(x * x * x + x) end.

В чём ошибка?

Vlasova123 1 авг. 2020 г., 00:14:42 | 5 - 9 классы

Что будет выведено на экран в результате выполнения следующей программы, если ввести число x = 521?

Что будет выведено на экран в результате выполнения следующей программы, если ввести число x = 521?

Var x, c1, c2, c3, c4 : integer ; Begin writeln(“введите трехзначное число”) ; Readln(x) ; c1 : = x mod 10 ; c2 : = x div 10 ; c3 : = c2 mod 10 ; c4 : = x div 100 ; Writeln(c1, c2, c3, c4) ; End.

Temnikt2998 26 июн. 2020 г., 06:21:35 | 5 - 9 классы

Почему не работает запись в Паскале по задаче : Написать программу, подсчитывающую количество четных цифр, которые делятся на 4, в числе?

Почему не работает запись в Паскале по задаче : Написать программу, подсчитывающую количество четных цифр, которые делятся на 4, в числе.

Вот запись, исправьте пожалуйста : program chisla ; var a, b, k : integer ; begin k : = 0 ; writeln('Введите число') ; readln(a) ; repeat if(a mod 2 = 0)and(a mod 4 = 0)then k : = k + 1 until a = 0 ; writeln('Количество чисел = ', k) end.

Fdfhve 20 апр. 2020 г., 06:55:17 | 10 - 11 классы

Var sumsec : integer ; var hour, min, sec : integer ; l : integer ; begin writeln ('Введите суммарное кол - во секунд') ; readln (sumsec) ; l : = sumsec div 60 ; sec : = sumsec mod 60 ; hour : = l div?

Var sumsec : integer ; var hour, min, sec : integer ; l : integer ; begin writeln ('Введите суммарное кол - во секунд') ; readln (sumsec) ; l : = sumsec div 60 ; sec : = sumsec mod 60 ; hour : = l div 60 ; min : = l mod 60 ; writeln (sumsec, ' секунд - это') ; writeln ( hour , 'час(а / ов) ', min , ' минут ' , sec , ' секунд ') ; end.

Сделать данную программу с помощью процедуры.

AvEnTaDoR005 25 сент. 2020 г., 12:43:18 | 5 - 9 классы

Program TELESHOP ; var x : real ; begin writeln ('?

Program TELESHOP ; var x : real ; begin writeln ('.

') ; write ('.

') ; write ('.

') ; readln (x) ; if x< ; = 1 then begin if x = 1 then begin writeln ('.

') ; writeln ('.

') ; end else begin writeln ('.

') ; end ; * else begin writeln ('.

') ; end end.

* - место ошибки.

"встречено 'else', а ожидалось оператор" Вопрос : в чем ошибка?

Ksusha1037 25 июн. 2020 г., 21:03:03 | 5 - 9 классы

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 ?

Здравствуйте, помогите пожалуйста найти ошибку program name ; uses crt ; var a : integer ; begin writeln ('Введите время = ') ; readln (a) ; if (a)then ; begin writeln ('ночь') ; end ; / / / if a = 3 then begin writeln ('утро') ; readln (d) ; if a = 12 then begin writeln ('день') ; end ; if a = 16 then begin writeln ('вечер') ; / / / if a = 21 then begin writeln ('ночь') ; / / / end ; end ;

Aigulmazh1 4 июн. 2020 г., 06:58:18 | 10 - 11 классы

Var : a, i, b : integer begin readln(a) ; for i : = 1 to a do if a mod i = 0 then b : = b + 1 ; if b = 2 then writeln('простое число') else writeln(' не простое число') end?

Var : a, i, b : integer begin readln(a) ; for i : = 1 to a do if a mod i = 0 then b : = b + 1 ; if b = 2 then writeln('простое число') else writeln(' не простое число') end.

Объясните пожалуйста подробно , что делает эта программа?

В чем суть ?

Буду очень благодарна).

Ряжка 25 дек. 2020 г., 18:21:48 | 5 - 9 классы

Помогите пожалуйста, cрочно?

Помогите пожалуйста, cрочно!

Составить блок - схему.

Program primer6 ;

uses crt ;

x : integer ;

begin

clrscr ;

readln(x) ;

if x mod 2 = 0 then writeln ('да')

else writeln ('нет')

end.

Яна2022 19 дек. 2020 г., 10:26:13 | 10 - 11 классы

Помогите с задачкой в паскале ( не сложная)?

Помогите с задачкой в паскале ( не сложная)!

Задача : каждые 3 часа моллюск делится на 2, сколько их будет через N часов?

Обратите внимание на то, что число часов может и с остатком делится на 3!

Program molusk ; var s, n, i : integer ; begin ; n : = 1 ; Writeln('введите время ') ; readln(s) ; for i : = 1 to s do if(s mod 3) = 3 then n : = s : 3 ; writeln(n) ; end.

Где у меня тут ошибка, думаю скорее всего в (.

Mod. ).

На этой странице сайта, в категории Информатика размещен ответ на вопрос Паскаль?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.