Почему не работает запись в Паскале по задаче : Написать программу, подсчитывающую количество четных цифр, которые делятся на 4, в числе?

Информатика | 5 - 9 классы

Почему не работает запись в Паскале по задаче : Написать программу, подсчитывающую количество четных цифр, которые делятся на 4, в числе.

Вот запись, исправьте пожалуйста : program chisla ; var a, b, k : integer ; begin k : = 0 ; writeln('Введите число') ; readln(a) ; repeat if(a mod 2 = 0)and(a mod 4 = 0)then k : = k + 1 until a = 0 ; writeln('Количество чисел = ', k) end.

Ответить на вопрос
Ответы (1)
Salavat22826 26 июн. 2020 г., 06:21:38

Var a, b, k : integer ;

begin

k : = 0 ;

writeln('Введите число') ;

readln(a) ;

repeat

if (a mod 10) in [4, 8] then k : = k + 1 ;

a : = a div 10 ;

until a = 0 ;

writeln('Количество чисел = ', k)

end.

Введите число

24583

Количество чисел = 2.

Polinka275 15 мая 2020 г., 04:26:59 | 5 - 9 классы

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число?

Paskal выдаёт ошибку, помогите пожалуйста испрвить : Задача : Написать программу, которая проверяет, является ли четным введенное пользователем целое число.

Program cisla ; var a : integer ; begin writeln('Введите число, ') ; readln(a) ; if a mod 2 = 0 then writeln('Число четное') ; else writeln('Число нечетное') ; readln end.

Reginasolnce200 26 мая 2020 г., 00:11:29 | 5 - 9 классы

Программисту поставили задачу написать программу, которая по введённому натуральному числу n должна выводить через пробел все нечётные числа из диапазона от 1 до n?

Программисту поставили задачу написать программу, которая по введённому натуральному числу n должна выводить через пробел все нечётные числа из диапазона от 1 до n.

Программист торопился и написал следующую программу : program error ; var n, i : integer ; begin ; write('9') ; readln(n) ; for i : = 1 to 9 do if (i mod 2 = 0) then write(i) ; writeln end.

С помощью откладки найдите и исправьте допущенные ошибки.

Valyaandrosova 10 мая 2020 г., 02:35:19 | 10 - 11 классы

ПРОГРАММИРОВАНИЕ В ПАСКАЛЬ Изменить программу которая ниже так, чтобы в ней подсчитывалось и выдавалось ?

ПРОГРАММИРОВАНИЕ В ПАСКАЛЬ Изменить программу которая ниже так, чтобы в ней подсчитывалось и выдавалось !

ОДНОВРЕМЕННО!

3 ответа, A НЕ 3 РАЗНЫЕ ПРОГРАММЫ а) количество цифр числа ; б) произведение цифр, больших 0 ; в) сумма цифр, меньших 3.

ПРОГРАММА.

Ввести с клавиатуры натуральное число.

Найти сумму его цифр.

Решение : Programm Sum ; Var chislo ; word ; {число, введенное с клавиатуры} tchifra, Summa : integer ; {tchifra - правая цифра}} begin Write ('введи число') ; Readln (chislo) ; Summa : = 0 ; Repeat tchifra : - chislo mod 10 ; {скопировали правую цифру} Summa : = Summa + tchifra ; chislo : = chislo div 10 {оставили от числа левую часть} Until chislo = 0 ; {выход из цикла, если нет больше цифр} Writeln ('сумма цифр = ', Summa) ; Readln end.

Dim0nGreshNIK 12 февр. 2020 г., 18:24:08 | 10 - 11 классы

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и b хотя бы одно четное?

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и b хотя бы одно четное.

Была написана следующая программа : var a, b : integer ; begin readln(a, b) ; a : = a mod 2 ; if a > ; 0 then b : = b mod 2 ; if b > ; 0 then writeln ('четных чисел нет') else writeln ('четное число есть') ; end.

Известно, что программа написана с ошибками.

Последовательно выполните три задания : укажите, как, по вашему мнению, нужно доработать программу (не используя слож - ные условия), чтобы не было случаев ее неправильной работы ;

Дулетол3 31 окт. 2020 г., 09:13:31 | 5 - 9 классы

Перевод программы с Pascal на QBasic Решение : var a, s : integer ; begin s : = 0 ; readln(a) ; while a< ; > ; 0 do begin if (a mod 6 = 0) and (a mod 10 = 4) then s : = s + a ; readln(a) ; end ; w?

Перевод программы с Pascal на QBasic Решение : var a, s : integer ; begin s : = 0 ; readln(a) ; while a< ; > ; 0 do begin if (a mod 6 = 0) and (a mod 10 = 4) then s : = s + a ; readln(a) ; end ; writeln(s) end.

Kokakola061 18 апр. 2020 г., 04:04:37 | 5 - 9 классы

Помогите понять программу (Pascal) P?

Помогите понять программу (Pascal) P.

S. Это решение задачи (добавил во вложения) program qq ;

var i, k, m, g : integer ;

begin

writeln('Введите количество цифр в последовательности (Не больше 100)') ;

repeat

readln(i) ;

until i< ; 101 ;

writeln('Вводите числа (не превышающие 300)') ;

for k : = 1 to i do begin

repeat

readln(m) ;

until m< ; 301 ;

if (m mod 3 = 0) then g : = g + m ;

end ;

writeln(g) ;

end.

Ema999 27 апр. 2020 г., 17:11:38 | 5 - 9 классы

Как записать программу сложения чисел 2 + 3 в Паскаль ?

Как записать программу сложения чисел 2 + 3 в Паскаль ?

Program summa ; var a, b, c : integer ; begin Что нужно дальше ?

Pautovadarja11 27 нояб. 2020 г., 12:52:33 | 5 - 9 классы

Дана программа : program primer3 ; uses crt ; var x : integer ; begin clrscr ; readin (x) ; if x mod 2 = 0 then wtiteln('да') else wtiteln ('нет') При каком значении x будет получен ответ 'ДА'?

Дана программа : program primer3 ; uses crt ; var x : integer ; begin clrscr ; readin (x) ; if x mod 2 = 0 then wtiteln('да') else wtiteln ('нет') При каком значении x будет получен ответ 'ДА'?

Laime2014 27 сент. 2020 г., 07:49:39 | 5 - 9 классы

Паскаль?

Паскаль.

Написать программу которая, используя признаки делимости, определяет, делится ли число на 6.

Var a, c : integer ; begin cls ; randomize ; a : = random (99999 + 99999 + 1) - 99999 ; writeln ( 'исходное числo : ', a) ; if (a mod 10) mod 2 = 0 then writeln (' делится на 2') else writeln (' не делится на 2') ; while a< ; > ; 0 do begin c : = c + (a mod 10) ; a : = a div 10 ; end ; if c mod 3 = 0 then writeln (' число делится на 3') else writeln (' число не делится на 3') ; end.

Признак делимости на 6 - это значит, что число делится на 2 и 3.

Я сделала по отдельности на 2 и 3 ( программа выше).

А как это обобщить?

Яна2022 19 дек. 2020 г., 10:26:13 | 10 - 11 классы

Помогите с задачкой в паскале ( не сложная)?

Помогите с задачкой в паскале ( не сложная)!

Задача : каждые 3 часа моллюск делится на 2, сколько их будет через N часов?

Обратите внимание на то, что число часов может и с остатком делится на 3!

Program molusk ; var s, n, i : integer ; begin ; n : = 1 ; Writeln('введите время ') ; readln(s) ; for i : = 1 to s do if(s mod 3) = 3 then n : = s : 3 ; writeln(n) ; end.

Где у меня тут ошибка, думаю скорее всего в (.

Mod. ).

На этой странице вы найдете ответ на вопрос Почему не работает запись в Паскале по задаче : Написать программу, подсчитывающую количество четных цифр, которые делятся на 4, в числе?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.