Введите три числа?

Информатика | 10 - 11 классы

Введите три числа.

Если они могут быть длинами сторон разностороннего остроугольного треугольника, выведите их в порядке возрастания и вычислите площадь полученного треугольника.

В паскале.

Ответить на вопрос
Ответы (1)
Pavelkhdv 3 нояб. 2020 г., 06:18:41

Не уверена, что по длине сторон можно определить, что треугольник остроугольный, но предположила, что здесь можно использовать т.

Пифагора, т.

Е. если квадрат гипотенузы (большей стороны) окажется меньше суммы квадратов катетов (меньших сторон), то соответственно и угол между последнимиокажется меньше 90 градусов.

Если я не права, прошу, отметьте ошибкой, пусть удалят.

Итак :

program aaa ;

var a, b, c, x, y, z, s, p : real ;

begin

writeln ('Введите стороны треугольника A, B и C') ;

readln (a, b, c) ; {сначала найдем меньшую, среднюю и большую сторону и присвоим их значения, соответственно, переменным x, y и z} if a< ; b then if a< ; c then if b< ; c then begin x : = a ; y : = b ; z : = c end else begin x : = a ; y : = c ; z : = b end else begin x : = c ; y : = a ; z : = b end else if a> ; c then if b< ; c then begin x : = b ; y : = c ; z : = a end else begin x : = c ; y : = b ; z : = a end else begin x : = b ; y : = a ; z : = c end ; {Теперь узнаем, является ли треугольник разносторонним и остроугольным : Для этого сравним длины сторон между собой а также сумму квадратов меньших сторон с квадратом большей}

if ((x * x + y * y)> ; (z * z)) and (a< ; > ; b) and (a< ; > ; c) and (b< ; > ; c) then begin p : = (a + b + c) / 2 ; / / находим полупериметр s : = sqrt(p * (p - a) * (p - b) * (p - c)) ; / / находим площадь треугольника writeln(x, ' ', y, ' ', z, ' - могут быть сторонами остроугольного разностороннего треугольника') ; writeln('Площадь этого треугольника = ', s) end else writeln(a : 4, b : 4, c : 4, ' - не могут быть сторонами остроугольного разностороннего треугольника')

end.

Dsfgh 18 февр. 2020 г., 11:50:16 | 10 - 11 классы

Даны три положительных числа?

Даны три положительных числа.

Если они могут быть длинами сторон остроугольного треугольника, то вычислить его площадь и определить вид треугольника ( равносторонний, равнобедренный или разносторонний), иначе выдать соответсвующее сообщение.

Kenn341 6 мая 2020 г., 22:48:44 | 10 - 11 классы

В программе паскаль : вычислите площадь треугольника по его сторонам?

В программе паскаль : вычислите площадь треугольника по его сторонам.

Evgeniybelov12 5 мар. 2020 г., 16:50:52 | 5 - 9 классы

С клавиатуры вводятся три числа (длины сторон треугольника)?

С клавиатуры вводятся три числа (длины сторон треугольника).

Определить, можно ли построить треугольник по введённым сторонам.

Программа Паскаль.

Сока 3 мая 2020 г., 09:26:31 | 10 - 11 классы

Дан треугольник со стороной a и прилежащими углами Y и B?

Дан треугольник со стороной a и прилежащими углами Y и B.

Вычислить площадь треугольника, найти остальные стороны и угол между ними.

Написать в паскале.

Ksardas2014 25 июн. 2020 г., 10:17:50 | 5 - 9 классы

Составьте программу, определяющую, могут ли три числа a, b, c являются длинами сторон треугольника?

Составьте программу, определяющую, могут ли три числа a, b, c являются длинами сторон треугольника.

Числа a, b, c введите с клавиатуры.

Бачи 4 мар. 2020 г., 04:03:58 | 10 - 11 классы

Треугольник задан длинами своих сторон – a, b, c?

Треугольник задан длинами своих сторон – a, b, c.

Определить является ли он тупоугольным, прямоугольным или остроугольным.

Решить на языке Паскаль.

KrIsTaI 6 апр. 2020 г., 13:14:52 | 5 - 9 классы

С клавиатуры вводится число - длина стороны квадрата?

С клавиатуры вводится число - длина стороны квадрата.

Вычислите и выведите площадь и периметр квадрата.

Onishenkoveroni 27 сент. 2020 г., 14:41:57 | 5 - 9 классы

Даны положительных числа a, b, c?

Даны положительных числа a, b, c.

Проверить могут ли они быть длинами сторон треугольника, если да, то вычесли его площадь.

(составить программу для паскаля).

Korobchenko84 8 июл. 2020 г., 12:09:04 | 5 - 9 классы

Написать программу на паскале?

Написать программу на паскале.

А. Проверить является ли число двухзначным ?

Б. (введено два числа.

Вывести их в порядке возрастания.

Kuganova30 1 мар. 2020 г., 11:19:21 | 10 - 11 классы

Даны три натуральных числа?

Даны три натуральных числа.

Напишите программу, определяющую, существует ли треугольник с такими длинами сторон.

Если такой треугольник существует, то определите его тип ( равносторонний, равнобедренный, разносторонний).

На этой странице находится ответ на вопрос Введите три числа?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.