Даны положительных числа a, b, c?

Информатика | 5 - 9 классы

Даны положительных числа a, b, c.

Проверить могут ли они быть длинами сторон треугольника, если да, то вычесли его площадь.

(составить программу для паскаля).

Ответить на вопрос
Ответы (1)
Svetohcasamilim 27 сент. 2020 г., 14:42:01

/ / Pascal ABC.

NET 3.

1 сборка 1256

Var

a, b, c, s, p : real ;

begin

readln(a, b, c) ;

if (a + b> ; c) and (b + c> ; a) and (a + c> ; b) then

begin p : = (a + b + c) / 2 ; s : = sqrt(p * (p - a) * (p - b) * (p - c)) ; writeln('S = ', s) ;

end

else

writeln('Такого треугольника не существует.

') ;

end.

Пример ввода :

3

4

3

Пример вывода :

S = 4.

47213595499958.

Dsfgh 18 февр. 2020 г., 11:50:16 | 10 - 11 классы

Даны три положительных числа?

Даны три положительных числа.

Если они могут быть длинами сторон остроугольного треугольника, то вычислить его площадь и определить вид треугольника ( равносторонний, равнобедренный или разносторонний), иначе выдать соответсвующее сообщение.

Kenn341 6 мая 2020 г., 22:48:44 | 10 - 11 классы

В программе паскаль : вычислите площадь треугольника по его сторонам?

В программе паскаль : вычислите площадь треугольника по его сторонам.

Evgeniybelov12 5 мар. 2020 г., 16:50:52 | 5 - 9 классы

С клавиатуры вводятся три числа (длины сторон треугольника)?

С клавиатуры вводятся три числа (длины сторон треугольника).

Определить, можно ли построить треугольник по введённым сторонам.

Программа Паскаль.

Dodydyd 13 янв. 2020 г., 18:54:23 | 10 - 11 классы

Даны три целых числа?

Даны три целых числа.

Определить, сколько среди них положительных чисел.

Составить программу на языке Паскаль.

Парkур 14 нояб. 2020 г., 15:28:10 | 5 - 9 классы

Паскаль напишите пожалуйста программу Срочно, прошу?

Паскаль напишите пожалуйста программу Срочно, прошу!

Даны действительные положительные числа a, b, c, которые задают длины сторон треугольника и угол между ними.

Напишите программу, позволяющую найти длину третьей стороны и два остальных угла.

110308 28 дек. 2020 г., 02:00:54 | 10 - 11 классы

Помогите с задачками в паскале?

Помогите с задачками в паскале.

Даны три положительных числа а, в, с.

Проверить будут ли они сторонами треугольника.

Если да то вычислить площадь этого треугольника.

Даны два действительных положительных числа х и у.

Арифметические действия над числами пронумерованы (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление).

Составить программу, которая по выведенному номеру выполняет то или иное действие над числами.

Aksentiy10 8 мая 2020 г., 15:53:34 | 10 - 11 классы

Составить программу для решения задачи : 1)Даны действительные, положительные числа x, y, z?

Составить программу для решения задачи : 1)Даны действительные, положительные числа x, y, z.

Выяснить, существует ли треугольник с длинами сторон x, y, z.

Если треугольник, то является ли он равносторонним?

2)Дан одномерный массив.

Найти количество смен знака между соседними элементами массива.

Программа - Паскаль.

Tihsunka 13 июл. 2020 г., 00:56:47 | 10 - 11 классы

Составить программу на паскале?

Составить программу на паскале.

Даны стороны двух треугольников.

Найти сумму их периметров и сумму площадей.

Определить процедуру для расчета периметра и площади треугольника по его сторонам.

Leanik1 27 дек. 2020 г., 23:43:49 | 10 - 11 классы

Создать программу, вычисляющую площадь треугольника Входные данные 3 числа(длины сторон треугольника) Выходные данные 1 число(площадь треугольника)?

Создать программу, вычисляющую площадь треугольника Входные данные 3 числа(длины сторон треугольника) Выходные данные 1 число(площадь треугольника).

Islamkyzy2003 3 нояб. 2020 г., 06:18:35 | 10 - 11 классы

Введите три числа?

Введите три числа.

Если они могут быть длинами сторон разностороннего остроугольного треугольника, выведите их в порядке возрастания и вычислите площадь полученного треугольника.

В паскале.

На этой странице находится ответ на вопрос Даны положительных числа a, b, c?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.