Треугольник задан длинами своих сторон – a, b, c?

Информатика | 10 - 11 классы

Треугольник задан длинами своих сторон – a, b, c.

Определить является ли он тупоугольным, прямоугольным или остроугольным.

Решить на языке Паскаль.

Ответить на вопрос
Ответы (1)
Kimulka 4 мар. 2020 г., 04:04:04

Можно заметить, что самый большой угол в треугольнике всегда расположен напротив самой длинной стороны, которую мы обозначим буквой с.

Значение такого угла можно найти по теореме косинусов :

$\displaystyle \cos(C)= \frac{a^2+b^2-c^2}{2ab}$

В остроугольном треугольнике угол всегда будет меньше 90 градусов, поэтому его косинус всегда будет положительным.

В прямоугольном треугольнике косинус будет равен нулю, а в тупоугольном он будет отрицательным.

На этом можно построить решение, предварительно определив, какая из сторон является самой длинной.

И, само собой разумеется, надо сразу после ввода проверить условие существования треугольника, т.

Е. чтобы сумма длин двух его любых сторон была больше третьей.

Var a, b, c, a1, b1, c1, cosC : real ;

begin Write('Введите длины сторон треугольника : ') ; Read(a, b, c) ; Write('Треугольник ') ; if (a< ; (b + c)) and (b< ; (a + c)) and (c< ; (a + b)) then begin if a> ; b then if a> ; c then begin c1 : = a ; a1 : = c ; b1 : = b end else begin c1 : = c ; a1 : = a ; b1 : = b end else if b> ; c then begin c1 : = b ; a1 : = a ; b1 : = c end else begin c1 : = c ; a1 : = a ; b1 : = b end ; cosC : = (sqr(a1) + sqr(b1) - sqr(c1)) / (2 * a * b) ; if cosC< ; 0 then Writeln('тупоугольный') else if cosC = 0 then Writeln('прямоугольный') else Writeln('остроугольный') end else Writeln('построить невозможно')

end.

Тестовое решение :

Введите длины сторон треугольника : 6 4.

1 4

Треугольник тупоугольный.

Kest878 16 мая 2020 г., 00:27:17 | 5 - 9 классы

Составьте программу которая распознает треугольник : остроугольный, тупоугольный, прямоугольный, остроугольный и равносторонний, тупоугольный и равнобедренный, прямоугольный и равнобедренный, (pascal)?

Составьте программу которая распознает треугольник : остроугольный, тупоугольный, прямоугольный, остроугольный и равносторонний, тупоугольный и равнобедренный, прямоугольный и равнобедренный, (pascal).

Diankamironyuk 21 мая 2020 г., 21:27:29 | 10 - 11 классы

Треугольник задан длинами своих сторон – a, b, c?

Треугольник задан длинами своих сторон – a, b, c.

Определить является ли он тупоугольным, прямоугольным или остроугольным.

Построить программу на языке С#.

AHDPOID69 9 авг. 2020 г., 23:14:28 | 5 - 9 классы

Напишите программу на языке Паскаль, распознающую по длинам сторон среди всех треугольников прямоугольный?

Напишите программу на языке Паскаль, распознающую по длинам сторон среди всех треугольников прямоугольный.

Если они прямоугольные, то должно выводится сообщение 'Это прямоугольный треугольник'.

Sedoykuliga 18 сент. 2020 г., 02:46:40 | 5 - 9 классы

Даны три стороны треугольника ?

Даны три стороны треугольника .

Определить существует ли треугольник с заданными сторонами, если да , то определить является ли он прямоугольным, равнобедренным или равносторонним, какой треугольник тупоугольный или остроугольный.

Lalola 7 авг. 2020 г., 05:54:37 | 10 - 11 классы

Известны длины сторон нескольких треугольников?

Известны длины сторон нескольких треугольников.

Для каждого из них определить его вид : прямоугольный, тупоугольный или остроугольный.

Признак окончания ввода - три нуля.

Напишите программу пожалуйста , паскаль.

Славикус 14 окт. 2020 г., 02:09:58 | 5 - 9 классы

Составьте алгоритм с помощью которого можно определить является ли треугольник с заданными длинами сторон а, в, с равносторонним?

Составьте алгоритм с помощью которого можно определить является ли треугольник с заданными длинами сторон а, в, с равносторонним.

Соня183 11 янв. 2020 г., 21:06:13 | 10 - 11 классы

Даны три натуральных числа, являющиеся длинами сторон треугольника?

Даны три натуральных числа, являющиеся длинами сторон треугольника.

Число ввести с клавиатуры.

Определить является ли треугольник прямоугольным, если эти отрезки позволяют его построить.

Написать программу на паскале только на паскале и не на другом языке!

SystemBin 3 нояб. 2020 г., 14:30:12 | 10 - 11 классы

Программу надо составить в паскале : Составить программу определения вида треугольника по двум углам (прямоугольный, остроугольный, тупоугольный)?

Программу надо составить в паскале : Составить программу определения вида треугольника по двум углам (прямоугольный, остроугольный, тупоугольный).

465733 18 февр. 2020 г., 23:39:56 | 5 - 9 классы

Заданы длины 3 сторон треугольника a, b, c?

Заданы длины 3 сторон треугольника a, b, c.

Определить, является ли треугольник прямоугольным, и вывести соответствующие сообщения.

Составьте блок схему плз.

Islamkyzy2003 3 нояб. 2020 г., 06:18:35 | 10 - 11 классы

Введите три числа?

Введите три числа.

Если они могут быть длинами сторон разностороннего остроугольного треугольника, выведите их в порядке возрастания и вычислите площадь полученного треугольника.

В паскале.

Вы зашли на страницу вопроса Треугольник задан длинами своих сторон – a, b, c?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.