Даны три положительных числа?

Информатика | 10 - 11 классы

Даны три положительных числа.

Если они могут быть длинами сторон остроугольного треугольника, то вычислить его площадь и определить вид треугольника ( равносторонний, равнобедренный или разносторонний), иначе выдать соответсвующее сообщение.

Ответить на вопрос
Ответы (1)
Natalitrubitsy 18 февр. 2020 г., 11:50:18

Uses crt ;

var a, b, c, mn, mx, sr, p, s : real ;

begin

clrscr ;

writeln('Введите 3 числа : ') ;

readln(a, b, c) ;

if(a< ; = abs(b - c))or(a> ; = b + c)then

write('Это не треугольник!

')

else

begin

mn : = a ;

if b< ; mn then mn : = b ;

if c< ; mn then mn : = c ; mx : = a ;

if b> ; mx then mx : = b ;

if c> ; mx then mx : = c ; sr : = a + b + c - mn - mx ;

if(a = b)and(b = c) then writeln('Это равносторонний треугольник')

else if((a = b)and(b< ; > ; c))or((a = c)and(b< ; > ; c))or((b = c)and(a< ; > ; b))then

writeln('Это равнобедренный треугольник')

else writeln('Это разноcторонний треугольник') ; p : = (a + b + c) / 2 ;

s : = sqrt(p * (p - a) * (p - b) * (p - c)) ;

writeln('его площадь = ', s : 0 : 2) ;

write('Стороны в порядке убывания : ', mx : 0 : 2, ' ', sr : 0 : 2, ' ', mn : 0 : 2) ;

end ;

readln

end.

Piopikpiopik 8 апр. 2020 г., 06:16:07 | 5 - 9 классы

Составить программу, классифицирующую треугольники по сторонам, если заданы градусные меры трех углов (равносторонний, равнобедренный, разносторонний, прямоугольный)?

Составить программу, классифицирующую треугольники по сторонам, если заданы градусные меры трех углов (равносторонний, равнобедренный, разносторонний, прямоугольный).

Пукач 27 мар. 2020 г., 06:59:52 | 10 - 11 классы

Составьте программу которая по трем введенным вами числам определить, могут ли эти числа быть длинами сторон треугольника, и если да , то определить вид треугольника?

Составьте программу которая по трем введенным вами числам определить, могут ли эти числа быть длинами сторон треугольника, и если да , то определить вид треугольника.

Помогите.

Sedoykuliga 18 сент. 2020 г., 02:46:40 | 5 - 9 классы

Даны три стороны треугольника ?

Даны три стороны треугольника .

Определить существует ли треугольник с заданными сторонами, если да , то определить является ли он прямоугольным, равнобедренным или равносторонним, какой треугольник тупоугольный или остроугольный.

Сиайлик1 27 февр. 2020 г., 00:39:51 | 5 - 9 классы

Треугольник со сторонамиДаны длины 3 - х отрезков?

Треугольник со сторонами

Даны длины 3 - х отрезков.

Из них можно составлять треугольники, соединяя отрезки концами.

Нужно сказать, можно ли получить таким способом равносторонний, равнобедренный или разносторонний треугольники.

Input Со стандартного устройства ввода вводится через пробел 3 целых положительных числа, не превосходящих 10000 – длины отрезков.

Output Нужно выдать на стандартное устройство вывода одно из следующих сообщений :

“Triangle is equilateral” – если треугольник равносторонний

“Triangle is isosceles” – если треугольник равнобедренный

“Triangle is scalene” – если треугольник разносторонний

“Triangle is invalid” – если треугольника не существует

Кавычки выводить не нужно.

Sample Input 100 60 80

Sample Output Triangle is scalene.

Onishenkoveroni 27 сент. 2020 г., 14:41:57 | 5 - 9 классы

Даны положительных числа a, b, c?

Даны положительных числа a, b, c.

Проверить могут ли они быть длинами сторон треугольника, если да, то вычесли его площадь.

(составить программу для паскаля).

Kim89096 11 июн. 2020 г., 20:39:28 | 10 - 11 классы

Составьте программу которая по трем введенным вами числам определит могут ли эти числа быть длинами сторон треугольника и если да то определить вид этого треугольника?

Составьте программу которая по трем введенным вами числам определит могут ли эти числа быть длинами сторон треугольника и если да то определить вид этого треугольника.

EVABedareva 7 янв. 2020 г., 19:54:30 | 10 - 11 классы

Даны стороны треугольника?

Даны стороны треугольника.

Определить его вид : равносторонний, равнобедренный или разносторонний - и вывести сообщение об этом.

И кроме того, если треугольник равносторонний, то найти его высоту, если он равнобедренный, то найти его полупериметр, а в противном случае найти его наибольшую сторону.

Korolcs777 2 февр. 2020 г., 08:58:39 | 5 - 9 классы

Даны три натуральных числа?

Даны три натуральных числа.

Напишите программу, определяющую, существует ли треугольник с такими длинами сторон.

Если такой треугольник существует, то определите его тип(равносторонний, равнобедренный, разносторонний).

НАПИСАТЬ В БЛОК СХЕМЕ!

Kuganova30 1 мар. 2020 г., 11:19:21 | 10 - 11 классы

Даны три натуральных числа?

Даны три натуральных числа.

Напишите программу, определяющую, существует ли треугольник с такими длинами сторон.

Если такой треугольник существует, то определите его тип ( равносторонний, равнобедренный, разносторонний).

Islamkyzy2003 3 нояб. 2020 г., 06:18:35 | 10 - 11 классы

Введите три числа?

Введите три числа.

Если они могут быть длинами сторон разностороннего остроугольного треугольника, выведите их в порядке возрастания и вычислите площадь полученного треугольника.

В паскале.

На этой странице сайта вы найдете ответы на вопрос Даны три положительных числа?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.