Дана строка символов состоящая из букв и цифр определить сумму всех цифр в этой сроке и количество прописных заглавных букв на PASCAL?

Информатика | 5 - 9 классы

Дана строка символов состоящая из букв и цифр определить сумму всех цифр в этой сроке и количество прописных заглавных букв на PASCAL.

Ответить на вопрос
Ответы (1)
Cheburek01 20 июл. 2020 г., 11:55:39

/ / PascalABC.

NET 3.

1 сборка 1219

begin var s : = ReadString('s = ') ; var t : = s.

MatchValues('[0 - 9] + ').

Aggregate(0, (s, x) - > ; s + StrToInt(x)) ; var t1 : = s.

MatchValues('[A - Z]').

Count ; Println(t, t1) ;

end.

Или

var s : string ; i, sum, k : integer ;

begin readln(s) ; for i : = 1 to Length(s) do begin if s[i] in '0123456789' then sum : = sum + StrToInt(s[i]) else if s[i] in 'ABCDEFGHIJKLMNOPQRSTUVWXYZ' then k : = k + 1 ; end ; writeln(sum, ' ', k) ;

end.

Валюшк 7 июн. 2020 г., 06:01:43 | 10 - 11 классы

Строки в Си Задан текст, состоящий из заглавных латинских букв и цифр?

Строки в Си Задан текст, состоящий из заглавных латинских букв и цифр.

Определите, сколько раз каждая гласная буква встречается в тексте.

Результат распечатайте в виде : Буква – количество.

(гласные : A, E, I, O, U).

Chichigina77 15 янв. 2020 г., 20:08:04 | 10 - 11 классы

Дана строка символов?

Дана строка символов.

Замените в строке все маленькие буквы на одноименные большие буквы.

Надо решить в Pascal.

Net.

Nyaro200 21 апр. 2020 г., 02:52:37 | 10 - 11 классы

Дана строка состоящая из букв и цифр?

Дана строка состоящая из букв и цифр.

Сложить все цифры в строке.

Ilonabolataeva 27 дек. 2020 г., 21:57:08 | 10 - 11 классы

Дана строка символов, состоящая только из цифр?

Дана строка символов, состоящая только из цифр.

Определить, сколько раз среди них встречается цифра 5.

Ilmatrastamp 24 апр. 2020 г., 12:12:22 | 5 - 9 классы

Дана строка, состоящая из заглавных английских букв и цифр?

Дана строка, состоящая из заглавных английских букв и цифр.

Вывести первый символ строки.

Входные данные : В единственной строке входного потока дана строка символов, длина которой не превышает 255.

Выходные данные : В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : KDSFJHGLKDJGHLSUIRH5HGUHG58H.

Пример выходного файла (output.

Txt) : K.

Еваника 10 мар. 2020 г., 08:55:01 | 5 - 9 классы

С клавиатуры вводится строка состоящая из букв, знака пробела и циифр?

С клавиатуры вводится строка состоящая из букв, знака пробела и циифр.

Определите количество цифр в этой строке.

Zm755 29 июн. 2020 г., 21:10:09 | 5 - 9 классы

Дана строка?

Дана строка.

Среди символов строки встречаются цифры.

Написать программу, вычисляющую сумму всех цифр строки.

ВЫПУСКНИК2014 10 янв. 2020 г., 18:59:00 | 10 - 11 классы

ПРОГРАММА НА PASCAL?

ПРОГРАММА НА PASCAL!

Распечатать введенную строку, удалив из нее символы, не являющиеся буквами и цифрами, и ЗАМЕНИВ КАЖДУЮ ЦИФРУ НА " * * ".

Никит228558 17 окт. 2020 г., 22:24:55 | 10 - 11 классы

Дана строка?

Дана строка.

Среди символов встречаются цифры.

Написать программу, вычисляющую сумму всех цифр.

Mada5 10 февр. 2020 г., 11:41:49 | 10 - 11 классы

Паскаль, помогите 1?

Паскаль, помогите 1.

Дана строка состоящая из русских букв.

Преобразовать в ней все прописные буквы в строчные.

Перед вами страница с вопросом Дана строка символов состоящая из букв и цифр определить сумму всех цифр в этой сроке и количество прописных заглавных букв на PASCAL?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.