Помогите, Pascal ABC?

Информатика | 10 - 11 классы

Помогите, Pascal ABC.

Дано предложение.

Если в этом предложении первая буква встречается более 3 раз, заменить её на восклицательный знак.

Исходный текст задать самостоятельно таким образом, чтобы решалась задача.

Ответить на вопрос
Ответы (1)
Ladymari91 13 нояб. 2020 г., 18:21:31

/ / PascalABC.

NET 3.

1 сборка 1239

begin var s : = ReadlnString('s = ') ; var c : = s[1] ; if s.

ToLower().

ToCharArray().

Count(x - > ; x = c) > ; = 3 then begin s : = s.

Replace(LowCase(c), '!

') ; s : = s.

Replace(UpCase(c), '!

') ; end ; writeln(s) ;

end.

Vermolenkova 1 нояб. 2020 г., 17:16:38 | 5 - 9 классы

Задача в Pascal ABC?

Задача в Pascal ABC.

Задайте массив из 10 элементов с помощью датчика случайных чисел.

Замените элементы массива, которые больше введенного с клавиатуры числа N.

Выведите на экран исходный и полученный массив.

Пожалуйста.

Richgirl 19 мар. 2020 г., 01:23:26 | 5 - 9 классы

ПОМОГИТЕ ПОЖАЛУЙСТА?

ПОМОГИТЕ ПОЖАЛУЙСТА!

1) В заданном предложении заменить все гласные на парные гласные.

2) В заданном предложении подсчитать количество букв С.

Заменить все буквы С на Ш.

Подсчитать сколько раз в полученном предложении встречается буква Ш.

Elgunaze 3 нояб. 2020 г., 15:50:35 | 5 - 9 классы

Help?

Help!

Только первые задачи!

Плиз!

Pascal ABC.

Irka7 25 мая 2020 г., 10:45:46 | 10 - 11 классы

Помогите с Pascal пожалуйста Задача : Подсчитать кол - во вхождений заданной буквы в строку и заменить эту букву на другую?

Помогите с Pascal пожалуйста Задача : Подсчитать кол - во вхождений заданной буквы в строку и заменить эту букву на другую.

Srybtsova1 7 апр. 2020 г., 22:03:21 | 5 - 9 классы

Срочно?

Срочно!

Pascal

Из заданного текста предложения выбрать и напечатать только те символы, которые встречаются в нем только один раз (в том порядке, в котором они встречаются в тексте).

Lololohka735 31 июл. 2020 г., 12:51:50 | 10 - 11 классы

Нужно составить программу в паскале ABC?

Нужно составить программу в паскале ABC!

Поставить в предложении вместо пробелов восклицательные знаки.

Sigida231 16 июл. 2020 г., 15:39:17 | 10 - 11 классы

Ребята, помогите пожалуйста написать программу в ABC Pascal?

Ребята, помогите пожалуйста написать программу в ABC Pascal.

Вот условие задачи :

Дан файл, содержащий текст на русском языке.

В предложениях некоторые из слов записаны подряд несколько раз (предложение заканчивается точкой или восклицательным знаком).

Получить в новом файле отредактированный текст, в котором удалены повторные вхождения слов в предложение.

Заранее вам огромное спасибо : ).

Mandzyukn 5 мая 2020 г., 14:09:44 | 10 - 11 классы

Дан текст из строчных латинских букв, за которыми следует точка?

Дан текст из строчных латинских букв, за которыми следует точка.

Включить в множество первые вхождения букв в текст, сохраняя их исходный взаимный порядок.

Pascal.

Решить с использованием процедур.

Cafia25 26 нояб. 2020 г., 04:52:15 | 5 - 9 классы

1. Дано предложение?

1. Дано предложение.

Подсчитать число пробелов стоящих на нечетных местах, и заменить такие пробелы на символ « * ».

2. Дано слово, состоящее из количества букв кратного четырем.

Поменять в нем буквы следующим образом : первую с четвертой, вторую с третьей, пятую с восьмой, шестую с седьмой и т.

Д. Например, из слова «карандаш» должны получить «аракшадн».

Язык Pascal ABC.

Paqrf 30 дек. 2020 г., 23:57:29 | 10 - 11 классы

На строки :Дан текст из букв и цифр?

На строки :

Дан текст из букв и цифр.

Заменить все нули в тексте на букву А, а все единицы на букву М.

Подсчитать число замен.

Pascal ABC.

Net type const.

Если вам необходимо получить ответ на вопрос Помогите, Pascal ABC?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.