Задан номер мобильного телефона?

Информатика | 10 - 11 классы

Задан номер мобильного телефона.

Определить, какие цифры отсутствуют в этом номере.

Входные данные : В единственной строке задан номер мобильного телефона.

Выходные данные : В первой строке вывести количество отсутствующих в номере цифр.

Во второй строке в порядке возрастания вывести отсутствующие цифры, разделенные пробелом.

Ответить на вопрос
Ответы (1)
Lebedevalizok 18 дек. 2020 г., 17:47:10

/ / PascalABC.

NET 3.

2 сборка 1318

Var SeNotExist : set of char = ['0', '1', '2', '3', '4', '5', '6', '7', '8', '9'] ; ArrNotExist : array of char ; count, i : integer ; Num : string ;

begin readln(Num) ; for i : = 1 to length(Num) do SeNotExist - = [Num[i]] ; foreach var x in SeNotExist do begin inc(count) ; setlength(ArrNotExist, count) ; ArrNotExist[count - 1] : = x ; end ; sort(ArrNotExist) ; writeln(count) ; ArrNotExist.

Print(' ') ;

end.

Пример ввода :

81233214554

Пример вывода :

4

0 6 7 9.

Anastasia19jeni 1 нояб. 2020 г., 06:21:23 | 10 - 11 классы

Даны два целых числа?

Даны два целых числа.

Определить, какое из них больше или определить их равенство.

Вывести знак '> ; ' если первое число больше, знак '< ; ' если второе число больше, знак ' = ' если числа равны.

Входные данные : Выходные данные : Во входном потоке в первой строке через пробел заданы целые числа A и B ( - 30000 < ; A, B < ; 30000).

В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : 5 7 Пример выходного файла (output.

Txt) : < ;

Ваня147 14 дек. 2020 г., 12:30:36 | 5 - 9 классы

Дана строка, состоящая из русских слов, разделенных пробелами (одним или несколькими)?

Дана строка, состоящая из русских слов, разделенных пробелами (одним или несколькими).

Вывести строку, содержащую эти же слова (разделенные одним пробелом), но расположенные в обратном порядке.

Help me!

Marinapavlova21 30 авг. 2020 г., 08:23:36 | 5 - 9 классы

Дана строка, содержащая, по крайней мере, один символ пробела?

Дана строка, содержащая, по крайней мере, один символ пробела.

Вывести подстроку, расположенную между первым и последним пробелом исходной строки.

Если строка содержит только один пробел, то вывести пустую строку после пробела.

Вивь 17 нояб. 2020 г., 23:19:06 | 5 - 9 классы

Дана кодировочная таблица(первая цифра кода - номер строки, вторая номер столбца) С помощью этой таблицы зашифруйте фразу : Я умею работать с информацией?

Дана кодировочная таблица(первая цифра кода - номер строки, вторая номер столбца) С помощью этой таблицы зашифруйте фразу : Я умею работать с информацией!

А ты?

Ilmatrastamp 24 апр. 2020 г., 12:12:22 | 5 - 9 классы

Дана строка, состоящая из заглавных английских букв и цифр?

Дана строка, состоящая из заглавных английских букв и цифр.

Вывести первый символ строки.

Входные данные : В единственной строке входного потока дана строка символов, длина которой не превышает 255.

Выходные данные : В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : KDSFJHGLKDJGHLSUIRH5HGUHG58H.

Пример выходного файла (output.

Txt) : K.

Namakiti10 18 янв. 2020 г., 12:47:30 | 10 - 11 классы

Дана матрица L(3, 3), найти и вывести номера строк?

Дана матрица L(3, 3), найти и вывести номера строк.

, эле­менты которых одинаковы.

Вывести матрицу L по строкам.

Slameman20141 7 июл. 2020 г., 16:31:54 | 10 - 11 классы

Добрый вечер )) Помогите пожалуйста решит данную задачу)) Задача на множества : Дана строка из букв латинского алфавита, цифр, русских букв и знаков препинания?

Добрый вечер )) Помогите пожалуйста решит данную задачу)) Задача на множества : Дана строка из букв латинского алфавита, цифр, русских букв и знаков препинания.

Вырезать из строки цифры и записать их а отдельную строку в том же порядке, в каком они были расположены в исходной.

Вывести на печать содержимое полученных строк.

Входные данные : исходная строка

Vv1, 32qq1 / 4b5b45!

Выходные данные : две полученные строки

13214545

Vv, qq / bb45!

За ране спасибо!

Иришка356587 15 июл. 2020 г., 20:29:41 | 10 - 11 классы

Решение задач с использованием файлов 1?

Решение задач с использованием файлов 1.

Дано число к и файл, содержащий целые числа.

Вывести элемент файла с номером к.

Если такой элемент отсутствует, то вывести 0.

2. Дан файл вещественных чисел.

Создать 2 новых файла, в первый из которых содержит строки исходного файла с четными номерами, а второй с нечетными номерами.

Наська200419966 21 мар. 2020 г., 22:38:49 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется сначала вывести элементы, стоящие на четных местах, затем — на нечетных.

Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных Требуется в одной строке через пробел вывести элементы массива в заданном порядке.

Inglis1111 12 нояб. 2020 г., 11:31:16 | 5 - 9 классы

Задача?

Задача.

Дано натуральное число N (1< ; = N< ; = 100000).

Требуется написать программу, определяющую для N, какая цифра больше – первая или последняя.

Формат входных данных : В единственной строке задано число N.

Формат выходных данных : В единственной строке необходимо вывести один символ : = , если цифры одинаковые, < ; , если первая цифра меньше последней, > ; , если первая цифра больше последней.

На этой странице находится вопрос Задан номер мобильного телефона?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.