Решение задач с использованием файлов 1?

Информатика | 10 - 11 классы

Решение задач с использованием файлов 1.

Дано число к и файл, содержащий целые числа.

Вывести элемент файла с номером к.

Если такой элемент отсутствует, то вывести 0.

2. Дан файл вещественных чисел.

Создать 2 новых файла, в первый из которых содержит строки исходного файла с четными номерами, а второй с нечетными номерами.

Ответить на вопрос
Ответы (1)
Yuliaq 15 июл. 2020 г., 20:29:45

1)

var k, a, i, n : integer ; t : Text ; begin

readln (k) ;

n : = 0 ; Assign (t, 'test.

Txt') ; Reset(t) ; i : = 1 ; while not Eof(t) do begin

read (t, a) ; if a = k then n : = i ; i : = i + 1 ; end ; Close (t) ;

writeln (n) ;

end.

2)

var

t, t1, t2 : Text ; i : integer ; a : real ;

begin Assign (t, 'text.

Txt') ;

Reset (t) ; Assign (t1, 'r1.

Txt') ; rewrite (t1) ;

Assign (t2, 'r2.

Txt') ;

rewrite (t2) ; i : = 1 ; while not Eof(t)

do

begin read (t, a) ; if i mod 2 = 1 then write (t1, a : 3 : 3, ' ') else write (t2, a : 3 : 3, ' ') ; i : = i + 1 ; end ; Close (t) ;

Close (t1) ;

Close (t2) ;

end.

Zakievaevelina 14 мар. 2020 г., 09:30:41 | 5 - 9 классы

Помогите?

Помогите!

Нужно написать программу на паскале : Дан файл целых чисел f1.

Создать файл f2 содержащий только отрицательные числа из файла f1.

Nickvik9 11 авг. 2020 г., 03:53:45 | 10 - 11 классы

Задачи на записи и файлы?

Задачи на записи и файлы.

№ 1. Пусть дан файл целых чисел.

Определите длину наибольшего интервала возрастания и среднее арифметическое чисел этого интервала.

№ 2. Имеется типизированный файл с числами.

Изменить все его элементы, порядковый номер которых кратен трем.

Новые значения вводятся с клавиатуры.

Размер существующего файла неизвестен.

Leokat61 30 апр. 2020 г., 08:50:41 | 10 - 11 классы

Дан текстовый файл?

Дан текстовый файл.

Вывести на экран самую длинную строку из файла.

Через паскале.

Ирка2 9 авг. 2020 г., 08:08:46 | 10 - 11 классы

Дан текстовый файл, содержащий целые числа?

Дан текстовый файл, содержащий целые числа.

Найти количество чисел в файле и их сумму.

Avorizh 30 мая 2020 г., 09:31:01 | 10 - 11 классы

Задача на pascal abc, решить задачу используя type Помогите пожалуйста очень надо) Составить программу которая создает файл каждая строка которого выглядет так : табельный номер, фио, оклад?

Задача на pascal abc, решить задачу используя type Помогите пожалуйста очень надо) Составить программу которая создает файл каждая строка которого выглядет так : табельный номер, фио, оклад.

Ввести в файл данные о 5 - ти работниках и вывести в другой файл максимальный оклад.

AdaGasanova 12 июн. 2020 г., 04:43:46 | 10 - 11 классы

Дан файл f, компоненты которого являются целыми числами?

Дан файл f, компоненты которого являются целыми числами.

Найти количество квадратов нечетных чисел среди компонент файла.

Записать это значение в начало нового файла g.

Остальные значения переписать из исходного файла f.

Лолар1 16 авг. 2020 г., 00:52:17 | 5 - 9 классы

Дан файл, компоненты которого являются целыми числами?

Дан файл, компоненты которого являются целыми числами.

Получить два новых файла, состоящих только из положительных и только отрицательных.

Nasvod 13 апр. 2020 г., 15:56:08 | 10 - 11 классы

Вычисление суммы элементов файла?

Вычисление суммы элементов файла.

Записать в двоичный файл N действительных чисел ; N вводится пользователем.

Вычислить сумму элементов файла и вывести на экран.

Примечание : Файл, в который записывается результат, называется OUTPUT.

DAT для двоичных файлов.

UToppent 5 июл. 2020 г., 23:26:03 | 5 - 9 классы

Дан файл из чисел?

Дан файл из чисел.

Создать второй файл из чисел первого файла, у которых сумма цифр находится в пределе от 12 до 34.

Pascal.

Reageh30 24 нояб. 2020 г., 13:07:08 | 10 - 11 классы

Дан входной файл в котором нужно вывести все четные элементы?

Дан входной файл в котором нужно вывести все четные элементы.

Вы зашли на страницу вопроса Решение задач с использованием файлов 1?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.