Дана строка, содержащая, по крайней мере, один символ пробела?

Информатика | 5 - 9 классы

Дана строка, содержащая, по крайней мере, один символ пробела.

Вывести подстроку, расположенную между первым и последним пробелом исходной строки.

Если строка содержит только один пробел, то вывести пустую строку после пробела.

Ответить на вопрос
Ответы (1)
Lera2000hrob 30 авг. 2020 г., 08:23:39

Pascal

Алгоритм1

var

s : string ;

n1, n2 : integer ;

i, l : integer ;

begin

readln (s) ;

n1 : = 0 ; n2 : = 0 ;

l : = Length(s) ;

for i : = 1 to l do if (s[i] = ' ') then if n1 = 0 then n1 : = i else n2 : = i ;

if n2 = 0 then

s : = ' '

else

s : = copy(s, n1 + 1, n2 - n1 - 1) ;

writeln (s) ;

end.

Алгоритм2 var

s : string ;

n1, n2 : integer ;

i, l : integer ;

r : boolean ;

begin

readln (s) ;

n1 : = 0 ; n2 : = 0 ;

r : = false ;

l : = Length(s) ;

i : = 1 ;

While (i< ; = l) and (not r) do

begin

if s[i] = ' ' then begin n1 : = i ; r : = true ; end ;

i : = i + 1 ;

end ;

r : = false ;

i : = l ;

While (i> ; 0) and (not r) do

begin

if s[i] = ' ' then

begin

n2 : = i ;

r : = true ;

end ;

i : = i - 1 ;

end ;

if n2 = n1 then

s : = ' '

else

s : = copy(s, n1 + 1, n2 - n1 - 1) ;

writeln (s) ;

end.

Ваня147 14 дек. 2020 г., 12:30:36 | 5 - 9 классы

Дана строка, состоящая из русских слов, разделенных пробелами (одним или несколькими)?

Дана строка, состоящая из русских слов, разделенных пробелами (одним или несколькими).

Вывести строку, содержащую эти же слова (разделенные одним пробелом), но расположенные в обратном порядке.

Help me!

Kiri4ka2101 25 февр. 2020 г., 02:39:32 | 10 - 11 классы

Дан текст в виде строки?

Дан текст в виде строки.

Слова в строке разделены несколькими пробелами.

Требуется удалить лишние пробелы, оставив только по одному между словами.

Dima21011979 26 дек. 2020 г., 02:07:37 | 10 - 11 классы

Письмо состояло из 45 строк?

Письмо состояло из 45 строк.

В каждой строке вместе с пробелами было 64 символа.

Сколько байт информации содержало письмо?

ЗаЙкА004567 23 нояб. 2020 г., 13:18:45 | 10 - 11 классы

Ввести с клавиатуры строку?

Ввести с клавиатуры строку.

Сформировать новую строку, в которой все символы из первой строки разделены пробелами.

Помогите, пожалуйста).

Kras22 17 янв. 2020 г., 12:55:20 | 10 - 11 классы

СРОЧНО дана строка, состоящая из двух слов, разделенных пробелом?

СРОЧНО дана строка, состоящая из двух слов, разделенных пробелом.

Написать программу меняющую части строки до и после пробела местами и добавляющую в конец строки восклицательный знак.

Решить в паскале.

Obuhancova 29 янв. 2020 г., 13:51:14 | 10 - 11 классы

Дана символьная строка, содержащая русские буквы, цифры и пробелы?

Дана символьная строка, содержащая русские буквы, цифры и пробелы.

Написать строку задом наперед, удалив из нее все цифры и пробелы.

PrayForUkraine 9 апр. 2020 г., 08:48:27 | 10 - 11 классы

Дана строка символов, состоящий из отдельных слов, разделенных пробелом?

Дана строка символов, состоящий из отдельных слов, разделенных пробелом.

Упорядочить слова по длине (в убыванию) и вывести на печать.

Даю 20 баллов.

Цааж 18 окт. 2020 г., 12:53:20 | 10 - 11 классы

Решить либо на С, С + + , PascalДана строка, состоящая из слов, разделенных пробелами?

Решить либо на С, С + + , Pascal

Дана строка, состоящая из слов, разделенных пробелами.

Напишите программу, удаляющую лишние пробелы и добавляющую недостающие пробелы.

Пробел считается лишним, если он : * стоит в начале строки ; * стоит перед знаком препинания ; * стоит в конце строки ; * следует за пробелом.

Добавить пробел после знака препинания, при условии выполнения предыдущих пунктов.

Kiti2259 24 июн. 2020 г., 06:59:43 | 10 - 11 классы

Дана строка слова в которой разделены пробелом, подсчитайте количество слов в этой строке?

Дана строка слова в которой разделены пробелом, подсчитайте количество слов в этой строке.

Den4ikD 5 нояб. 2020 г., 16:54:29 | 5 - 9 классы

Работая в текстовом редакторе, Миша вставил 7 символов без пробелов, затем скопировал их и вставлял без пробелов до тех пор, пока страница не закончилась?

Работая в текстовом редакторе, Миша вставил 7 символов без пробелов, затем скопировал их и вставлял без пробелов до тех пор, пока страница не закончилась.

При этом символы, не умещающиеся в строку переносились на следующую .

Какой символ бы последним на странице, если в строку вмещаются 61 символ, а строк в странице 35.

Вы зашли на страницу вопроса Дана строка, содержащая, по крайней мере, один символ пробела?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.