Задача?

Информатика | 5 - 9 классы

Задача.

Дано натуральное число N (1< ; = N< ; = 100000).

Требуется написать программу, определяющую для N, какая цифра больше – первая или последняя.

Формат входных данных : В единственной строке задано число N.

Формат выходных данных : В единственной строке необходимо вывести один символ : = , если цифры одинаковые, < ; , если первая цифра меньше последней, > ; , если первая цифра больше последней.

Ответить на вопрос
Ответы (1)
Obalan 12 нояб. 2020 г., 11:31:19

Var n, k : integer ;

begin

readln(n) ;

k : = n mod 10 ;

n : = n div 10 ;

while n> ; 10 do n : = n div 10 ;

if k = n

then writeln(' = ')

else if n< ; k then writeln('< ; ') else writeln('> ; ') ;

end.

Пример :

652843

> ;

Dimamakarenkorus 23 июл. 2020 г., 01:13:36 | 10 - 11 классы

Напишите программу, которая подсчитывает сумму всех цифр в данной строке?

Напишите программу, которая подсчитывает сумму всех цифр в данной строке.

Например, в строке "Sochi - 2014" сумма цифр равна 7.

Формат входных данных

Одна строка, возможно с пробелами, буквами, цифрами и спецсимволами.

Формат результата

Одно число — сумма цифр в строке.

Для Python.

Ilmatrastamp 24 апр. 2020 г., 12:12:22 | 5 - 9 классы

Дана строка, состоящая из заглавных английских букв и цифр?

Дана строка, состоящая из заглавных английских букв и цифр.

Вывести первый символ строки.

Входные данные : В единственной строке входного потока дана строка символов, длина которой не превышает 255.

Выходные данные : В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : KDSFJHGLKDJGHLSUIRH5HGUHG58H.

Пример выходного файла (output.

Txt) : K.

PFK 25 авг. 2020 г., 16:21:55 | 5 - 9 классы

Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N?

Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N.

Формат входных данных Задано единственное число N.

Формат выходных данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.

Warfacezadrot 6 окт. 2020 г., 01:56:10 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Определить, какое из его цифр больше : первая или последняя.

Titan55557 24 июн. 2020 г., 01:32:35 | 5 - 9 классы

Дано пятизначное натуральное число?

Дано пятизначное натуральное число.

Определить его первую и последнюю цифры.

Мастер20001 10 февр. 2020 г., 12:22:15 | 5 - 9 классы

Дано натуральное число N (1< ; = N< ; = 10000)?

Дано натуральное число N (1< ; = N< ; = 10000).

Требуется написать программу, определяющую для N, какая цифра больше – первая или последняя.

Клубничка311 29 дек. 2020 г., 21:54:23 | 5 - 9 классы

Дано натуральное трёхзначное число n?

Дано натуральное трёхзначное число n.

Найдите сумму и произведение цифр в нём.

Формат входных данных

Вводится целое число n (100≤n≤999)

Формат выходных данных

Требуется вывести сумму и произведение его цифр через пробел.

Olyapen 18 дек. 2020 г., 17:47:06 | 10 - 11 классы

Задан номер мобильного телефона?

Задан номер мобильного телефона.

Определить, какие цифры отсутствуют в этом номере.

Входные данные : В единственной строке задан номер мобильного телефона.

Выходные данные : В первой строке вывести количество отсутствующих в номере цифр.

Во второй строке в порядке возрастания вывести отсутствующие цифры, разделенные пробелом.

Serjana 9 окт. 2020 г., 05:42:28 | 10 - 11 классы

Уровень B?

Уровень B.

Задача M.

Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221).

Входные данные Входная строка содержит одно натуральное число.

Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'NO', если такой пары цифр нет.

Примеры входные данные 5221 выходные данные YES входные данные 1232 выходные данные NO

Уровень C.

Задача O.

Две одинаковые цифры Напишите программу, которая определяет, верно ли, что введённое число содержит по крайней мере две одинаковых цифры, возможно, не стоящие рядом (как, например, 212).

Входные данные Входная строка содержит одно натуральное число.

Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, и слово 'NO', если такой пары цифр нет.

Примеры входные данные 212 выходные данные YES входные данные 12345 выходные данные NO.

Akolesova2002 30 нояб. 2020 г., 01:46:11 | 5 - 9 классы

Дано натуральное число N?

Дано натуральное число N.

Напишите функцию (Pascal), вычисляющую сумму цифр числа N.

Входные данные

Задано единственное число N

Выходные данные

Необходимо вывести сумму цифр числа N.

Примеры

входные данные

12

выходные данные

3

ПРОГРАММА БЫЛА, НО ВВОДИЛ 12 И ВЫВОДИЛ ВМЕСТО 3, 0.

Вы зашли на страницу вопроса Задача?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.