Дана строка, состоящая из русских слов, разделенных пробелами (одним или несколькими)?

Информатика | 5 - 9 классы

Дана строка, состоящая из русских слов, разделенных пробелами (одним или несколькими).

Вывести строку, содержащую эти же слова (разделенные одним пробелом), но расположенные в обратном порядке.

Help me!

Ответить на вопрос
Ответы (1)
Okcanakisy 14 дек. 2020 г., 12:30:40

Var s : integer ; t, t1, t2 : string ;

b1 : boolean ;

begin b1 : = false ; writeln('введите строку') ; readln(t) ; t2 : = '' ; repeat p1 : = pos(' ', t) ; if p1> ; 0 then begin t2 : = copy(t, 1, p1 - 1) ; if length(t2)> ; 0) then t1 : = t2 + ' ' + t1 ; delete(t, 1, p1) ; end else if (length(t)> ; = 1) then / / обработка кнца строки begin t2 : = t ; t1 : = t2 + ' ' + t1 ; b1 : = true ; end else b1 : = true ; / / еще одна проверка, если пследний символ строки - пробел

until (b1 = true) ; writeln('Ответ ', t1)

end.

Daynat 2 февр. 2020 г., 11:55:02 | 10 - 11 классы

Дана строка, состоящая из русских слов, набранных заглавными буквами и разделенных пробелами (одним или несколькими)?

Дана строка, состоящая из русских слов, набранных заглавными буквами и разделенных пробелами (одним или несколькими).

Найти количество слов, которые содержат хотя бы одну букву «А».

Kiri4ka2101 25 февр. 2020 г., 02:39:32 | 10 - 11 классы

Дан текст в виде строки?

Дан текст в виде строки.

Слова в строке разделены несколькими пробелами.

Требуется удалить лишние пробелы, оставив только по одному между словами.

Marinapavlova21 30 авг. 2020 г., 08:23:36 | 5 - 9 классы

Дана строка, содержащая, по крайней мере, один символ пробела?

Дана строка, содержащая, по крайней мере, один символ пробела.

Вывести подстроку, расположенную между первым и последним пробелом исходной строки.

Если строка содержит только один пробел, то вывести пустую строку после пробела.

Yakovleffsascha 16 янв. 2020 г., 11:56:50 | 10 - 11 классы

Дана строка, состоящая из русских слов, разделенных пробелом?

Дана строка, состоящая из русских слов, разделенных пробелом.

Определить слово, с наибольшим количеством гласных букв, ребят помогииитее паскаль.

Kulikovacelina 13 дек. 2020 г., 07:54:35 | 10 - 11 классы

Паскаль?

Паскаль.

Дана строка, содержащая слова, разделенные одним пробелом.

Напечатать все слова, предварительно преобразовав каждое из них по следующему правилу : удалить из слова все последующие вхождения первой буквы.

Lenokmalyshok 1 мая 2020 г., 18:53:58 | 1 - 4 классы

Составьте программу вводящую предложения, состоящие из слов, разделенных произвольным количеством пробелов?

Составьте программу вводящую предложения, состоящие из слов, разделенных произвольным количеством пробелов.

Предложения вводятся в одну строку.

Программа должна переписать введенную строку, оставив полько по одному пробелу между словами.

Kras22 17 янв. 2020 г., 12:55:20 | 10 - 11 классы

СРОЧНО дана строка, состоящая из двух слов, разделенных пробелом?

СРОЧНО дана строка, состоящая из двух слов, разделенных пробелом.

Написать программу меняющую части строки до и после пробела местами и добавляющую в конец строки восклицательный знак.

Решить в паскале.

PrayForUkraine 9 апр. 2020 г., 08:48:27 | 10 - 11 классы

Дана строка символов, состоящий из отдельных слов, разделенных пробелом?

Дана строка символов, состоящий из отдельных слов, разделенных пробелом.

Упорядочить слова по длине (в убыванию) и вывести на печать.

Даю 20 баллов.

СинийШар 15 янв. 2020 г., 00:09:44 | 10 - 11 классы

Составьте программу которая находит позицию пробела в строке s состоящей из двух слов разделенных пробелом?

Составьте программу которая находит позицию пробела в строке s состоящей из двух слов разделенных пробелом.

Строка вводится с клавиатуры.

Цааж 18 окт. 2020 г., 12:53:20 | 10 - 11 классы

Решить либо на С, С + + , PascalДана строка, состоящая из слов, разделенных пробелами?

Решить либо на С, С + + , Pascal

Дана строка, состоящая из слов, разделенных пробелами.

Напишите программу, удаляющую лишние пробелы и добавляющую недостающие пробелы.

Пробел считается лишним, если он : * стоит в начале строки ; * стоит перед знаком препинания ; * стоит в конце строки ; * следует за пробелом.

Добавить пробел после знака препинания, при условии выполнения предыдущих пунктов.

Вы перешли к вопросу Дана строка, состоящая из русских слов, разделенных пробелами (одним или несколькими)?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.