Дана строка, состоящая из заглавных английских букв и цифр?

Информатика | 5 - 9 классы

Дана строка, состоящая из заглавных английских букв и цифр.

Вывести первый символ строки.

Входные данные : В единственной строке входного потока дана строка символов, длина которой не превышает 255.

Выходные данные : В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : KDSFJHGLKDJGHLSUIRH5HGUHG58H.

Пример выходного файла (output.

Txt) : K.

Ответить на вопрос
Ответы (1)
Лысковец95 24 апр. 2020 г., 12:12:29

Program Zadacha ;

Const max = 255 ;

Var t : Text ;

i : Integer ;

s : String[max] ;

Begin

Assign(t, 'd : \ input.

Txt') ;

Reset(t) ; i : = 2 ;

While Not Eof(t) Do

Begin

If i > ; max Then

Break ;

Read(t, s) ;

End ;

Close(t) ;

Assign(t, 'd : \ output.

Txt') ;

Rewrite(t) ;

Write(t, s[1]) ;

Close(t) ;

End.

Anastasia19jeni 1 нояб. 2020 г., 06:21:23 | 10 - 11 классы

Даны два целых числа?

Даны два целых числа.

Определить, какое из них больше или определить их равенство.

Вывести знак '> ; ' если первое число больше, знак '< ; ' если второе число больше, знак ' = ' если числа равны.

Входные данные : Выходные данные : Во входном потоке в первой строке через пробел заданы целые числа A и B ( - 30000 < ; A, B < ; 30000).

В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : 5 7 Пример выходного файла (output.

Txt) : < ;

Кевин27 24 мар. 2020 г., 18:22:30 | 5 - 9 классы

Задача «Справедливое распределение»У Андрея было А грамм крупы, у Бориса – В грамм, а у Сергея вообще не было крупы?

Задача «Справедливое распределение»

У Андрея было А грамм крупы, у Бориса – В грамм, а у Сергея вообще не было крупы.

Ребята сварили кашу и разделили ее поровну на троих.

Поскольку Сергей был без крупы, то

в благодарность за кашу он отдал С конфет Андрею с Борисом.

Требуется написать программу, которая определяет, как Андрей и Борис должны

поделить конфеты по справедливости.

Конфеты делить на части нельзя.

Описание входных данных

Входные данные вводятся с клавиатуры или из файла input.

Txt. В единственной

строке записаны три целых числа А, В и С.

Описание выходных данных

Выходные данные выводятся на экран или в файл output.

Txt. В единственной

строке необходимо вывести два целых числа — количество конфет у Андрея и количество

конфет у Бориса.

Пример входных и выходных данных

Входные данные Выходные данные

700 500 12 9 3.

Lfitymrf123 8 сент. 2020 г., 10:12:24 | 5 - 9 классы

В кафе продается мороженое по 3 или по 5 шариков в порции?

В кафе продается мороженое по 3 или по 5 шариков в порции.

Определить, можно ли купить K шариков мороженного.

Входные данные : Во входном потоке в первой строке задано натуральное число К (K < ; = 1000) Выходные данные : Вывести YES или NO.

Пример входного файла (input.

Txt) : 2.

Larisapolukhin1 25 февр. 2020 г., 23:19:20 | 5 - 9 классы

Вывести все значения элементов заданной числовой последовательности?

Вывести все значения элементов заданной числовой последовательности.

Входные данные : Выходные данные : Во входном потоке в первой строке записано единственное целое число N (0 < ; N < ; = 100) - число элементов числовой последовательности ; Во второй строке перечислены значения элементов целочисленной последовательности (через пробел).

Значения элементов по модулю не превышают 1000.

В выходной поток вывести значения элементов числовой последовательности в столбик, каждое с новой строки.

Пример входного файла (input.

Txt) : 10 43 564 32 76 342 76 43 342 876 42 Пример выходного файла (output.

Txt) : 43 564 32 76 342 76 43 342 876 42 ПОМОГИТЕ ПОЖАЛУЙСТААА!

Ghfgdfg 16 сент. 2020 г., 11:45:38 | 1 - 4 классы

Дано натуральное трехзначное число N ?

Дано натуральное трехзначное число N .

Определить сумму и произведение его цифр.

Имя входного файла Input.

Txt, имя выходного файла output.

Txt.

Komogorova07 5 июн. 2020 г., 07:16:59 | 10 - 11 классы

Заданы два натуральных числа N и K?

Заданы два натуральных числа N и K.

Вычислить остаток от деления первого числа на второе.

Входные данные : Входной поток содержит два целых числа N и K (1 < ; = N < ; = 10 ^ 100, 1 < ; = K < ; = 10 ^ 9) записанные в двух отдельных строках.

Выходные данные : В выходной поток выведите остаток от деления N на K.

Пример входного файла (input.

Txt) : 239 16 Пример выходного файла (output.

Txt) : 15.

Adamgulova2002 28 сент. 2020 г., 16:42:34 | 10 - 11 классы

Заданы два натуральных числа N и K?

Заданы два натуральных числа N и K.

Вычислить остаток от деления первого числа на второе.

Входные данные : Входной поток содержит два целых числа N и K (1 < ; = N < ; = 10 ^ 100, 1 < ; = K < ; = 10 ^ 9) записанные в двух отдельных строках.

Выходные данные : В выходной поток выведите остаток от деления N на K.

Пример входного файла (input.

Txt) : 239 16 Пример выходного файла (output.

Txt) : 15.

Варя81 7 окт. 2020 г., 00:35:35 | 5 - 9 классы

Напишите программу, которая заменяет расширение у заданного имени файла?

Напишите программу, которая заменяет расширение у заданного имени файла.

Входные данные Первая строка содержит имя файла, которое нужно изменить.

Во второй строке записано нужное расширение.

Выходные данные Программа должна вывести изменённое имя файла с заданным расширением.

Примеры входные данные qwerty exe выходные данные qwerty.

Exe входные данные qwetry.

Old. pas html выходные данные qwetry.

Old. html.

Маша133 31 окт. 2020 г., 06:11:15 | 10 - 11 классы

Напишите программу, которая удаляет из строки все повторяющиеся символы?

Напишите программу, которая удаляет из строки все повторяющиеся символы.

Входные данные

На вход программы подаётся строка, содержащая символы таблицы ASCII.

Выходные данные

Программа должна вывести исходную строку, из которой удалены все повторяющиеся символы.

Примеры

входные данные

abc13a1b2z3c

выходные данные

abc132z

входные данные

QWasd123

выходные данные

QWasd123

Pascal ABC 1.

8.

Oklubkova 10 дек. 2020 г., 09:26:25 | 5 - 9 классы

Напишите программу, которая выбирает максимальное и минимальное из пяти введённых чисел?

Напишите программу, которая выбирает максимальное и минимальное из пяти введённых чисел.

Входные данные

Входная строка содержит 5 целых чисел, разделённых пробелами.

Выходные данные

В первой строке нужно вывести минимальное из введённых чисел, во второй строке – максимальное.

Примеры

входные данные

1 2 3 4 5

выходные данные

1

5

На паскале.

Перед вами страница с вопросом Дана строка, состоящая из заглавных английских букв и цифр?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.