Добрый вечер )) Помогите пожалуйста решит данную задачу)) Задача на множества : Дана строка из букв латинского алфавита, цифр, русских букв и знаков препинания?

Информатика | 10 - 11 классы

Добрый вечер )) Помогите пожалуйста решит данную задачу)) Задача на множества : Дана строка из букв латинского алфавита, цифр, русских букв и знаков препинания.

Вырезать из строки цифры и записать их а отдельную строку в том же порядке, в каком они были расположены в исходной.

Вывести на печать содержимое полученных строк.

Входные данные : исходная строка

Vv1, 32qq1 / 4b5b45!

Выходные данные : две полученные строки

13214545

Vv, qq / bb45!

За ране спасибо!

Ответить на вопрос
Ответы (1)
СБЛиана 7 июл. 2020 г., 16:31:59

Var s, sd, so : string ; digits : set of '0'.

'9' ; i : integer ;

begin writeln('Введите текстовую строку') ; readln(s) ; digits : = ['0'.

'9'] ; sd : = '' ; so : = '' ; for i : = 1 to length(s) do if s[i] in digits then sd : = sd + s[i] else so : = so + s[i] ; writeln('Результат : ') ; writeln(sd) ; writeln(so)

end.

Тестовое решение :

Введите текстовую строку

Vv1, 32qq1 / 4b5b45!

Результат :

13214545

Vv, qq / bb!

Nyaro200 21 апр. 2020 г., 02:52:37 | 10 - 11 классы

Дана строка состоящая из букв и цифр?

Дана строка состоящая из букв и цифр.

Сложить все цифры в строке.

Dimamakarenkorus 23 июл. 2020 г., 01:13:36 | 10 - 11 классы

Напишите программу, которая подсчитывает сумму всех цифр в данной строке?

Напишите программу, которая подсчитывает сумму всех цифр в данной строке.

Например, в строке "Sochi - 2014" сумма цифр равна 7.

Формат входных данных

Одна строка, возможно с пробелами, буквами, цифрами и спецсимволами.

Формат результата

Одно число — сумма цифр в строке.

Для Python.

Ilmatrastamp 24 апр. 2020 г., 12:12:22 | 5 - 9 классы

Дана строка, состоящая из заглавных английских букв и цифр?

Дана строка, состоящая из заглавных английских букв и цифр.

Вывести первый символ строки.

Входные данные : В единственной строке входного потока дана строка символов, длина которой не превышает 255.

Выходные данные : В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : KDSFJHGLKDJGHLSUIRH5HGUHG58H.

Пример выходного файла (output.

Txt) : K.

Джувия5Локсар 20 июл. 2020 г., 11:06:48 | 5 - 9 классы

1. Даны две строки?

1. Даны две строки.

Написать программу для вывода на экран слова полученного из суммы двух первых букв каждой строки.

2. Дана строка.

Определить есть ли в данной строке буква h.

Vovago30 18 июн. 2020 г., 16:57:55 | 10 - 11 классы

Заданы две строки А и В?

Заданы две строки А и В.

Можно ли переставить буквы в одном из слов так , чтобы слова стали одинаковыми?

Формат входных данных первая строка входного файла содержит строку A состоящую из строчных букв английского алфавита (1< ; = |B|< ; = 1000).

Вторая строка содержит строку B в таком же формате формат выходных данных.

Obuhancova 29 янв. 2020 г., 13:51:14 | 10 - 11 классы

Дана символьная строка, содержащая русские буквы, цифры и пробелы?

Дана символьная строка, содержащая русские буквы, цифры и пробелы.

Написать строку задом наперед, удалив из нее все цифры и пробелы.

Милена678985 11 сент. 2020 г., 01:41:18 | 5 - 9 классы

Дана строка?

Дана строка.

Поместить все цифры строки в отдельную строку.

Паскаль.

Помогите пожалуйста, решить!

Olyapen 18 дек. 2020 г., 17:47:06 | 10 - 11 классы

Задан номер мобильного телефона?

Задан номер мобильного телефона.

Определить, какие цифры отсутствуют в этом номере.

Входные данные : В единственной строке задан номер мобильного телефона.

Выходные данные : В первой строке вывести количество отсутствующих в номере цифр.

Во второй строке в порядке возрастания вывести отсутствующие цифры, разделенные пробелом.

Нассссссстттттяяяя 18 окт. 2020 г., 00:26:05 | 10 - 11 классы

Вам даны две строки s и t, определите длину наибольшей строки, которая встречается в обеих?

Вам даны две строки s и t, определите длину наибольшей строки, которая встречается в обеих.

Формат входных данных Первая строка входных данных содержит строку s, вторая строка содержит строку t.

Обе строки состоят только из строчных латинских букв.

1 < ; = длина строк < ; = 1, 000.

Формат выходных данных Выведите ответ к задаче.

Маша133 31 окт. 2020 г., 06:11:15 | 10 - 11 классы

Напишите программу, которая удаляет из строки все повторяющиеся символы?

Напишите программу, которая удаляет из строки все повторяющиеся символы.

Входные данные

На вход программы подаётся строка, содержащая символы таблицы ASCII.

Выходные данные

Программа должна вывести исходную строку, из которой удалены все повторяющиеся символы.

Примеры

входные данные

abc13a1b2z3c

выходные данные

abc132z

входные данные

QWasd123

выходные данные

QWasd123

Pascal ABC 1.

8.

На этой странице сайта вы найдете ответы на вопрос Добрый вечер )) Помогите пожалуйста решит данную задачу)) Задача на множества : Дана строка из букв латинского алфавита, цифр, русских букв и знаков препинания?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.