Разработать алгоритм для ввода четырёх целых чисел и вычисление их среднего арифметического?

Информатика | 5 - 9 классы

Разработать алгоритм для ввода четырёх целых чисел и вычисление их среднего арифметического.

Протестировать алгоритм на исходных данных : - 5, 8, - 1, 9.

Линейный алгоритм.

Ответить на вопрос
Ответы (1)
АрэкуХамира 3 сент. 2020 г., 12:28:42

Program znanija.

Com ;

var a, b, c, d : integer ;

sr : real ;

begin

read(a, b, c, d) ;

sr = (a + b + c + d) / 4 ;

write(sr : 5 : 2)

end.

Norepiytumbrco 25 февр. 2020 г., 10:04:00 | 10 - 11 классы

Дано целое число А?

Дано целое число А.

Если значение А меньше 0 то необходимо удвоить его.

Разработать схему алгоритма для решения этой задачи.

Протестировать алгоритм для А = 6, А = - 10, А = 0.

Olyapetuhova 26 сент. 2020 г., 11:29:48 | 5 - 9 классы

Разработать схему алгоритма для подсчёта количества отрицательных чисел среди целых чисел а, в, с?

Разработать схему алгоритма для подсчёта количества отрицательных чисел среди целых чисел а, в, с.

Протестировать алгоритм для всех возможных случаев (когда количество отрицательных чисел равно 0, 1, 2, 3, )

Помогите кто понимает)).

Sumluk 27 июл. 2020 г., 11:23:20 | 10 - 11 классы

Пожалуйста, помогите составить программу правильно?

Пожалуйста, помогите составить программу правильно!

Вот условие : Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран этот же массив в прямом и обратном порядке.

Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

На Паскале.

Викториэта 9 июл. 2020 г., 05:13:00 | 5 - 9 классы

Написать на языке Паскаль программу ввода четырёх целых чисел и вычисления их среднего арифметического?

Написать на языке Паскаль программу ввода четырёх целых чисел и вычисления их среднего арифметического.

Протестировать программу на различных исходных данных (включая вещественные числа) и доказать правильность её работы.

Mashadinos 3 янв. 2020 г., 03:25:54 | 5 - 9 классы

1. Разработать схему алгоритма для ввода четырёх целых чисел и вычисления их среднего арифметического?

1. Разработать схему алгоритма для ввода четырёх целых чисел и вычисления их среднего арифметического.

Протестировать алгоритм на различных исходных данных (включая вещественные числа) и доказать правильность его работы.

2. Вводятся величины X, Y целого типа.

Разработать схему алгоритма для обмена значений величин.

Необходимо использовать вспомогательную величину Т.

Протестировать алгоритм для X = 5 и Y = - 11.

Aksiniazorina 10 апр. 2020 г., 22:02:15 | 5 - 9 классы

Разработать схему алгоритма для вычисления выражения :S = (2x + y)(x - y)Протестировать алгоритм для следующих исходных данных :1)x = 2, y = 12)x = 3, y = 0 3) x = 0, y = - 2?

Разработать схему алгоритма для вычисления выражения :

S = (2x + y)(x - y)

Протестировать алгоритм для следующих исходных данных :

1)x = 2, y = 12)x = 3, y = 0 3) x = 0, y = - 2.

KiskaLove2016 30 окт. 2020 г., 13:54:02 | 10 - 11 классы

Нужно найти среднее арифметическое всех целых чисел от а до б это должен быть алгоритм?

Нужно найти среднее арифметическое всех целых чисел от а до б это должен быть алгоритм.

LexanDros 2 нояб. 2020 г., 07:06:43 | 10 - 11 классы

Разработайте алгоритм вычисления функции v?

Разработайте алгоритм вычисления функции v.

Dartwey 19 окт. 2020 г., 21:00:10 | 10 - 11 классы

Разработайте алгоритм вычисления функции z?

Разработайте алгоритм вычисления функции z.

Olollik 23 нояб. 2020 г., 05:35:18 | 5 - 9 классы

Дано целое число A?

Дано целое число A.

Если значение A > 0, то необходимо увеличить его на единицу.

Разработать схему алгоритма для решения этой задачи.

Протестировать алгоритм для A = 5, A = - 4, A = 0.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Разработать алгоритм для ввода четырёх целых чисел и вычисление их среднего арифметического?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.