Написать на языке Паскаль программу ввода четырёх целых чисел и вычисления их среднего арифметического?

Информатика | 5 - 9 классы

Написать на языке Паскаль программу ввода четырёх целых чисел и вычисления их среднего арифметического.

Протестировать программу на различных исходных данных (включая вещественные числа) и доказать правильность её работы.

Ответить на вопрос
Ответы (1)
Hasanova469 9 июл. 2020 г., 05:13:05

Я не понял по каким числам оно должно работать, ты пишешь при вводе 4 ЦЕЛЫХ чисел а потом протестировать на вещественные.

Что ты имешь ввиду?

Если что то не так то поменяй тип с integer на real.

Program zadacha_1 ;

const n = 4 ;

var Arr : array [1.

N] of integer ; i, sum : integer ;

begin sum : = 0 ; for i : = 1 to n do begin writeln('Введите значение ', i, ' элемента.

') ; read(Arr[i]) ; sum : = sum + Arr[i] ; end ; writeln('Ср.

Арифмитическая сумма равна : ', sum / n) ;

end.

Aaa70 20 мар. 2020 г., 13:18:05 | 5 - 9 классы

Помогите написать программу на паскале?

Помогите написать программу на паскале!

Создать файл а4, состоящий из 28 целых чисел.

Найти среднее арифметическое всех чисел.

Vudi 27 июн. 2020 г., 21:21:09 | 5 - 9 классы

Программа для вычисления среднего арифметического из двух чисел в паскале?

Программа для вычисления среднего арифметического из двух чисел в паскале.

Mashadinos 3 янв. 2020 г., 03:25:54 | 5 - 9 классы

1. Разработать схему алгоритма для ввода четырёх целых чисел и вычисления их среднего арифметического?

1. Разработать схему алгоритма для ввода четырёх целых чисел и вычисления их среднего арифметического.

Протестировать алгоритм на различных исходных данных (включая вещественные числа) и доказать правильность его работы.

2. Вводятся величины X, Y целого типа.

Разработать схему алгоритма для обмена значений величин.

Необходимо использовать вспомогательную величину Т.

Протестировать алгоритм для X = 5 и Y = - 11.

Dfyz192837465 22 янв. 2020 г., 10:09:25 | 10 - 11 классы

Написать программу на языке паскаль ?

Написать программу на языке паскаль .

ПЖЛ ПОМАГИТЕ дан одновременный массив из п целых чисел .

Составить программу вычисления суммы элементов стоящих на четных местах.

Смышлённый 30 окт. 2020 г., 17:54:32 | 5 - 9 классы

Написать программу в паскале которая будет вводить целые числа до 0, подсчитать среднее арифметическое этих чисел?

Написать программу в паскале которая будет вводить целые числа до 0, подсчитать среднее арифметическое этих чисел.

MariaWay111 10 мая 2020 г., 14:17:11 | 5 - 9 классы

Написать программу которая вычисляет среднее арифметическое последовательности из десяти чисел?

Написать программу которая вычисляет среднее арифметическое последовательности из десяти чисел.

Числа вводятся во время работы программы(письменно).

Bakunova02 10 февр. 2020 г., 16:22:07 | 5 - 9 классы

Написать программу, которая вводит массив из N вещественных случайных чисел, лежащих в диапазоне от - 10 до 10?

Написать программу, которая вводит массив из N вещественных случайных чисел, лежащих в диапазоне от - 10 до 10.

Вывести на экран полученный массив и массив, составленный только из нечётных элементов исходного.

Протестировать программу.

Nurtjt99 9 дек. 2020 г., 14:45:10 | 5 - 9 классы

1. Найти среднее арифметическое и среднее геометрическое двух чисел?

1. Найти среднее арифметическое и среднее геометрическое двух чисел.

Написать программу (Паскаль).

НастяMaltseva 6 июл. 2020 г., 20:55:41 | 5 - 9 классы

Написать б \ с и программу ввода трех целых чисел и вычисления их среднего арифметического?

Написать б \ с и программу ввода трех целых чисел и вычисления их среднего арифметического.

Белей 3 сент. 2020 г., 12:28:39 | 5 - 9 классы

Разработать алгоритм для ввода четырёх целых чисел и вычисление их среднего арифметического?

Разработать алгоритм для ввода четырёх целых чисел и вычисление их среднего арифметического.

Протестировать алгоритм на исходных данных : - 5, 8, - 1, 9.

Линейный алгоритм.

На этой странице находится вопрос Написать на языке Паскаль программу ввода четырёх целых чисел и вычисления их среднего арифметического?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.