Пожалуйста, помогите составить программу правильно?

Информатика | 10 - 11 классы

Пожалуйста, помогите составить программу правильно!

Вот условие : Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран этот же массив в прямом и обратном порядке.

Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

На Паскале.

Ответить на вопрос
Ответы (1)
KillmeP 27 июл. 2020 г., 11:23:24

Var n, i : integer ;

a : array[1.

1024] of integer ;

begin

randomize ;

write('N = ') ;

readln(n) ;

for i : = 1 to n do

a[i] : = random(2 * n + 1) - n ;

write('V pramom poradke - ') ;

for i : = 1 to n do

write(a[i], ' ') ;

writeln ;

write('V obratnom poradke - ') ;

for i : = n downto 1 do

write(a[i], ' ') ;

writeln ;

end.

ОлькаЕС 6 апр. 2020 г., 14:56:56 | 5 - 9 классы

Разработать схему алгоритма который вводит массив из N целых чисел и выводит на экран сам массив и сумму всех его элементов?

Разработать схему алгоритма который вводит массив из N целых чисел и выводит на экран сам массив и сумму всех его элементов.

Спасибо : ).

NinaMoskovskikh 22 июл. 2020 г., 23:14:02 | 10 - 11 классы

Составьте программу для ввода с клавиатуры в массив 7 целых чисел и вывода этих чисел в обратном порядке?

Составьте программу для ввода с клавиатуры в массив 7 целых чисел и вывода этих чисел в обратном порядке.

N2189735 11 сент. 2020 г., 05:36:52 | 5 - 9 классы

Разработать схему алгоритма, который вводит массив из n целых чисел и выводит номера отрицательных элементов и сами эти элементы?

Разработать схему алгоритма, который вводит массив из n целых чисел и выводит номера отрицательных элементов и сами эти элементы.

Протестировать алгоритм для следующих массивов : а) 3 5 - 2 3 - 2 0 - 6 - 8 1 б) - 1 - 2 - 3 - 4 0 - 1 2 3 Написать программу на языке Паскаль.

Mashadinos 3 янв. 2020 г., 03:25:54 | 5 - 9 классы

1. Разработать схему алгоритма для ввода четырёх целых чисел и вычисления их среднего арифметического?

1. Разработать схему алгоритма для ввода четырёх целых чисел и вычисления их среднего арифметического.

Протестировать алгоритм на различных исходных данных (включая вещественные числа) и доказать правильность его работы.

2. Вводятся величины X, Y целого типа.

Разработать схему алгоритма для обмена значений величин.

Необходимо использовать вспомогательную величину Т.

Протестировать алгоритм для X = 5 и Y = - 11.

Tu110380 2 апр. 2020 г., 21:14:42 | 10 - 11 классы

50 Баллов?

50 Баллов.

Пожалуйста.

В Паскаль.

Написать программу, которая вводит массив из N целых чисел и выводит на экран сам массив и сумму всех его элементов.

Asyazuykova 11 февр. 2020 г., 13:57:05 | 5 - 9 классы

Составить алгоритм и программу вывода на экран удвоенных значений целых чисел от 5 до 15?

Составить алгоритм и программу вывода на экран удвоенных значений целых чисел от 5 до 15.

Мерипопенс 20 сент. 2020 г., 02:15:23 | 5 - 9 классы

Составить алгоритм , который вводит массив из n целых чисел и выводит на экран элементы с нечетными номерами в обрадном порядке?

Составить алгоритм , который вводит массив из n целых чисел и выводит на экран элементы с нечетными номерами в обрадном порядке.

Kononovaania 25 июл. 2020 г., 03:00:35 | 5 - 9 классы

Составить алгоритм и программу вывода на экран кубы всех целых чисел от - 5 до 12?

Составить алгоритм и программу вывода на экран кубы всех целых чисел от - 5 до 12.

Белей 3 сент. 2020 г., 12:28:39 | 5 - 9 классы

Разработать алгоритм для ввода четырёх целых чисел и вычисление их среднего арифметического?

Разработать алгоритм для ввода четырёх целых чисел и вычисление их среднего арифметического.

Протестировать алгоритм на исходных данных : - 5, 8, - 1, 9.

Линейный алгоритм.

Lera8939 6 нояб. 2020 г., 06:48:04 | 5 - 9 классы

Написать программу, которая вводит массив из N целых чисел и выводит на экран этот же массив в прямом и обратном порядке?

Написать программу, которая вводит массив из N целых чисел и выводит на экран этот же массив в прямом и обратном порядке.

Протестировать :

программу на поизвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

Вы зашли на страницу вопроса Пожалуйста, помогите составить программу правильно?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.