Вывести в обратном порядке последнее слово строки?

Информатика | 5 - 9 классы

Вывести в обратном порядке последнее слово строки.

Подсчитать количество букв в нем.

Ответить на вопрос
Ответы (1)
DOROMAR 30 окт. 2020 г., 10:39:10

На Паскаль (для Delphi и Lazarus, надо подкорректировать для PascalABC) :

const V = 255 ;

type L = array [1.

V] of char ;

var S : string ; A : L ; f, i : integer ;

begin read(S) ; f : = 0 ; for i : = 1 to Length(S) do begin if S[i]< ; > ; ' ' then begin f : = f + 1 ; A[f] : = S[i] end else f : = 0 ; end ; for i : = f downto 1 do write(A[i]) ; writeln(' ', f) ; readln ; readln

end.

Rudywade 13 янв. 2020 г., 14:58:31 | 10 - 11 классы

Заданы М строк слов, которые вводятся с клавиатуры?

Заданы М строк слов, которые вводятся с клавиатуры.

Подсчитать количество гласных букв в каждой из заданных строк.

Катюша228 13 мар. 2020 г., 06:32:49 | 10 - 11 классы

1)Вывести в обратном порядке второе слово строки?

1)Вывести в обратном порядке второе слово строки.

Подсчитать количество букв в нем.

2) Составить программу для вычисления Т = (R / Q + 1) + S.

R - наименьший элемент массива ; Q - произведение элементов массива с нечетными номерами ; S - количество элементов, лежащих в интервале (A, B) (ввести с клавиатуры).

3) Вычислить среднее арифметическое положительных элементов матрицы, расположенных ниже побочной диагонали.

Закрасить указанные элементы.

Vaganova0808 24 окт. 2020 г., 14:48:31 | 10 - 11 классы

Заполнить массив 5 целыми числами с клавиатуры и вывести их в строку в обратном порядке?

Заполнить массив 5 целыми числами с клавиатуры и вывести их в строку в обратном порядке.

Lyudamininaa 19 июн. 2020 г., 02:48:51 | 10 - 11 классы

Дана строка символов?

Дана строка символов.

Подсчитать количество вхождений буквы "n".

Кицюня095 23 янв. 2020 г., 07:00:42 | 5 - 9 классы

Дана строка?

Дана строка.

Подсчитать количество слов , начинающихся с буквы Б.

Matveydarin 26 дек. 2020 г., 14:04:06 | 5 - 9 классы

Вывести на экран все буквы в обратном порядке?

Вывести на экран все буквы в обратном порядке.

Inga89 11 сент. 2020 г., 06:34:58 | 5 - 9 классы

Дана строка?

Дана строка.

Вывести ее на экран по одному символу в обратном порядке.

Sesnation 19 авг. 2020 г., 09:04:03 | 5 - 9 классы

Дано предложение - строка?

Дано предложение - строка.

Подсчитать количество слов, начинающихся с буквы 'а' написать программу на паскале.

Sanek05121983r 13 июн. 2020 г., 14:49:04 | 10 - 11 классы

Подсчитайте количество гласных латинских букв в строке?

Подсчитайте количество гласных латинских букв в строке.

(ПАСКАЛЬ).

Kiti2259 24 июн. 2020 г., 06:59:43 | 10 - 11 классы

Дана строка слова в которой разделены пробелом, подсчитайте количество слов в этой строке?

Дана строка слова в которой разделены пробелом, подсчитайте количество слов в этой строке.

Вы перешли к вопросу Вывести в обратном порядке последнее слово строки?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.