Кто хорошо разбирается в программировании?

Информатика | 10 - 11 классы

Кто хорошо разбирается в программировании?

Очень нужно : ) Помогите пожалуйста, напишите программы в Паскале для задач : 1.

Заполнить массив А[15] числами 106, 112, 118, 124, 130, .

2. дан массив целых чисел, состоящий из 30 элементов.

Заполнить его с помощью датчика случайных чисел.

Hайти : a) сумму отрицательных элементов б) количество тех элементов, значения которых положительны и не превосходят заданного числа А.

Ответить на вопрос
Ответы (1)
Fdfghgvc 23 дек. 2020 г., 14:07:24

/ / PascalABC.

NET 3.

2, сборка 1325 от 19.

10. 2016

begin var a : = 106.

Step(6).

Take(15).

ToArray ; a.

Println

end.

Результат

106 112 118 124 130 136 142 148 154 160 166 172 178 184 190 / / PascalABC.

NET 3.

2, сборка 1325 от 19.

10. 2016

begin var b : = ArrRandom(30, - 50, 50) ; b.

Println ; var a : = ReadInteger('Введите число А : ') ; Writeln('Сумма отрицательных : ', b.

Where(x - > ; x< ; 0).

Sum) ; Writeln('Cумма положительных, не больших ', a, ', равна ', b.

Where(x - > ; (x> ; 0) and (x< ; = a)).

Sum)

end.

Пример - 21 12 8 50 - 47 35 45 - 2 - 30 - 33 3 12 41 - 29 8 2 - 24 - 44 - 50 - 2 - 13 - 32 33 - 29 35 - 43 20 - 44 42 - 3

Введите число А : 36

Сумма отрицательных : - 446

Cумма положительных, не больших 36, равна 168.

Kolotovkinayul 9 янв. 2020 г., 08:06:20 | 10 - 11 классы

Написать программу дан массив целых чисел состоящий из 20 элементов?

Написать программу дан массив целых чисел состоящий из 20 элементов.

Вывести индексы тех элементов значения которых больше заданного числа а.

Седдааа 7 апр. 2020 г., 01:01:43 | 5 - 9 классы

Дан массив состоящий из 10 элементов заполнить массив целых чисел найти сумму, количество элементов положительных и кратных три?

Дан массив состоящий из 10 элементов заполнить массив целых чисел найти сумму, количество элементов положительных и кратных три.

DDDina 17 мар. 2020 г., 18:11:39 | 5 - 9 классы

Дан массив целых чисел?

Дан массив целых чисел.

Найти количество тех элементов, значение которых положительны и не превосходят заданного натурального числа А.

(сделайте в паскале).

АрПлон 5 апр. 2020 г., 19:49:59 | 5 - 9 классы

Заполнить массив положительными и отрицательными числами на интервале от - 40 до 40 и найти сумму отрицательных чисел, случайным элементом под элементом 25?

Заполнить массив положительными и отрицательными числами на интервале от - 40 до 40 и найти сумму отрицательных чисел, случайным элементом под элементом 25.

Dianchik112 1 нояб. 2020 г., 23:34:11 | 10 - 11 классы

Задайте массив из 10 элементов с помощью датчика случайных чисел?

Задайте массив из 10 элементов с помощью датчика случайных чисел.

Замените все отрицательные элементы на наименьший положительный.

Выведите на экран исходный и полученный массив.

Ntoniy10 30 мар. 2020 г., 04:29:04 | 10 - 11 классы

Дан массив целых чисел, состоящий из 10 элементов?

Дан массив целых чисел, состоящий из 10 элементов.

Заполнить его с клавиатуры.

Найти : - Удвоенную сумму положительных элементов ; - Вывести значения тех элементов, которые меньше заданного числа А кратны 3.

Smakatov 16 мар. 2020 г., 07:55:30 | 5 - 9 классы

Заполнить массив из 15 элементов целыми числами с клавиатуры, и найти количество отрицательных элементов?

Заполнить массив из 15 элементов целыми числами с клавиатуры, и найти количество отрицательных элементов.

Программа Паскаль.

Annaborash2003 19 сент. 2020 г., 13:21:30 | 10 - 11 классы

Помогите решить задачу в Pascal Дан массив целых чисел, состоящий из 30 элементов?

Помогите решить задачу в Pascal Дан массив целых чисел, состоящий из 30 элементов.

Заполнить его датчиком случайных чисел.

Найти сумму отрицательных элементов.

Aishakov2000 5 мар. 2020 г., 16:27:29 | 5 - 9 классы

Решить при помощи паскаль : задан одномерный массив датчиком случайных чисел состоящий из 10 элементов вывести на экран max - элемент?

Решить при помощи паскаль : задан одномерный массив датчиком случайных чисел состоящий из 10 элементов вывести на экран max - элемент.

Laszay14 2 окт. 2020 г., 14:20:12 | 5 - 9 классы

Дан массив целых чисел, состоящий из 20 элементов?

Дан массив целых чисел, состоящий из 20 элементов.

Заполнить его с клавиатуры.

Найти :

1)сумму элементов, имеющих нечетное значение ;

2)вывести индексы тех элементов, значения которых больше заданного числа А.

На этой странице находится ответ на вопрос Кто хорошо разбирается в программировании?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.