Дан массив целых чисел?

Информатика | 5 - 9 классы

Дан массив целых чисел.

Найти количество тех элементов, значение которых положительны и не превосходят заданного натурального числа А.

(сделайте в паскале).

Ответить на вопрос
Ответы (1)
Ekaterina220785 17 мар. 2020 г., 18:11:45

Uses crt ;

const N = 20 ;

var

i, A, x : integer ;

arr : array [1.

N] of integer ;

begin

clrscr ;

x : = 0 ;

write ('A = ') ;

readln (A) ;

writeln ('Array : ') ; f

or i : = 1 to N do

begin

arr[i] : = random(41) - 20 ;

write (arr[i], ' ') ;

end ;

for i : = 1 to N do

begin

if (arr[i]> ; = 0) and (arr[i]< ; = A) then

x : = x + 1 ;

end ;

writeln () ;

writeln ('Answer : ', x) ;

readln () ;

end.

Kolotovkinayul 9 янв. 2020 г., 08:06:20 | 10 - 11 классы

Написать программу дан массив целых чисел состоящий из 20 элементов?

Написать программу дан массив целых чисел состоящий из 20 элементов.

Вывести индексы тех элементов значения которых больше заданного числа а.

Artem777849 10 нояб. 2020 г., 04:07:57 | 10 - 11 классы

Дана последовательность целых положительных чисел?

Дана последовательность целых положительных чисел.

Найти произведение только тех из них которые больше заданного числа m.

Если таких чисел нет, то выдать сообщение об этом Паскаль!

Можно с обьяснениями плиз)).

Ксения1013 9 нояб. 2020 г., 16:02:08 | 10 - 11 классы

Дана последовательность целых положительных чисел?

Дана последовательность целых положительных чисел.

Найти произведение только тех чисел, которые больше заданного числа М.

Если таких нет выдать сообщение об этом.

На Паскале.

Срочно, и пожалуйста, без заумных команд, а так чтобы понятно было!

Ntoniy10 30 мар. 2020 г., 04:29:04 | 10 - 11 классы

Дан массив целых чисел, состоящий из 10 элементов?

Дан массив целых чисел, состоящий из 10 элементов.

Заполнить его с клавиатуры.

Найти : - Удвоенную сумму положительных элементов ; - Вывести значения тех элементов, которые меньше заданного числа А кратны 3.

Odinokij2001 29 мая 2020 г., 12:37:44 | 5 - 9 классы

СРОЧНО?

СРОЧНО!

Дан цело численный массив .

Найти : КАЖДУЮ ОТДЕЛЬНО!

А) удвоенную сумму положительных элементов б)Коол - во элементов массива , значения которых больше заданного числа А(А - Склавиатуры) в)Кол - во тех элементов, значения которых положительны и не превосходят данного числа А (А - Склавиатуры).

ЛенаКотик2005 20 окт. 2020 г., 09:09:40 | 10 - 11 классы

Пусть дан одномерный числовой массив, составленный из целых чисел?

Пусть дан одномерный числовой массив, составленный из целых чисел.

Его можно получить либо вводом с клавиатуры командой Input, либо выбором из ячеек рабочего листа.

Количество элементов заранее неизвестно.

4. Найти количество тех элементов, значения которых положительны и не превосходят заданного числа А.

(создть в Excel в VBA.

Izgaraeva 22 нояб. 2020 г., 06:16:43 | 10 - 11 классы

Дан массив, состоящий из целых чисел?

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитывает количество положительных чисел среди элементов массива.

Входные данные Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные Необходимо единственное число - количество положительных элементов в массиве.

Java.

Игорь414 23 дек. 2020 г., 14:07:22 | 10 - 11 классы

Кто хорошо разбирается в программировании?

Кто хорошо разбирается в программировании?

Очень нужно : ) Помогите пожалуйста, напишите программы в Паскале для задач : 1.

Заполнить массив А[15] числами 106, 112, 118, 124, 130, .

2. дан массив целых чисел, состоящий из 30 элементов.

Заполнить его с помощью датчика случайных чисел.

Hайти : a) сумму отрицательных элементов б) количество тех элементов, значения которых положительны и не превосходят заданного числа А.

IldarAWM 2 дек. 2020 г., 16:47:58 | 5 - 9 классы

Помогите пожалуйста с информатикой?

Помогите пожалуйста с информатикой!

Массивы На паскале.

Даю 50 баллов Дан массив целых чисел, состоящий из 20 элементов.

Заполнить его с клавиатуры.

Найти : •вывести индексы тех элементов, значения которых больше заданного числа А ; •определить, есть ли в данном массиве положительные элементы, кратные k (k вводить с клавиатуры).

Laszay14 2 окт. 2020 г., 14:20:12 | 5 - 9 классы

Дан массив целых чисел, состоящий из 20 элементов?

Дан массив целых чисел, состоящий из 20 элементов.

Заполнить его с клавиатуры.

Найти :

1)сумму элементов, имеющих нечетное значение ;

2)вывести индексы тех элементов, значения которых больше заданного числа А.

На этой странице вы найдете ответ на вопрос Дан массив целых чисел?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.