Заполнить массив положительными и отрицательными числами на интервале от - 40 до 40 и найти сумму отрицательных чисел, случайным элементом под элементом 25?

Информатика | 5 - 9 классы

Заполнить массив положительными и отрицательными числами на интервале от - 40 до 40 и найти сумму отрицательных чисел, случайным элементом под элементом 25.

Ответить на вопрос
Ответы (1)
Miras017 5 апр. 2020 г., 19:50:02

Var a : array[1.

100] of integer ; i, n, sum : integer ;

begin

randomize ;

n : = 100 ; {Кол - во элементов в массиве}

sum : = 0 ;

for i : = 1 to n do

a[i] : = random(81) - 40 ;

for i : = 1 to n do

if a[i] < ; 0 then

sum : = sum + a[i] ;

writeln(sum) ;

end.

Skumborevskumbo 8 июл. 2020 г., 18:14:15 | 10 - 11 классы

Заполнить массив случайными числами в интервале [2 ; - 2] и подсчитать количество положительных элементов?

Заполнить массив случайными числами в интервале [2 ; - 2] и подсчитать количество положительных элементов.

Dalena81 23 февр. 2020 г., 08:20:01 | 10 - 11 классы

Помогите пожалуйста) заполнить массив из 10 элементов случайными числами в интервале [ - 10, 10] и подсчитать сумму всех отрицательных элементов?

Помогите пожалуйста) заполнить массив из 10 элементов случайными числами в интервале [ - 10, 10] и подсчитать сумму всех отрицательных элементов.

Aziz999aziz 3 июн. 2020 г., 03:53:19 | 10 - 11 классы

Решите, пожалуйста Заполнить массив из 13 элементов случайными числами в интервале [ - 200 ; 100] и найти количество отрицательных элементов массива меньше - семи и больше - двадцати?

Решите, пожалуйста Заполнить массив из 13 элементов случайными числами в интервале [ - 200 ; 100] и найти количество отрицательных элементов массива меньше - семи и больше - двадцати.

Anelle78 22 сент. 2020 г., 03:33:40 | 10 - 11 классы

Заполнить массив из 10 элементов случайными числами в интервале [ - 10, 10] и подсчитать сумму всех отрицательных элементов?

Заполнить массив из 10 элементов случайными числами в интервале [ - 10, 10] и подсчитать сумму всех отрицательных элементов.

Helz 21 июл. 2020 г., 13:49:40 | 10 - 11 классы

Дан массив из 50 чисел?

Дан массив из 50 чисел.

Заполните его случайными числами.

Вывести на экран сначала все положительные его элементы, а затем все отрицательные.

MAXCHEBOTKOV 30 янв. 2020 г., 14:37:22 | 5 - 9 классы

Написать программу Заполнить массив из 15 элементов случайными числами ( - 20 ; 80) Посчитать сумму всех элементов массива Посчитать количество отрицательных элементов?

Написать программу Заполнить массив из 15 элементов случайными числами ( - 20 ; 80) Посчитать сумму всех элементов массива Посчитать количество отрицательных элементов.

Ммм000 24 сент. 2020 г., 15:14:27 | 5 - 9 классы

Дан одномерный массив А из 12 - ти элементов?

Дан одномерный массив А из 12 - ти элементов.

Найти суммы отрицательных элементов и суммы положительных элементов.

СветЛана9910 3 мая 2020 г., 09:11:59 | 10 - 11 классы

Заполнить массив случайными числами (положительными и отрицательными) из произвольного диапазона?

Заполнить массив случайными числами (положительными и отрицательными) из произвольного диапазона.

Вывести созданный массив на экран, расположив элементы в одну строку через пробелы.

Заменить все отрицательные элементы квадратом соответствующего индекса.

Annaborash2003 19 сент. 2020 г., 13:21:30 | 10 - 11 классы

Помогите решить задачу в Pascal Дан массив целых чисел, состоящий из 30 элементов?

Помогите решить задачу в Pascal Дан массив целых чисел, состоящий из 30 элементов.

Заполнить его датчиком случайных чисел.

Найти сумму отрицательных элементов.

Pro100zheka 5 нояб. 2020 г., 16:50:49 | 5 - 9 классы

Заполнить массив из 10 элементов случайными целыми числами из диапазона - 100 – + 100?

Заполнить массив из 10 элементов случайными целыми числами из диапазона - 100 – + 100.

Найти :

a) наименьший элемент массива и его порядковый номер ;

b) наибольший элемент массива и его порядковый номер ;

c) сумму отрицательных и положительных элементов массива ;

d) среднее арифметическое отрицательных и положительных элементов массива ;

e) количество значений отрицательных, положительных и равных нулю элементов массива ;

На этой странице находится ответ на вопрос Заполнить массив положительными и отрицательными числами на интервале от - 40 до 40 и найти сумму отрицательных чисел, случайным элементом под элементом 25?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.