Задайте массив из 10 элементов с помощью датчика случайных чисел?

Информатика | 10 - 11 классы

Задайте массив из 10 элементов с помощью датчика случайных чисел.

Замените все отрицательные элементы на наименьший положительный.

Выведите на экран исходный и полученный массив.

Ответить на вопрос
Ответы (1)
Rumisa2999 1 нояб. 2020 г., 23:34:12

Var a : array[1.

10] of integer ; k, n, i : integer ; min : INTEGER ;

begin randomize ; N : = 10 ; k : = 0 {кол - во отрицательных элементов} ; writeln ('исходный массив') ; for i : = 1 to N do begin if random(2) = 1 then a[i] : = random(100) else begin k : = k + 1 ; a[i] : = - random(100) ; min : = a[I] end ; write(a[i] : 5) ; end ; writeln ; {поиск минимального положительного} if (k< ; > ; 0) or (k< ; > ; N) then {есть отрицательные или не все отрицательные} begin for i : = 1 to N do if (a[i]> ; 0) and (a[i]< ; min) then min : = a[i] ; {замена} for i : = 1 to N do if (a[i]< ; 0) then a[i] : = min ; end ; writeln('Новый массив') for i : = 1 to N do write(a[i] : 5) ;

end.

Marymenyailova 30 июл. 2020 г., 15:25:16 | 10 - 11 классы

Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел?

Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел.

Получите новый масив, каждый элемент которого равен среднему арифметическому соответствующего элемента исходного массива и введенного с клавиатуры числа А.

В полученном массиве найдите максимальный элемент среди элементов с нечетными номерами.

Выведите на экран исходные и полученные результаты.

Vermolenkova 1 нояб. 2020 г., 17:16:38 | 5 - 9 классы

Задача в Pascal ABC?

Задача в Pascal ABC.

Задайте массив из 10 элементов с помощью датчика случайных чисел.

Замените элементы массива, которые больше введенного с клавиатуры числа N.

Выведите на экран исходный и полученный массив.

Пожалуйста.

Jeneasuper96 2 апр. 2020 г., 20:28:56 | 10 - 11 классы

Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел?

Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел.

Получите новый массив, каждый элемент которого равен удвоенному соответствующему элементу исходного массива .

В полученном массиве найдите максимальный элемент среди элементов, номера которых кратны трем.

Выведите на экран исходные и полученные результаты.

Майн1 15 апр. 2020 г., 00:00:47 | 10 - 11 классы

Задайте массив из 10 элементов с помощью датчиков случайных чисел?

Задайте массив из 10 элементов с помощью датчиков случайных чисел.

Выведите на экран исходный массив и те элементы, которые больше 25.

Satusa 22 февр. 2020 г., 01:25:13 | 10 - 11 классы

Сформулируйте массив содержащий 15 элементов, с помощью датчика случайных чисел?

Сформулируйте массив содержащий 15 элементов, с помощью датчика случайных чисел.

Получите новый массив, каждый элемент которого равен квадрату соответствующего элемента исходного массива.

В полученном массиве определите насколько максимальный элемент исходного массива отличается от минимального элемента нового массива.

Выведите на экран исходные и полученные результаты.

Haruzheva2010 22 мая 2020 г., 05:08:48 | 5 - 9 классы

Задайте массив из 10 элементов с помощью датчика случайных чисел?

Задайте массив из 10 элементов с помощью датчика случайных чисел.

Выведите на экран исходный массив и и номера тех элементов, которые расположены между наибольшим и наименьшим элементами.

Lubap1980 29 дек. 2020 г., 17:28:31 | 10 - 11 классы

Задайте массив из 10 элементов с помощью датчика случайных чисел ?

Задайте массив из 10 элементов с помощью датчика случайных чисел .

Поменяйте знаки всем четным элементам массива на протиположные .

Выведите на экран исходный и полученный массивы.

Idfjkhgjfiiii 17 мар. 2020 г., 03:25:39 | 5 - 9 классы

Сформируйте массив a[i, j] с помощью датчика случайных чисел?

Сформируйте массив a[i, j] с помощью датчика случайных чисел.

Увеличить каждый элемент массива в 3 раза и если элемент массива отрицательный.

Массив выведите на экран в виде таблицы.

Камиль57 7 авг. 2020 г., 03:37:31 | 5 - 9 классы

СРОЧНООООО задайте массив из 10 элементов с помощью датчика случайных чисел?

СРОЧНООООО задайте массив из 10 элементов с помощью датчика случайных чисел.

Найдите сумму индексов элементов, которые больше среднего арифметического.

Выведите на экран исходный массив и полученную сумму.

Aishakov2000 5 мар. 2020 г., 16:27:29 | 5 - 9 классы

Решить при помощи паскаль : задан одномерный массив датчиком случайных чисел состоящий из 10 элементов вывести на экран max - элемент?

Решить при помощи паскаль : задан одномерный массив датчиком случайных чисел состоящий из 10 элементов вывести на экран max - элемент.

Вы перешли к вопросу Задайте массив из 10 элементов с помощью датчика случайных чисел?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.