Дан массив целых чисел, состоящий из 20 элементов?

Информатика | 5 - 9 классы

Дан массив целых чисел, состоящий из 20 элементов.

Заполнить его с клавиатуры.

Найти :

1)сумму элементов, имеющих нечетное значение ;

2)вывести индексы тех элементов, значения которых больше заданного числа А.

Ответить на вопрос
Ответы (1)
Hisamovazulfia 2 окт. 2020 г., 14:20:14

Program Pr1 ;

uses crt ;

var mas : array[1.

20] of integer ;

i, v, a, k, x : integer ;

Begin

clrscr ;

writeln('Vvedite A') ;

readln(a) ;

writeln('Vvedite K') ;

readln(k) ;

for i : = 1 to 20 do begin

writeln('Vvedite ', i, ' - ji simvol') ;

readln(mas[i]) ;

end ;

v : = 0 ; x : = 0 ;

for i : = 1 to 20 do begin

if mas[i] mod 20 then v : = v + mas[i] ;

if mas[i]>a then writeln('>a ', i) ;

if (mas[i] mod k = 0) and (mas[i]>0) then x : = x + 1 ;

end ;

writeln('Summa nechetnih - ', v ) ;

if x>0 then writeln('TRUE')

else writeln('FALSE') ;

end.

Kolotovkinayul 9 янв. 2020 г., 08:06:20 | 10 - 11 классы

Написать программу дан массив целых чисел состоящий из 20 элементов?

Написать программу дан массив целых чисел состоящий из 20 элементов.

Вывести индексы тех элементов значения которых больше заданного числа а.

АЗАЗАЗАЗАНА5 3 нояб. 2020 г., 10:30:02 | 10 - 11 классы

1) Определите и выведите на экран количество чисел от 50 до 500, которые делятся на 11 и 13 одновременно?

1) Определите и выведите на экран количество чисел от 50 до 500, которые делятся на 11 и 13 одновременно.

2) Дан массив целых чисел, состоящий из 100 элементов.

Заполнить его с клавиатуры.

Найти :

а) удвоенную сумму положительных элементов ;

б)вывести индексы тех элементов, значения которых больше значения предыдцщего элемента ( начиная со второго).

Azat1209 7 апр. 2020 г., 02:08:51 | 10 - 11 классы

Помогите решить задачу :Дан массив целых чисел Х, состоящий из 10 введенных с клавиатуры элементов?

Помогите решить задачу :

Дан массив целых чисел Х, состоящий из 10 введенных с клавиатуры элементов.

- Найти сумму элементов, имеющих нечетное значение ; - вывести те элементы, значение которых больше 15.

Vetrovax 20 февр. 2020 г., 06:38:08 | 10 - 11 классы

1) дан массив целых чисел, состоящий из 10 элементов?

1) дан массив целых чисел, состоящий из 10 элементов.

Заполнить его с клавиатуры.

Вывести на экран только те числа, для которых из значение больше номера их индекса.

Помогите пожалуйста, срочно надо!

((.

Glebdrokin 27 янв. 2020 г., 18:50:45 | 10 - 11 классы

Напишите программу, Дан целый одномерный массив А, неотрицательных чисел, с индексами от 1 до 6?

Напишите программу, Дан целый одномерный массив А, неотрицательных чисел, с индексами от 1 до 6.

Заполнить данный массив с клавиатуры, найти и вывести наименьшую нечетную сумму двух соседних элементов массива.

5даг05 26 июл. 2020 г., 00:38:29 | 10 - 11 классы

Help?

Help!

Дан массив целых чисел, состоящий из 10 элементов.

Заполнить его с клавиатуры.

Найти : - Удвоенную сумму положительных элементов ; - Удалить все четные элементы массива.

Ntoniy10 30 мар. 2020 г., 04:29:04 | 10 - 11 классы

Дан массив целых чисел, состоящий из 10 элементов?

Дан массив целых чисел, состоящий из 10 элементов.

Заполнить его с клавиатуры.

Найти : - Удвоенную сумму положительных элементов ; - Вывести значения тех элементов, которые меньше заданного числа А кратны 3.

IRINASTRELZ 27 нояб. 2020 г., 01:23:12 | 5 - 9 классы

PascalABC1)Дан массив целых чисел, состоящий из 8 элементов?

PascalABC

1)Дан массив целых чисел, состоящий из 8 элементов.

Заполнить его с клавиатуры.

Найти сумму элементов, имеющий нечётный индекс.

2)Сформировать одномерные массив из N элементов, где элементы массива - целые случайные числа.

Вывести индексы тех элементов, значение которых больше заданного числа A (A вводить с клавиатуры).

3)Определите, есть ли в данном массиве положительные элементы, кратные k (k вводить с клавиатуры).

Gffghvd 8 окт. 2020 г., 19:16:16 | 5 - 9 классы

Дан массив А целых чисел, состоящий из 25 элементов?

Дан массив А целых чисел, состоящий из 25 элементов.

Заполнить с клавиатуры.

3)Найти элемент массива кратный 12 и его индекс.

4)Найти сумму положительных элементов, значения которых меньше 10.

5)Вывести индексы тех элементов, которых кратн.

IldarAWM 2 дек. 2020 г., 16:47:58 | 5 - 9 классы

Помогите пожалуйста с информатикой?

Помогите пожалуйста с информатикой!

Массивы На паскале.

Даю 50 баллов Дан массив целых чисел, состоящий из 20 элементов.

Заполнить его с клавиатуры.

Найти : •вывести индексы тех элементов, значения которых больше заданного числа А ; •определить, есть ли в данном массиве положительные элементы, кратные k (k вводить с клавиатуры).

Вы зашли на страницу вопроса Дан массив целых чисел, состоящий из 20 элементов?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.