. Помогите?

Информатика | 10 - 11 классы

. Помогите.

Задача на паскаль.

Известны год и номер месяца рождения человека, а также год и номер

месяца сегодняшнего дня.

Определить возраст человека и число полных месяцев.

При определении разность между номером месяцев.

Например, если месяц рождения февраля, а текущий месяц май, то число полных месяцев равно трем независимим от дня рождения и сегоднешнего дня.

Ответить на вопрос
Ответы (1)
OlgaTimchenko 25 янв. 2020 г., 14:05:59

Var m, y, mr, yr, mf, yf : integer ;

begin write('введите месяц и год рождения : ') ; readln(mr, yr) ; write('введите месяц и год расчета : ') ; readln(m, y) ; yf : = y - yr ; mf : = m - mr ; if mf < ; 1 then begin yf : = yf - 1 ; mf : = mf + 12 end ; writeln('Прожито лет - ', yf, ', месяцев - ', mf)

end.

Тестовое решение :

введите месяц и год рождения : 8 1976

введите месяц и год расчета : 3 2014

Прожито лет - 37, месяцев - 7.

1999101615 28 июл. 2020 г., 20:28:56 | 10 - 11 классы

Составить программу, которая по заданным году и номеру месяца m определяет количество дней в этом месяце?

Составить программу, которая по заданным году и номеру месяца m определяет количество дней в этом месяце?

В паскале.

Kostya31rus 11 авг. 2020 г., 21:03:28 | 1 - 4 классы

Пожалуйста помогите?

Пожалуйста помогите!

Ввести номер месяца и номер дня вывести число дней оставшихся до нового года (номер месяц.

12 день 25).

Rawshan666 11 февр. 2020 г., 21:13:00 | 5 - 9 классы

Помогите пожалуйста?

Помогите пожалуйста.

Паскаль авс используя дату текущего дня, вычислить следующую дату.

Сначала с помощью инструкции case проверить , является ли текущий день последним днём месяца.

Затем проверить, является ли текущий месяц днём декабрем : если нет, то номер месяца увеличить на 1, если да то номер года, а номер месяца оставить равен 1 (учесть возможность ввода високосного года(если год / 4 = 0, то год високосный)).

Iiiiig 25 сент. 2020 г., 03:29:27 | 10 - 11 классы

Дано натуральное число n (1n1188), определяющее возраст человека (в месяцах)?

Дано натуральное число n (1n1188), определяющее возраст человека (в месяцах).

Выразить возраст в годах и месяцах.

Например, 21 год 10 месяцев, 52 года 1 месяц, 46 лет равно и т.

Д.

Simina 9 авг. 2020 г., 15:15:43 | 10 - 11 классы

Введите с клавиатуры текущий год и год рождения?

Введите с клавиатуры текущий год и год рождения.

Вычислите возраст, если он меньше 18 вывести год совершеннолетия, а если больше, то год выхода на пенсию.

Вывести текущий месяц и месяц рождения.

Вычислить возраст в месяцах) дата рождения 11.

03. 1998.

Darya200290567 15 нояб. 2020 г., 20:23:25 | 5 - 9 классы

Известны год и номер месяца рождения человека, а также год и номер месяца сегодняшнего дня (январь – 1 и т?

Известны год и номер месяца рождения человека, а также год и номер месяца сегодняшнего дня (январь – 1 и т.

Д. ).

Определить возраст человека (число полных лет).

В случае совпадения указанных месяцев считать, что прошел весь год.

Паскаль.

Kerli1 8 нояб. 2020 г., 17:13:49 | 10 - 11 классы

Напишите программу в Паскаль, которая получает номер месяца и выводит его название и время года?

Напишите программу в Паскаль, которая получает номер месяца и выводит его название и время года.

Пример : Введите номер месяца : 5 Этот месяц - май, время года - весна.

Пример : Введите номер месяца : 15 Неверный номер месяца.

Tylercreator 21 авг. 2020 г., 09:21:56 | 5 - 9 классы

Сначала года по некоторый день прошло n месяцев и 2 дня?

Сначала года по некоторый день прошло n месяцев и 2 дня.

Определить название месяца На паскале.

Dorani 30 сент. 2020 г., 21:45:58 | 1 - 4 классы

Преобразовать день месяц год рождения в двоичный формат?

Преобразовать день месяц год рождения в двоичный формат.

Страныйчел 26 дек. 2020 г., 13:56:38 | 5 - 9 классы

Составить программу на языке СиИзвестны год и номер месяца рождения человека?

Составить программу на языке Си

Известны год и номер месяца рождения человека.

Определить возраст человека на март(3 месяц) 2008 года.

Вы находитесь на странице вопроса . Помогите? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.