Дано натуральное число n (1n1188), определяющее возраст человека (в месяцах)?

Информатика | 10 - 11 классы

Дано натуральное число n (1n1188), определяющее возраст человека (в месяцах).

Выразить возраст в годах и месяцах.

Например, 21 год 10 месяцев, 52 года 1 месяц, 46 лет равно и т.

Д.

Ответить на вопрос
Ответы (1)
Dpanickiy 25 сент. 2020 г., 03:29:28

Program saidim ;

uses crt ;

var

m : integer ;

begin writeln(' * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * ') ; writeln(' * * Переводилка возраста * * ') ; writeln(' * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * ') ; writeln() ; writeln('Введите возраст в месяцах') ; readln(m) ; writeln(' * * * alphaues is thinking.

* * * ') ; writeln() ; / / writeln('Возраст равен ', m div 12, ' лет ', m mod 12, ' месяцев') ; write('Возраст равен ', m div 12) ; case ((m div 12) mod 10) of 1 : write(' год ') ; 2, 3, 4 : write(' годa ') ; else write(' лет ') ; end ; case (m mod 12) of 0 : writeln(' ровно ') ; 1 : writeln(m mod 12, ' месяц ') ; 2, 3, 4 : writeln(m mod 12, ' месяцa ') ; else writeln(m mod 12, ' месяцев ') ; end ;

end.

1999101615 28 июл. 2020 г., 20:28:56 | 10 - 11 классы

Составить программу, которая по заданным году и номеру месяца m определяет количество дней в этом месяце?

Составить программу, которая по заданным году и номеру месяца m определяет количество дней в этом месяце?

В паскале.

Vangog97 25 янв. 2020 г., 14:05:55 | 10 - 11 классы

. Помогите?

. Помогите.

Задача на паскаль.

Известны год и номер месяца рождения человека, а также год и номер

месяца сегодняшнего дня.

Определить возраст человека и число полных месяцев.

При определении разность между номером месяцев.

Например, если месяц рождения февраля, а текущий месяц май, то число полных месяцев равно трем независимим от дня рождения и сегоднешнего дня.

Dashutamyasoed 17 авг. 2020 г., 08:19:10 | 5 - 9 классы

Паскаль?

Паскаль.

Оператор выбора.

Дано натуральное число N (N< ; 100), что означает возраст человека в годах.

Дать для этого числа наименование : "год", "года", "лет".

Azievaaliya 30 окт. 2020 г., 11:00:49 | 10 - 11 классы

Написать алгоритм нахождения числа дней в месяце, если даны : Номер месяца n - целое число а, равное 1 для високосного года и равное 0 в противном случае?

Написать алгоритм нахождения числа дней в месяце, если даны : Номер месяца n - целое число а, равное 1 для високосного года и равное 0 в противном случае.

Unnamed11 24 окт. 2020 г., 00:36:03 | 5 - 9 классы

ПОМОГИТЕЕЕ?

ПОМОГИТЕЕЕ!

59 пунктов и лучшее решение будет, если будут пояснения

№11.

В зависимости от введённого пользователем возраста (от 1 до 99 лет)

вывести сообщение о том.

Сколько пользователю лет.

Предусмотреть

ситуацию, что может быть :

«Тебе 7 лет».

«Тебе 2 года».

«Тебе 23 года».

«Тебе 1 год»

для любого числа.

№12. Пользователь вводит число и месяц не високосного года.

Вывести дату

следующего дня.

Например :

Дано : 1 января.

Вывод : 2 января

Дано : 28 февраля.

Вывод : 1 марта

Дано : 31 декабря.

Вывод : 1 января

№13.

Даны год.

Месяц и число рождения двух человек.

Определить, кто из

них старше.

Примечание ;

Предусмотреть ситуации :

1.

Люди родились в разные года

2.

Люди родились в один год.

Но разные месяцы

3.

Люди родились в один год.

Разные месяцы, но разные дни.

4. Люди родились в один год.

Месяц и день.

ЖЕЛАТЕЛЬНО С ПОЯСНЕНИЯМИ, ЧТО К ЧЕМУ.

Valerkaot 26 февр. 2020 г., 00:07:53 | 10 - 11 классы

Написать алгоритм нахождения числа дней в месяце, если даны : Номер месяца n - целое число а, равное 1 для високосного года и равное 0 в противном случае?

Написать алгоритм нахождения числа дней в месяце, если даны : Номер месяца n - целое число а, равное 1 для високосного года и равное 0 в противном случае.

Simina 9 авг. 2020 г., 15:15:43 | 10 - 11 классы

Введите с клавиатуры текущий год и год рождения?

Введите с клавиатуры текущий год и год рождения.

Вычислите возраст, если он меньше 18 вывести год совершеннолетия, а если больше, то год выхода на пенсию.

Вывести текущий месяц и месяц рождения.

Вычислить возраст в месяцах) дата рождения 11.

03. 1998.

Nranenko 22 янв. 2020 г., 19:21:34 | 5 - 9 классы

Написать программу, которая по данному натурального числу от 1 до 12 (номеру месяца) выдает все приходящиеся на этот месяц праздничные дни (например, если введено число 1, то : 1 января - Новый Год, 7?

Написать программу, которая по данному натурального числу от 1 до 12 (номеру месяца) выдает все приходящиеся на этот месяц праздничные дни (например, если введено число 1, то : 1 января - Новый Год, 7 января - Рождество).

Darya200290567 15 нояб. 2020 г., 20:23:25 | 5 - 9 классы

Известны год и номер месяца рождения человека, а также год и номер месяца сегодняшнего дня (январь – 1 и т?

Известны год и номер месяца рождения человека, а также год и номер месяца сегодняшнего дня (январь – 1 и т.

Д. ).

Определить возраст человека (число полных лет).

В случае совпадения указанных месяцев считать, что прошел весь год.

Паскаль.

Страныйчел 26 дек. 2020 г., 13:56:38 | 5 - 9 классы

Составить программу на языке СиИзвестны год и номер месяца рождения человека?

Составить программу на языке Си

Известны год и номер месяца рождения человека.

Определить возраст человека на март(3 месяц) 2008 года.

На этой странице сайта размещен вопрос Дано натуральное число n (1n1188), определяющее возраст человека (в месяцах)? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 10 - 11 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.