Помогите пожалуйста?

Информатика | 5 - 9 классы

Помогите пожалуйста.

Паскаль авс используя дату текущего дня, вычислить следующую дату.

Сначала с помощью инструкции case проверить , является ли текущий день последним днём месяца.

Затем проверить, является ли текущий месяц днём декабрем : если нет, то номер месяца увеличить на 1, если да то номер года, а номер месяца оставить равен 1 (учесть возможность ввода високосного года(если год / 4 = 0, то год високосный)).

Ответить на вопрос
Ответы (1)
Лика38ррл 11 февр. 2020 г., 21:13:04

Var s, sd, sm, sy : string ; d, m, y, err : integer ;

begin Write('Введите текущую дату в формате дд / мм / гггг или дд.

Мм. гггг : ') ; Readln(s) ; if Length(s)< ; > ; 10 then Writeln('Неверный ввод') else begin sd : = s[1] + s[2] ; Val(sd, d, err) ; sm : = s[4] + s[5] ; Val(sm, m, err) ; sy : = Copy(s, 7, 4) ; Val(sy, y, err) ; if err> ; 0 then Writeln('Неверный ввод') else begin if d< ; 28 then d : = d + 1 else begin case m of 1, 3, 5, 7, 8, 10, 12 : if d< ; 31 then d : = d + 1 else begin d : = 1 ; m : = m + 1 end ; 2 : if (y mod 4) = 0 then if d = 28 then d : = 29 else begin d : = 1 ; m : = 3 end else begin d : = 1 ; m : = 3 end ; else if d< ; 30 then d : = d + 1 else begin d : = 1 ; m : = m + 1 end end end ; if m> ; 12 then begin m : = 1 ; y : = y + 1 end ; Str(d, sd) ; if Length(sd) = 1 then sd : = '0' + sd ; Str(m, sm) ; if Length(sm) = 1 then sm : = '0' + sm ; Str(y, sy) ; s : = sd + '.

' + sm + '.

' + sy ; Writeln('Завтра будет ' + s) end end

end.

Lyudakrivenkov 6 мар. 2020 г., 02:01:33 | 5 - 9 классы

Составить программу в паскале?

Составить программу в паскале!

9 класс!

СРОЧНО!

Пожалуйста!

Без всяких div и mod.

Год является високосным, если его номер кратен 4.

Из кратных 100 високосными являются лишь те года, которые кратны также 400 (например, 1700, 1800 и 1900 — не високосные года, 2000 — високосный).

Дано натуральное число n.

Определить, является ли високосным год с таким номером.

Vangog97 25 янв. 2020 г., 14:05:55 | 10 - 11 классы

. Помогите?

. Помогите.

Задача на паскаль.

Известны год и номер месяца рождения человека, а также год и номер

месяца сегодняшнего дня.

Определить возраст человека и число полных месяцев.

При определении разность между номером месяцев.

Например, если месяц рождения февраля, а текущий месяц май, то число полных месяцев равно трем независимим от дня рождения и сегоднешнего дня.

Kostya31rus 11 авг. 2020 г., 21:03:28 | 1 - 4 классы

Пожалуйста помогите?

Пожалуйста помогите!

Ввести номер месяца и номер дня вывести число дней оставшихся до нового года (номер месяц.

12 день 25).

Вася162ро 29 июл. 2020 г., 07:11:31 | 5 - 9 классы

Составить программу, которая запрашивает у пользователя год количество дней в текущем месяце и сегодняшнее число?

Составить программу, которая запрашивает у пользователя год количество дней в текущем месяце и сегодняшнее число.

После этого выводит сообщение о том, сколько дней осталось до конца месяца.

Пример работы программы : Сколько дней в текущем месяце?

31 Какое сегодня число?

26 Количество дней до конца текущего месяца : 5.

Karina1111Butko 17 мая 2020 г., 12:37:53 | 10 - 11 классы

Володе очень понравились задачи олимпиады по информатике, поэтому он решил ходить на занятия кружка по программированию?

Володе очень понравились задачи олимпиады по информатике, поэтому он решил ходить на занятия кружка по программированию.

Придя на первое занятие кружка, он узнал, что занятия будут проходить еженедельно в один и тот же день недели.

Помогите Володе составить календарь занятий до конца года – определите даты всех занятий, начиная с первого занятия и до конца года.

Программа получает на вход два числа, записанных в разных строках : номер месяца и номер дня месяца, когда проходит первое занятие.

Номер месяца может быть одним из четырёх возможных чисел – 9, 10, 11, 12.

Номер дня месяца – число от 1 до 30 для сентября и ноября (месяцы с номерами 9 и 11) или от 1 до 31 для октября и декабря (месяцы с номерами 10 и 12).

Программа должна вывести даты всех занятий кружка до конца года в хронологическом порядке, по одной дате в строке, сначала месяц, затем день месяца, через пробел.

Занятия проходят еженедельно, в тот же день недели, что и первое занятие.

Формат вывода дат такой же, как в условии.

Считайте, что каникулы отсутствуют, а последнее занятие может происходить в любой день декабря, в том числе и 31 числа.

Simina 9 авг. 2020 г., 15:15:43 | 10 - 11 классы

Введите с клавиатуры текущий год и год рождения?

Введите с клавиатуры текущий год и год рождения.

Вычислите возраст, если он меньше 18 вывести год совершеннолетия, а если больше, то год выхода на пенсию.

Вывести текущий месяц и месяц рождения.

Вычислить возраст в месяцах) дата рождения 11.

03. 1998.

Bartyshvika 15 июн. 2020 г., 21:37:18 | 10 - 11 классы

Дан файл, содержащий различные даты?

Дан файл, содержащий различные даты.

Каждая дата — это число, месяц и год.

Найти год с наименьшим номером.

Паскаль.

Sony20022 17 июн. 2020 г., 00:59:09 | 1 - 4 классы

Какое число в текущем году приходится на третью среду марта?

Какое число в текущем году приходится на третью среду марта?

Какой день недели в текущем году приходится на 31 декабря?

Какое число в текущем году приходится на последнее воскресенье мая?

Kerli1 8 нояб. 2020 г., 17:13:49 | 10 - 11 классы

Напишите программу в Паскаль, которая получает номер месяца и выводит его название и время года?

Напишите программу в Паскаль, которая получает номер месяца и выводит его название и время года.

Пример : Введите номер месяца : 5 Этот месяц - май, время года - весна.

Пример : Введите номер месяца : 15 Неверный номер месяца.

Tylercreator 21 авг. 2020 г., 09:21:56 | 5 - 9 классы

Сначала года по некоторый день прошло n месяцев и 2 дня?

Сначала года по некоторый день прошло n месяцев и 2 дня.

Определить название месяца На паскале.

Вы зашли на страницу вопроса Помогите пожалуйста?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.