Напишите программу в Паскаль, которая получает номер месяца и выводит его название и время года?

Информатика | 10 - 11 классы

Напишите программу в Паскаль, которая получает номер месяца и выводит его название и время года.

Пример : Введите номер месяца : 5 Этот месяц - май, время года - весна.

Пример : Введите номер месяца : 15 Неверный номер месяца.

Ответить на вопрос
Ответы (1)
Nanabanana23 8 нояб. 2020 г., 17:13:52

Var n : integer ;

begin repeat read(n) ; if n< ; 1 or n> ; 12 then writeln('Неверный номер месяца') ;

until n = > ; 1 and n< ; = 12 ;

case n of 1 : writeln('Этот месяц - Январь, время года - зима.

') ; 2 : writeln('Этот месяц - Февраль, время года - зима.

') ; 3 : writeln('Этот месяц - Март, время года - весна.

') ; 4 : writeln('Этот месяц - Апрель, время года - весна.

') ; 5 : writeln('Этот месяц - Май, время года - весна.

') ; 6 : writeln('Этот месяц - Июнь, время года - лето.

) ; 7 : writeln('Этот месяц - Июль, время года - лето.

') ; 8 : writeln('Этот месяц - Август, время года - лето.

') ; 9 : writeln('Этот месяц - Сентябрь, время года - осень.

') ; 10 : writeln('Этот месяц - Октябрь, время года - осень.

') ; 11 : writeln('Этот месяц - Ноябрь, время года - осень.

') ; 12 : writeln('Этот месяц - Декабрь, время года - зима.

') ;

end ;

end.

1999101615 28 июл. 2020 г., 20:28:56 | 10 - 11 классы

Составить программу, которая по заданным году и номеру месяца m определяет количество дней в этом месяце?

Составить программу, которая по заданным году и номеру месяца m определяет количество дней в этом месяце?

В паскале.

Vangog97 25 янв. 2020 г., 14:05:55 | 10 - 11 классы

. Помогите?

. Помогите.

Задача на паскаль.

Известны год и номер месяца рождения человека, а также год и номер

месяца сегодняшнего дня.

Определить возраст человека и число полных месяцев.

При определении разность между номером месяцев.

Например, если месяц рождения февраля, а текущий месяц май, то число полных месяцев равно трем независимим от дня рождения и сегоднешнего дня.

Vladka1310 21 февр. 2020 г., 08:01:19 | 1 - 4 классы

Напишите программу которая по введённому номеру месяца выводит сообщения о том какое сейчас время года?

Напишите программу которая по введённому номеру месяца выводит сообщения о том какое сейчас время года.

Umnikr 25 июл. 2020 г., 15:04:32 | 10 - 11 классы

В ПАСКАЛЕ?

В ПАСКАЛЕ!

Написать программу которая по номеру месяца выдает название следующего за ним месяц при m = 1.

Sakensei 17 сент. 2020 г., 15:19:13 | 10 - 11 классы

По введенному номеру месяца вывести на экран время года ?

По введенному номеру месяца вывести на экран время года .

(программа трассировка ).

Романинк 11 февр. 2020 г., 03:57:12 | 10 - 11 классы

Напишите пожалуйста программу в Паскале : Написать программу, которая по номеру месяца выводит название следующего за ним месяца(с помощью оператора case) Например : если я ввожу 2 должно выйти март?

Напишите пожалуйста программу в Паскале : Написать программу, которая по номеру месяца выводит название следующего за ним месяца(с помощью оператора case) Например : если я ввожу 2 должно выйти март.

Davletyarov 18 апр. 2020 г., 09:41:14 | 10 - 11 классы

Напишите программу, которая вводит номер месяца и выводит название времени года на английском языке?

Напишите программу, которая вводит номер месяца и выводит название времени года на английском языке.

При вводе неверного номера месяца должно быть выведено слово 'NO'.

Anel9913 30 мая 2020 г., 12:09:13 | 5 - 9 классы

Помогите пожалуйста?

Помогите пожалуйста!

Напишите программу : По заданному номеру месяца выводилось его название и указано количество дней в месяце.

ReginaJ98 12 сент. 2020 г., 06:25:02 | 5 - 9 классы

Помогите составить программу с помощью которой можно было бы ввести номер месяца, а программа бы ответила к какому времени года соответствует этот месяц(Паскаль)?

Помогите составить программу с помощью которой можно было бы ввести номер месяца, а программа бы ответила к какому времени года соответствует этот месяц(Паскаль).

Karymovemil 9 нояб. 2020 г., 09:57:58 | 5 - 9 классы

Уровень A?

Уровень A.

Напишите программу, которая получает три числа – рост трёх спортсменов, и выводит сообщение 'По росту.

', если числа введены по возрастанию, или сообщение 'Не по росту!

', если они введены в другом порядке Пример : Введите рост трёх спортсменов : 165 170 172 По росту.

Пример : Введите рост трёх спортсменов : 175 170 172 Не по росту.

Уровень B.

Напишите программу, которая получает с клавиатуры номер месяца и выводит название соответствующего ему время года или сообщение об ошибке.

Пример : Введите номер месяца : 5 Весна.

Уровень C.

Напишите программу, которая получает возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом 'год', 'года' или 'лет'.

Например, '21 год', '22 года', '25 лет'.

Пример : Введите возраст : 18 Вам 18 лет.

Пример : Введите возраст : 21 Вам 21 год.

Пример : Введите возраст : 22 Вам 22 года.

Вы находитесь на странице вопроса Напишите программу в Паскаль, которая получает номер месяца и выводит его название и время года? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.