Составить программу на языке СиИзвестны год и номер месяца рождения человека?

Информатика | 5 - 9 классы

Составить программу на языке Си

Известны год и номер месяца рождения человека.

Определить возраст человека на март(3 месяц) 2008 года.

Ответить на вопрос
Ответы (1)
Lisenkovanya 26 дек. 2020 г., 13:56:40

#include

int main() {

int year, month, cur_y = 2008, cur_m = 3, m_age, y_age ;

scanf("%d%d", &year, &month) ;

if(month - cur_m > 0) { m_age = 12 - (month - cur_m) ; y_age = (cur_y - year) - 1 ; } else { m_age = cur_m - month ; y_age = cur_y - year ; } printf("%d years and %d months \ n", y_age, m_age) ; return 0 ;

}.

1999101615 28 июл. 2020 г., 20:28:56 | 10 - 11 классы

Составить программу, которая по заданным году и номеру месяца m определяет количество дней в этом месяце?

Составить программу, которая по заданным году и номеру месяца m определяет количество дней в этом месяце?

В паскале.

Vangog97 25 янв. 2020 г., 14:05:55 | 10 - 11 классы

. Помогите?

. Помогите.

Задача на паскаль.

Известны год и номер месяца рождения человека, а также год и номер

месяца сегодняшнего дня.

Определить возраст человека и число полных месяцев.

При определении разность между номером месяцев.

Например, если месяц рождения февраля, а текущий месяц май, то число полных месяцев равно трем независимим от дня рождения и сегоднешнего дня.

Davletyarov 18 апр. 2020 г., 09:41:14 | 10 - 11 классы

Напишите программу, которая вводит номер месяца и выводит название времени года на английском языке?

Напишите программу, которая вводит номер месяца и выводит название времени года на английском языке.

При вводе неверного номера месяца должно быть выведено слово 'NO'.

Iiiiig 25 сент. 2020 г., 03:29:27 | 10 - 11 классы

Дано натуральное число n (1n1188), определяющее возраст человека (в месяцах)?

Дано натуральное число n (1n1188), определяющее возраст человека (в месяцах).

Выразить возраст в годах и месяцах.

Например, 21 год 10 месяцев, 52 года 1 месяц, 46 лет равно и т.

Д.

Simina 9 авг. 2020 г., 15:15:43 | 10 - 11 классы

Введите с клавиатуры текущий год и год рождения?

Введите с клавиатуры текущий год и год рождения.

Вычислите возраст, если он меньше 18 вывести год совершеннолетия, а если больше, то год выхода на пенсию.

Вывести текущий месяц и месяц рождения.

Вычислить возраст в месяцах) дата рождения 11.

03. 1998.

Darya200290567 15 нояб. 2020 г., 20:23:25 | 5 - 9 классы

Известны год и номер месяца рождения человека, а также год и номер месяца сегодняшнего дня (январь – 1 и т?

Известны год и номер месяца рождения человека, а также год и номер месяца сегодняшнего дня (январь – 1 и т.

Д. ).

Определить возраст человека (число полных лет).

В случае совпадения указанных месяцев считать, что прошел весь год.

Паскаль.

Novikova656 17 окт. 2020 г., 13:17:55 | 10 - 11 классы

Составить программу для c + + "Ввести возраст человека и вывести его вместе со словом ГОД, ГОДА, ЛЕТ(пример вам 1 год, вам 2 года, вам 55 лет)?

Составить программу для c + + "Ввести возраст человека и вывести его вместе со словом ГОД, ГОДА, ЛЕТ(пример вам 1 год, вам 2 года, вам 55 лет).

Kerli1 8 нояб. 2020 г., 17:13:49 | 10 - 11 классы

Напишите программу в Паскаль, которая получает номер месяца и выводит его название и время года?

Напишите программу в Паскаль, которая получает номер месяца и выводит его название и время года.

Пример : Введите номер месяца : 5 Этот месяц - май, время года - весна.

Пример : Введите номер месяца : 15 Неверный номер месяца.

Vippersonka 10 мар. 2020 г., 06:31:31 | 10 - 11 классы

Задание 3 Составить программу, выводящую время года в зависимости от номера месяца введенного пользователем?

Задание 3 Составить программу, выводящую время года в зависимости от номера месяца введенного пользователем.

ReginaJ98 12 сент. 2020 г., 06:25:02 | 5 - 9 классы

Помогите составить программу с помощью которой можно было бы ввести номер месяца, а программа бы ответила к какому времени года соответствует этот месяц(Паскаль)?

Помогите составить программу с помощью которой можно было бы ввести номер месяца, а программа бы ответила к какому времени года соответствует этот месяц(Паскаль).

Вы находитесь на странице вопроса Составить программу на языке СиИзвестны год и номер месяца рождения человека? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 5 - 9 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.