Дан массив из n элементов?

Информатика | 5 - 9 классы

Дан массив из n элементов.

Необходимо определить, есть ли в данном массиве два соседних элемента, равных заданному числу k ?

Если есть, то вывести индексы первой такой пары чисел.

Индексация элементов начинаются с единицы Формат входных данных С клавиатуры вводится натуральное число n (n≤100).

На следующей строке через пробел вводятся n элементов массива.

Все числа по модулю не превосходят 100.

В последней строке вводится число k, (−200≤k≤200).

Формат выходных данных В качестве ответа выведите индексы искомых элементов через пробел в порядке возрастания.

Если таких элементов нет, то вывести 0.

Ответить на вопрос
Ответы (1)
Ирина20040321 6 сент. 2020 г., 15:52:03

Var i, k, n : integer ; a : array[1.

10000]of integer ;

begin readln(n) ; for i : = 1 to n do read(a[i]) ; readln(k) ; for i : = 2 to n do

if(a[i - 1] = k) and (a[i] = k) then begin write(i, ' ', i - 1) ; exit ; end ; write('0') ;

end.

Badertdinovrus 8 февр. 2020 г., 04:07:52 | 5 - 9 классы

Вводится массив, состоящий из целых чисел?

Вводится массив, состоящий из целых чисел.

Найти наибольшее среди них.

Входные данные Сначала задано число N — количество элементов в массиве (1N35).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные Необходимо вывести значение наибольшего элемента в массиве.

Примеры Входные данные 3 1 2 3 Выходные данные 3.

Wapiro 15 июн. 2020 г., 23:50:17 | 5 - 9 классы

Дан одномерный массив с индексами от 0 до 14, найти индекс минимального и максимального элементов массива(числа вводятся с клавиатуры)?

Дан одномерный массив с индексами от 0 до 14, найти индекс минимального и максимального элементов массива

(числа вводятся с клавиатуры).

EonEGuy1 21 нояб. 2020 г., 08:01:29 | 10 - 11 классы

Дан массив целых чисел?

Дан массив целых чисел.

Нумерация элементов начинается с 0.

Выведите все элементы массива с четными номерами.

Формат входных данныхСначала задано число N - количество элементов в массиве, N100.

Далее через пробел записаны N чисел - элементы массива.

Все числа по модулю не превосходят 10000

Формат выходных данныхВыведите все элементы массива с четными индексами (то есть A[0], A[2], A[4], .

).

Наська200419966 21 мар. 2020 г., 22:38:49 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется сначала вывести элементы, стоящие на четных местах, затем — на нечетных.

Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных Требуется в одной строке через пробел вывести элементы массива в заданном порядке.

Мистер00 21 янв. 2020 г., 03:12:38 | 5 - 9 классы

Дан массив из тридцати элементов?

Дан массив из тридцати элементов.

Вывести индексы всех элементов, равных по значению а.

Если таких элементов нет - вывести сообщение с текстом "No solution".

Формат входных данных На первой строке через пробел записаны целые числа Arri (|Arri|≤1000) — элементы массива.

На второй строке записано целое положительное число a.

Формат выходных данных Строка, содержащая искомые индексы, либо знадпись "No solution", если таковых нет.

Nataelyut 3 мар. 2020 г., 00:05:17 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется вывести только неотрицательные числа.

Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных Требуется в одной строке через пробел вывести все неотрицательные числа в том же порядке, в каком они расположены во входном файле.

Dinochka8 22 янв. 2020 г., 19:04:03 | 5 - 9 классы

Дан массив a из n целых чисел?

Дан массив a из n целых чисел.

Требуется посчитать количество положительных элементов и количество отрицательных элементов.

Формат входных данных На первой строке входного файла записано натуральное число nn (n≤100)(n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа aiai (|ai|≤1000)(|ai|≤1000) — элементы массива aa.

Формат выходных данных Требуется через пробел вывести два числа — количество положительных и количество отрицательных элементов массива.

Примеры входные данные : 3 - 2 0 5 выходные данные 1 1.

VADIMIII18 8 мая 2020 г., 18:54:38 | 5 - 9 классы

Паскаль?

Паскаль.

Известно, что первые два элемента массива равны a и b.

А каждый следующий элемент равен сумме значений всех предыдущих элементов и собственного номера (нумерация элементов массива начинается с единицы).

Заполните массив из n элементов, используя этот принцип и выведите значения элементов массива в обратном порядке.

Формат входных данных Целые положительное число n (2 Целые числа a, b ( - 50 < ; a, b < ; 50) Формат выходных данных Строка, содержащая элементы искомого массива в обратном порядке, записанные через пробел.

IRINASTRELZ 27 нояб. 2020 г., 01:23:12 | 5 - 9 классы

PascalABC1)Дан массив целых чисел, состоящий из 8 элементов?

PascalABC

1)Дан массив целых чисел, состоящий из 8 элементов.

Заполнить его с клавиатуры.

Найти сумму элементов, имеющий нечётный индекс.

2)Сформировать одномерные массив из N элементов, где элементы массива - целые случайные числа.

Вывести индексы тех элементов, значение которых больше заданного числа A (A вводить с клавиатуры).

3)Определите, есть ли в данном массиве положительные элементы, кратные k (k вводить с клавиатуры).

IldarAWM 2 дек. 2020 г., 16:47:58 | 5 - 9 классы

Помогите пожалуйста с информатикой?

Помогите пожалуйста с информатикой!

Массивы На паскале.

Даю 50 баллов Дан массив целых чисел, состоящий из 20 элементов.

Заполнить его с клавиатуры.

Найти : •вывести индексы тех элементов, значения которых больше заданного числа А ; •определить, есть ли в данном массиве положительные элементы, кратные k (k вводить с клавиатуры).

На этой странице сайта, в категории Информатика размещен ответ на вопрос Дан массив из n элементов?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.