С клавиатуры вводится строка str, а также символ для подсчета определить количество этих символов во введенной строке?

Информатика | 5 - 9 классы

С клавиатуры вводится строка str, а также символ для подсчета определить количество этих символов во введенной строке.

Ответить на вопрос
Ответы (1)
Eangela009 5 апр. 2020 г., 15:26:51

/ / Dev - C + + 5.

11 (C)

#include < ; stdio.

H> ;

#include < ; string.

H> ;

int main(void)

{char str[256], c ;

int k = 0 ;

scanf("%s %c", & ; str, & ; c) ;

for(int i = 0 ; i< ; strlen(str) ; i + + ) if(str[i] = = c)k + + ;

printf("%d", k) ;

return 0 ; }

Пример ввода :

camerata a

Пример вывода :

3.

Hazeevar79 20 дек. 2020 г., 12:41:51 | 10 - 11 классы

С клавиатуры вводится строка?

С клавиатуры вводится строка.

С новой строки вводится буква.

Составьте программу подсчета количества заданных букв в заданной строке.

Определить, является ли длина введенного слова числом, кратным трем.

Определить, заканчивается ли введенное слово гласной буквой.

Сфавыпрвна 22 мар. 2020 г., 01:30:27 | 10 - 11 классы

ВпрограммеC + + ?

ВпрограммеC + + .

Ввести массив символов разделителей с заданным количеством символов, число и массив строк текста, содержащий неизвестное заранее количество строк.

Последней строкой текста будет строка, после ввода которой количество одинаковых слов в тексте превысит заданное в исходных данных число.

Из строк введенного текста сформировать другой текст, в котором строки будут располагаться в порядке увеличения количества символов разделителей с одновременным удалением строк, в которых было повторение любого символа разделителя.

89129627357 12 апр. 2020 г., 07:10:10 | 10 - 11 классы

Составить программу для ввода строки символов с клавиатуры в буфер и вывод этой строки на экран?

Составить программу для ввода строки символов с клавиатуры в буфер и вывод этой строки на экран.

ПНПУКН55444 8 авг. 2020 г., 11:51:31 | 10 - 11 классы

С клавиатуру вводится строка?

С клавиатуру вводится строка.

Определить в ней количество пробелов.

Анастасия9815 25 сент. 2020 г., 06:41:48 | 10 - 11 классы

5. 1 Ввести с клавиатуры строку символов?

5. 1 Ввести с клавиатуры строку символов.

Признак окончания ввода строки – нажатие клавиши "Ввод".

Программа должна определить длину введенной строки L, и, если длина L > ; 6, то выделяется подстрока в { } скобках.

5. 2 Дана строка.

Подсчитать количество букв k в последнем его слове.

Prostmasha2014 21 нояб. 2020 г., 04:28:36 | 5 - 9 классы

Ввести строку с клавиатуры ввести символ с клавиатуры используя оператора ввода задать некоторую строку содержашая 15 - 25 символов определить длину строки вывести на экран сам символ и позицую в като?

Ввести строку с клавиатуры ввести символ с клавиатуры используя оператора ввода задать некоторую строку содержашая 15 - 25 символов определить длину строки вывести на экран сам символ и позицую в каторой он найден (также надо задать любое четверостишие это оченка 5).

Lerkabelka2004 2 авг. 2020 г., 19:24:27 | 1 - 4 классы

Известно количество символов в каждой строке, количество строк на странице?

Известно количество символов в каждой строке, количество строк на странице.

Написать программу, считывающую эти значения с клавиатуры и вычисляющую число символов на странице.

13Vlad 19 янв. 2020 г., 12:29:54 | 5 - 9 классы

Во введенной строке подсчитайте количество символов " * " и символов "?

Во введенной строке подсчитайте количество символов " * " и символов "!

". Информатика.

Паскаль.

Строки.

GlebovichPolinka 22 дек. 2020 г., 15:42:26 | 10 - 11 классы

Pascal abc Написать программу, которая вводит с клавиатуры строку и выводит на экран символ, код которого в два раза больше, чем количество символов в исходной строке (использовать функции Length и ch?

Pascal abc Написать программу, которая вводит с клавиатуры строку и выводит на экран символ, код которого в два раза больше, чем количество символов в исходной строке (использовать функции Length и chr).

Лили0108 30 окт. 2020 г., 19:25:42 | 5 - 9 классы

1) с клавиатуры вводится строка символов состоящая из заменить все буквы в слов, последнем слове на восклицательные знаки 2)С клавиатуры вводится строка символов, удалить все символы стоящие между пер?

1) с клавиатуры вводится строка символов состоящая из заменить все буквы в слов, последнем слове на восклицательные знаки 2)С клавиатуры вводится строка символов, удалить все символы стоящие между первой и второй точкой запятой.

ПРИМЕР : abсxyz ; reо(xyz - удаляется.

На этой странице вы найдете ответ на вопрос С клавиатуры вводится строка str, а также символ для подсчета определить количество этих символов во введенной строке?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.