5. 1 Ввести с клавиатуры строку символов?

Информатика | 10 - 11 классы

5. 1 Ввести с клавиатуры строку символов.

Признак окончания ввода строки – нажатие клавиши "Ввод".

Программа должна определить длину введенной строки L, и, если длина L > ; 6, то выделяется подстрока в { } скобках.

5. 2 Дана строка.

Подсчитать количество букв k в последнем его слове.

Ответить на вопрос
Ответы (1)
Anara82muratov 25 сент. 2020 г., 06:41:54

Var

l, a, b : integer ;

s : string ;

begin

write('Введите строку : ') ;

readln(s) ;

l : = length(s) ;

writeln('L = ', l) ;

if l> ; 6 then begin a : = pos('(', s) ; b : = pos(')', s) ; if (a> ; 0) and (b> ; 0) then writeln(copy(s, a + 1, b - a - 1)) ; if (a = 0) and (b> ; 0) then writeln('Скобка не открыта') ; if (a> ; 0) and (b = 0) then writeln('Скобка не закрыта') ; if (a = 0) and (b = 0) then writeln('Текста в скобках нет') ; end ;

end.

Var

n, i, k : integer ;

s, t : string ;

begin

write('Введите строку : ') ;

readln(s) ;

t : = s ;

repeat i : = pos(' ', t) ; delete(t, 1, i) ; until i = 0 ;

k : = length(t) ;

for i : = 1 to k do if t[i] = 'k' then n : = n + 1 ;

writeln('Кол - во букв k : ', n) ;

end.

Hazeevar79 20 дек. 2020 г., 12:41:51 | 10 - 11 классы

С клавиатуры вводится строка?

С клавиатуры вводится строка.

С новой строки вводится буква.

Составьте программу подсчета количества заданных букв в заданной строке.

Определить, является ли длина введенного слова числом, кратным трем.

Определить, заканчивается ли введенное слово гласной буквой.

Rudywade 13 янв. 2020 г., 14:58:31 | 10 - 11 классы

Заданы М строк слов, которые вводятся с клавиатуры?

Заданы М строк слов, которые вводятся с клавиатуры.

Подсчитать количество гласных букв в каждой из заданных строк.

89129627357 12 апр. 2020 г., 07:10:10 | 10 - 11 классы

Составить программу для ввода строки символов с клавиатуры в буфер и вывод этой строки на экран?

Составить программу для ввода строки символов с клавиатуры в буфер и вывод этой строки на экран.

ПНПУКН55444 8 авг. 2020 г., 11:51:31 | 10 - 11 классы

С клавиатуру вводится строка?

С клавиатуру вводится строка.

Определить в ней количество пробелов.

Еваника 10 мар. 2020 г., 08:55:01 | 5 - 9 классы

С клавиатуры вводится строка состоящая из букв, знака пробела и циифр?

С клавиатуры вводится строка состоящая из букв, знака пробела и циифр.

Определите количество цифр в этой строке.

Prostmasha2014 21 нояб. 2020 г., 04:28:36 | 5 - 9 классы

Ввести строку с клавиатуры ввести символ с клавиатуры используя оператора ввода задать некоторую строку содержашая 15 - 25 символов определить длину строки вывести на экран сам символ и позицую в като?

Ввести строку с клавиатуры ввести символ с клавиатуры используя оператора ввода задать некоторую строку содержашая 15 - 25 символов определить длину строки вывести на экран сам символ и позицую в каторой он найден (также надо задать любое четверостишие это оченка 5).

13Vlad 19 янв. 2020 г., 12:29:54 | 5 - 9 классы

Во введенной строке подсчитайте количество символов " * " и символов "?

Во введенной строке подсчитайте количество символов " * " и символов "!

". Информатика.

Паскаль.

Строки.

Здлдк 5 янв. 2020 г., 11:00:34 | 5 - 9 классы

Ввести строку символов определить и вывести на экран ее длину?

Ввести строку символов определить и вывести на экран ее длину.

Вывести на экран первый и последний символ этой строки.

Мазоха 5 апр. 2020 г., 15:26:49 | 5 - 9 классы

С клавиатуры вводится строка str, а также символ для подсчета определить количество этих символов во введенной строке?

С клавиатуры вводится строка str, а также символ для подсчета определить количество этих символов во введенной строке.

Непонятно 6 дек. 2020 г., 01:10:08 | 10 - 11 классы

Программа вводит две строки?

Программа вводит две строки.

Из более длинной строки программа выводит все символы, коды которых > ; 70.

В короткой строке заменяет все «!

» знаки на « * » и выводит короткую строку на экран.

На этой странице сайта вы найдете ответы на вопрос 5. 1 Ввести с клавиатуры строку символов?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.