1) с клавиатуры вводится строка символов состоящая из заменить все буквы в слов, последнем слове на восклицательные знаки 2)С клавиатуры вводится строка символов, удалить все символы стоящие между пер?

Информатика | 5 - 9 классы

1) с клавиатуры вводится строка символов состоящая из заменить все буквы в слов, последнем слове на восклицательные знаки 2)С клавиатуры вводится строка символов, удалить все символы стоящие между первой и второй точкой запятой.

ПРИМЕР : abсxyz ; reо(xyz - удаляется.

Ответить на вопрос
Ответы (1)
Marusochka 30 окт. 2020 г., 19:25:44

1)

(Слова разделяются одним пробелом)

var s : string ;

l, i : integer ;

begin

writeln('Введите строку : ') ;

readln(s) ;

l : = length(s) ;

i : = l ;

while s[i]< ; > ; ' ' do

begin

s[i] : = '!

' ;

i : = i - 1 ;

end ;

writeln(s) ;

end.

Пример : Введите строку :

с клавиатуры вводится строка символов

с клавиатуры вводится строка !

2)

var s1, s2 : string ;

p, i : integer ;

begin

writeln('Введите строку : ') ;

readln(s1) ;

p : = pos(' ; ', s1) ;

s2 : = copy(s1, 1, p) ;

i : = p + 1 ;

while s1[i]< ; > ; ' ; ' do i : = i + 1 ;

s2 : = s2 + copy(s1, i, length(s1) - i + 1) ;

writeln(s2) ;

end.

Введите строку :

abс ; xyz ; reо

abс ; ; reо.

Rybyska 12 мар. 2020 г., 10:21:47 | 5 - 9 классы

1. С клавиатуры вводят слово и символ?

1. С клавиатуры вводят слово и символ.

Составьте программу , которая определяет позицию данного символа.

89129627357 12 апр. 2020 г., 07:10:10 | 10 - 11 классы

Составить программу для ввода строки символов с клавиатуры в буфер и вывод этой строки на экран?

Составить программу для ввода строки символов с клавиатуры в буфер и вывод этой строки на экран.

Zarina97zaza 20 апр. 2020 г., 18:38:56 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составьте программу, которая : проверяет, есть ли в этом слове заданный символ.

Ketymailcom 14 июн. 2020 г., 00:15:58 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составьте программу, которая определяет позицию заданного символа.

Еваника 10 мар. 2020 г., 08:55:01 | 5 - 9 классы

С клавиатуры вводится строка состоящая из букв, знака пробела и циифр?

С клавиатуры вводится строка состоящая из букв, знака пробела и циифр.

Определите количество цифр в этой строке.

GIRL99love 5 мая 2020 г., 20:10:13 | 10 - 11 классы

С клавиатуры вводят слово и символ?

С клавиатуры вводят слово и символ.

Составте программу которая : подсчитывает количество вхождений заданного символа.

Prostmasha2014 21 нояб. 2020 г., 04:28:36 | 5 - 9 классы

Ввести строку с клавиатуры ввести символ с клавиатуры используя оператора ввода задать некоторую строку содержашая 15 - 25 символов определить длину строки вывести на экран сам символ и позицую в като?

Ввести строку с клавиатуры ввести символ с клавиатуры используя оператора ввода задать некоторую строку содержашая 15 - 25 символов определить длину строки вывести на экран сам символ и позицую в каторой он найден (также надо задать любое четверостишие это оченка 5).

Dasdgffjj 4 апр. 2020 г., 20:51:39 | 5 - 9 классы

Помогите, прошу?

Помогите, прошу.

Составить программу, которая вводит с клавиатуры один символ и выводит на экран два символа стоящие до и после этого символа.

Gulzadab79 26 мар. 2020 г., 18:36:01 | 10 - 11 классы

Написать программу, которая удаляет из введенного слова любой введенный с клавиатуры символ?

Написать программу, которая удаляет из введенного слова любой введенный с клавиатуры символ.

Слово вводится в программе.

PascalABC.

Мазоха 5 апр. 2020 г., 15:26:49 | 5 - 9 классы

С клавиатуры вводится строка str, а также символ для подсчета определить количество этих символов во введенной строке?

С клавиатуры вводится строка str, а также символ для подсчета определить количество этих символов во введенной строке.

Вы перешли к вопросу 1) с клавиатуры вводится строка символов состоящая из заменить все буквы в слов, последнем слове на восклицательные знаки 2)С клавиатуры вводится строка символов, удалить все символы стоящие между пер?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.