(50 баллов) Помогите, пожалуйста?

Информатика | 5 - 9 классы

(50 баллов) Помогите, пожалуйста!

Программа Паскаль : написать массив, который выводит все элементы с нулём.

Ответить на вопрос
Ответы (2)
Masa4 26 дек. 2020 г., 02:12:06

Const n = 10 ;

var a : array[1.

N] of integer ;

i : integer ; c : string ;

begin

Randomize ;

for i : = 1 to n do

begin

a[i] : = random(200) ;

write(a[i] : 5) ;

end ;

writeln ;

for i : = 1 to n do

begin

str(a[i], c) ;

if pos('0', c)> ; 0 then write(a[i] : 5) ;

end ;

writeln ;

end.

Пример : 110 43 38 35 103 44 35 192 86 199 110 103.

Dianka927 26 дек. 2020 г., 02:12:08

А еще можно вот так.

/ / PascalABC.

NET 3.

1, сборка 1200 от 13.

03. 2016

begin var a : = ArrRandom(ReadInteger('n = '), 100, 999) ; a.

Println ; a.

Where(x - > ; (x.

ToString.

IndexOf('0')> ; 0)).

Println ;

end.

Тестовое решение :

n = 16

959 277 138 801 580 575 785 986 679 544 762 852 614 460 955 411

801 580 460

И даже можно решить одним - единственным "оператором" )))

begin ArrRandom(ReadInteger('n = '), 100, 999).

Println.

Where(x - > ; (x.

ToString.

IndexOf('0')> ; 0)).

Println ;

end.

Школа88 9 февр. 2020 г., 18:10:25 | 5 - 9 классы

Написать программу?

Написать программу.

Которая вводит массив из N целых чисел и выводит на экран элементы с чётными номерами.

Tu110380 2 апр. 2020 г., 21:14:42 | 10 - 11 классы

50 Баллов?

50 Баллов.

Пожалуйста.

В Паскаль.

Написать программу, которая вводит массив из N целых чисел и выводит на экран сам массив и сумму всех его элементов.

Galinababenko 9 окт. 2020 г., 06:25:18 | 10 - 11 классы

Написать программу на паскале?

Написать программу на паскале.

Создать двухмерный массив из целых чисел, в котором поменять местами максимальный и минимальный элементы.

Помогите пж.

Galievadianka 5 янв. 2020 г., 02:03:12 | 5 - 9 классы

Написать программу, которая вводит массив из N целых чисел и выводит на экран номера отрицательных элементов и сами эти элементы?

Написать программу, которая вводит массив из N целых чисел и выводит на экран номера отрицательных элементов и сами эти элементы.

ПОМОГИТЕ ПОЖАЛУЙСТА!

Спасибо.

Botya1974 10 мая 2020 г., 02:40:54 | 5 - 9 классы

Напишите на ^ Паскале программу, которая запрашивает с клавиатуры массив из N чисел, а затем выводит среднее арифметическое всех элементов массива?

Напишите на ^ Паскале программу, которая запрашивает с клавиатуры массив из N чисел, а затем выводит среднее арифметическое всех элементов массива.

Matveypomoz 20 мар. 2020 г., 15:38:56 | 10 - 11 классы

Помогите оставить программу в Паскале : Дан одномерный массив заменить все чётные элементы массива нулём?

Помогите оставить программу в Паскале : Дан одномерный массив заменить все чётные элементы массива нулём.

Заразалина 31 дек. 2020 г., 10:12:24 | 5 - 9 классы

Пожалуйста, помогтме решить задачи на Pasсal?

Пожалуйста, помогтме решить задачи на Pasсal.

Во всех задачах массив состоит из 10 элементов и задаётся из интервала от 1 до 99.

1. Написать программу, которая выводит на экран все четные элементы массива и их количество.

2. Написать программу, которая выводит на экран все двузначные элементы массива и их количество.

3. Написать программу, которая выводит на экран сначала все четные элементы, а потом нечетные (по индексу).

. Написать программу, которая выводит на экран сначала все четные элементы, а потом нечетные (по значению).

5. Написать программу, которая выводит на экран количество элементов оканчивающихся на 5.

Butusovke 13 дек. 2020 г., 10:23:28 | 5 - 9 классы

Паскаль?

Паскаль.

Написать программу, которая выводит на экран количество чисел Х в массиве.

В массиве N элементов, числа целые.

Х задаётся.

Помогите))).

Iri4241 22 авг. 2020 г., 20:03:43 | 10 - 11 классы

Помогите решить на паскале?

Помогите решить на паскале.

Дан массив, в котором 10 элементов, составить программу для вывода его элемента массива по его индексу.

Dalibovsaid 28 окт. 2020 г., 22:24:00 | 10 - 11 классы

Как на паскале abc net написать программу которая выводит на экран текст несколько раз?

Как на паскале abc net написать программу которая выводит на экран текст несколько раз.

Вы перешли к вопросу (50 баллов) Помогите, пожалуйста?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.